Unable to change output scale in Sway

My output scale appears to default to 1.5 regardless of my configurations or manual commands. I have attempted to identify a possible cause for this issue, but lack the expertise to solve it.


Upon installation, I’ve noticed that the scale appears unusually blown up.

    ~  swaymsg -t get_outputs                                                                                                                                                     ✔  3s  
Output eDP-1 'Chimei Innolux Corporation 0x1614 Unknown' (focused)
  Current mode: 1920x1200 @ 60.003 Hz
  Position: 0,0
  Scale factor: 1.500000
  Scale filter: linear
  Subpixel hinting: unknown
  Transform: normal
  Workspace: 1:  
  Max render time: off
  Adaptive sync: enabled
  Available modes:
    1920x1200 @ 60.003 Hz

I attempted to amend ~/.config/sway/config with the line output eDP-1 scale 1. Neither rebooting nor swaymsg reload reflected the change, and the output to swaymsg -t get_outputs still displayed the scale as 1.5.

Next, I tried to change it manually by attempting variations of the line below with different integers, non-integers, and output arguments.

swaymsg output eDP-1 scale 1

The scale does not change and every attempt to run swaymsg -t get_outputs returns the scale as 1.5 afterwards. However, the screen briefly flickers and on occasion Firefox will crash, leading me to believe that the command does run successfully but then defaults to 1.5 immediately after.


I should mention that I am unable to run swaymsg via sudo, but don’t know whether this is a contributing factor.

   ~  sudo swaymsg -t get_inputs                                                                                                                                                        ✔ 
[sudo] password for iris: 
00:00:00.022 [swaymsg/main.c:491] Unable to retrieve socket path

I’ve looked into this but it hasn’t yielded anything of value.

Also, when attempting to boot Manjaro with proprietary drivers when installing, the process stalls partway. I don’t have logs on hand, but if this seems relevant, I’m willing to provide them.

Thank you in advance for the support.

Hello @cultofmetamorphosis :wink:

All I can say that the commands and configurations work on my side. I am also using swaywm. If it keeps to be scaling at 1.5 , then I bet you have set it somewhere and forgot about it.

Swaywm is running as the current user. So it is totally normal that root has no access.

Yeah alright “proprietary drivers”. You mean nvidia then. It is officially not supported as I know and need special tweaks.

If nvidia is the only choice you have, then I would advice to forget about sway.

Hi. I appreciate the prompt response.

I’ll look into this, but it seems unlikely considering I’ve only completed a fresh installation.

I suspected this might be the case. Thanks for letting me know.

My laptop uses both Nvidia and Intel. I used the term proprietary drivers since that’s what the Manjaro installation screen used. I’m currently using open source drivers instead.

Thanks again for the assistance.

Apparently one of the definitions set in etc/sway/definitions allows the user to adjust scaling using the following commands:

# scaling
set $scale_up /usr/share/sway/scripts/scale.sh up
set $scale_down /usr/share/sway/scripts/scale.sh down

I’m still not sure whether this is what restricted manual changes to the scaling, but it works well enough for this to not be a concern. The increment can also be changed in /usr/share/sway/scripts/scale.sh; I’ve personally found that an increment of 0.25 is not sufficiently precise.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.

What would be a sufficiently precise one? I didn’t put much thought into it when I chose it.