Unable to build iso with buildiso

Hi everyone.

I’m in the process of making my own spin of manjaro.

I’m using manjaro tools to do so.

When i try to build an iso file with buildiso, I get the following error:

cp: cannot stat ‘/var/lib/manjaro-tools/buildiso/kde/x86_64/livefs/usr/share/grub/cfg/*.cfg’: No such file or directory

I checked and saw that there is no files matching:


The directory does exist, but there is no .cfg files, how come there is no .cfg files?

Do i have to create the .cfg files myself?

? Could be you have not restarted your system after an update - all sorts of weird errors can be traced back to a missing restart.

Maybe you’re on to something, tried rebooting, it couldn’t boot again. I’m building on a virtual machine, because i don’t currently have a machine running Manjaro.

Would it be possible to install manjaro-tools-iso on arch linux?

I don’t think it will work - not that I tried.

There is no problem in building in a VM.

Try installing the -git packages

  • manjaro-tools-yaml-git
  • manjaro-tools-iso-git
  • manjaro-tools-base-git

If your building packages as well install

  • manjaro-tools-pkg-git


If you are using a default VBox install - this may create issues as the tools only works with EFI systems. At least I think so - I have not tested.

You will have to reinstall your Virtual Machine and set the system to use EFI boot.

I just tried again with and without git packages on an EFI VM, neither worked.

If it helps the error occurs in make_grub()

I am not sure about building within a VBox install but, you can build on bare metal installs that are MBR (in my experience, on my system at least)

I also use the *-git versions as well.

Are you hitting this error consistently? I have found that sometimes it just takes a couple tries (often times a reboot helps). I haven’t built KDE, so this general advice may not apply.

It seems I’ve found the problem, i tried adding some packages back, that i had removed and the error stopped

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.