Unable to build android-apktool

Whenever i try to update the android-apktool package using pamac, it gives me the same error.

Building android-apktool...
==> Making package: android-apktool 2.9.0-1 (Saturday 18 November 2023 08:44:53 AM)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Downloading android-apktool-2.9.0.tar.gz...
** Resuming transfer from byte position 1084959
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed

  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0

  0     0    0     0    0     0      0      0 --:--:--  0:00:01 --:--:--     0
curl: (33) HTTP server doesn't seem to support byte ranges. Cannot resume.
==> ERROR: Failure while downloading https://github.com/iBotPeaches/Apktool/archive/refs/tags/v2.9.0.tar.gz
Failed to build android-apktool

How do i proceed?

Download did not complete - and cannot be restarted from where it was interrupted.
Try again and hope for a stable connection? :man_shrugging:

I doubt it has anything to do with internet connection because this is the only package that gives out an error and it has been so for a week or so now.

I just downloaded the file, using wget.

size ~ 35MB

wget https://github.com/iBotPeaches/Apktool/archive/refs/tags/v2.9.0.tar.gz

Works fine.

There is a .bin version of the program in AUR - no need to compile it yourself, I think.
(link goes directly to the AUR with the query already in)

AUR (en) - Packages

Im pretty new to this, how do i make sure it gets downloaded to /usr/bin? should i just sudo mv it?

Empty the Pamac build directory via Pamac > Preferences > Third Party > Build Directory > Clean & then try building the package again. You currently have a partially downloaded file in the build directory that cannot be resumed by Pamac, so the best thing to do is empty the build directory & have Pamac download the file again. It may not have been able to resume the download if the original file on the server has changed since the partial file was downloaded.

This worked. Thanks!

1 Like

Wrong approach - don’t even try to do that. Not necessary and you will likely mess up your system in short order.
The AUR helpers handle that.
You could try using a different one (yay, for example).

1 Like

Alright, will do next time.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.