Unable to boot with any kernels following update: No working init found

I updated my system and forgot to reboot to see if there were any issues. Returning to my laptop after the weekend, I was unable to boot into any of my kernels (5.10, 5.15, 6.1) with any of the options available in grub. I always end up with an error related to my init file. A transcription of my error message is as follows:

Failed to execute /init (error -2)
Kernel panic - not syncing: No working init found. Try passing init= option to kernel. See Linux Documentation/admin-guide/init.rst for guidance. 
Hardware name: TUXEDO TUXEDO Aura 15 Gen1/NL5xRU, BIOS 1.07.08TTR3 03/18/2021
Call Trace:
 ? rest_init+0x90/0xd0
 ? rest_init+0xd0/0xd0
Kernel Offset: 0x3800000 from 0xffffffff81000000 (relocation range: 0xffffffff80000000-0xffffffffbfffffff)
---[ end Kernel panic - not syncing: No working init found. Try passing init= option to kernel. See Linux Documentation/admin-guide/init.rst for guidance.]

I’m able to chroot into my system from a live usb. I’ve reinstalled the kernels, I’ve manually rerun mkinitcpio successfully for multiple kernels, and reinstalled the filesystem package, none of it has changed anything about this error screen. I’ve also refreshed my mirrors and attempted a full system upgrade.

I know that what I’m doing is having an effect because I started out without the 6.1 kernel, I added that through the chroot and it shows up successfully in grub now.

I can’t seem to find anyone else with this error. What else can I do to fix this?

Out of space?

In whatever case if you can get a chroot then start with

inxi -Fazy

According to df, I’m good on space. my highest usage filesystem is efivarfs which is only 62% used. My output from inxi -Fazy is

  12Kernel 6.6.8-2-MANJARO 12arch x86_64 12bits 64 12compiler gcc 12v 13.2.1
    12clocksource hpet 12available acpi_pm 12parameters BOOT_IMAGE=/boot/vmlinuz-x86_64
    lang=en_US keytable=us tz=UTC misobasedir=manjaro
    misolabel=MANJARO_KDE_2312 quiet systemd.show_status=1 splash driver=free
    nouveau.modeset=1 i915.modeset=1 radeon.modeset=1
  12Desktop KDE Plasma 12v ERR-101 12tk Qt 12v 5.15.11 12wm kwin_x11 12dm N/A
    12Distro Manjaro Linux 12base Arch Linux
  12Type Laptop 12System TUXEDO 12product TUXEDO Aura 15 Gen1 12v N/A 12serial N/A
    12Chassis 12type 10 12serial N/A
  12Mobo NB01 12model NL5xRU 12serial N/A 12UEFI INSYDE 12v 1.07.08TTR3 12date 03/18/2021
  12ID-1 BAT0 12charge 35.6 Wh (100.0%) 12condition 35.6/48.3 Wh (73.7%) 12volts 16.4
    12min 15.2 12model Notebook BAT 12type Li-ion 12serial <filter> 12status full
  12Info 12model AMD Ryzen 7 4700U with Radeon Graphics 12socket FP6 12bits 64 12type MCP
    12arch Zen 2 12gen 3 12level v3 12note check 12built 2020-22 12process TSMC n7 (7nm)
    12family 0x17 (23) 12model-id 0x60 (96) 12stepping 1 12microcode 0x8600106
  12Topology 12cpus 1x 12cores 8 12smt <unsupported> 12cache 12L1 512 KiB
    12desc d-8x32 KiB; i-8x32 KiB 12L2 4 MiB 12desc 8x512 KiB 12L3 8 MiB 12desc 2x4 MiB
  12Speed (MHz) 12avg 1475 12high 2000 12min/max 1400/2000 12boost enabled
    12base/boost 2000/4200 12scaling 12driver acpi-cpufreq 12governor schedutil
    12volts 1.2 V 12ext-clock 100 MHz 12cores 121 2000 122 1400 123 1400 124 1400 125 1400
    126 1400 127 1400 128 1400 12bogomips 31949
  12Flags avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  12Type gather_data_sampling 12status Not affected
  12Type itlb_multihit 12status Not affected
  12Type l1tf 12status Not affected
  12Type mds 12status Not affected
  12Type meltdown 12status Not affected
  12Type mmio_stale_data 12status Not affected
  12Type retbleed 12mitigation untrained return thunk; SMT disabled
  12Type spec_rstack_overflow 12mitigation SMT disabled
  12Type spec_store_bypass 12mitigation Speculative Store Bypass disabled via
  12Type spectre_v1 12mitigation usercopy/swapgs barriers and __user pointer
  12Type spectre_v2 12mitigation Retpolines, IBPB: conditional, STIBP: disabled,
    RSB filling, PBRSB-eIBRS: Not affected
  12Type srbds 12status Not affected
  12Type tsx_async_abort 12status Not affected
  12Device-1 AMD Renoir [Radeon RX Vega 6 ] 12vendor CLEVO/KAPOK 12driver amdgpu
    12v kernel 12arch GCN-5 12code Vega 12process GF 14nm 12built 2017-20 12pcie 12gen 4
    12speed 16 GT/s 12lanes 16 12ports 12active eDP-1 12empty DP-1,DP-2 12bus-ID 05:00.0
    12chip-ID 1002:1636 12class-ID 0300 12temp 42.0 C
  12Device-2 Bison BisonCam NB Pro 12driver uvcvideo 12type USB 12rev 2.0
    12speed 480 Mb/s 12lanes 1 12mode 2.0 12bus-ID 3-4:3 12chip-ID 5986:9102 12class-ID 0e02
  12Display 12server X.org 12v 12compositor kwin_x11 12driver 12X 12loaded amdgpu
    12unloaded modesetting 12alternate fbdev,vesa 12dri radeonsi 12gpu amdgpu
    12display-ID :0
  12Monitor-1 eDP-1 12model ChiMei InnoLux 0x15e8 12built 2018 12res 1920x1080
    12dpi 142 12gamma 1.2 12size 344x193mm (13.54x7.6") 12diag 394mm (15.5") 12ratio 16:9
    12modes 12max 1920x1080 12min 640x480
  12API EGL 12v 1.5 12hw 12drv amd radeonsi 12platforms 12device 0 12drv radeonsi 12device 1
    12drv swrast 12surfaceless 12drv radeonsi 12inactive gbm,wayland,x11
  12API OpenGL 12v 4.6 12compat-v 4.5 12vendor mesa 12v 23.1.9-manjaro1.1
    12note incomplete (EGL sourced) 12renderer AMD Radeon Graphics (renoir LLVM
    16.0.6 DRM 3.54 6.6.8-2-MANJARO), llvmpipe (LLVM 16.0.6 256 bits)
  12API Vulkan 12Message No Vulkan data available.
  12Device-1 AMD Renoir Radeon High Definition Audio 12vendor CLEVO/KAPOK
    12driver snd_hda_intel 12v kernel 12pcie 12gen 4 12speed 16 GT/s 12lanes 16
    12bus-ID 05:00.1 12chip-ID 1002:1637 12class-ID 0403
  12Device-2 AMD ACP/ACP3X/ACP6x Audio Coprocessor 12vendor CLEVO/KAPOK
    12driver N/A 12pcie 12gen 4 12speed 16 GT/s 12lanes 16 12bus-ID 05:00.5 12chip-ID 1022:15e2
    12class-ID 0480
  12Device-3 AMD Family 17h/19h HD Audio 12vendor CLEVO/KAPOK
    12driver snd_hda_intel 12v kernel 12pcie 12gen 4 12speed 16 GT/s 12lanes 16
    12bus-ID 05:00.6 12chip-ID 1022:15e3 12class-ID 0403
  12API ALSA 12v k6.6.8-2-MANJARO 12status kernel-api 12with aoss 12type oss-emulator
    12tools alsactl,alsamixer,amixer
  12Server-1 PipeWire 12v 1.0.0 12status n/a (root, process) 12with 121 pipewire-pulse
    12status active 122 pipewire-media-session 12status off 123 pipewire-alsa 12type plugin
    124 pw-jack 12type plugin 12tools pactl,pw-cat,pw-cli
  12Device-1 Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    12vendor CLEVO/KAPOK 12driver r8169 12v kernel 12pcie 12gen 1 12speed 2.5 GT/s 12lanes 1
    12port 2000 12bus-ID 02:00.0 12chip-ID 10ec:8168 12class-ID 0200
  12IF enp2s0 12state up 12speed 1000 Mbps 12duplex full 12mac <filter>
  12Device-2 Intel Wi-Fi 6 AX200 12driver iwlwifi 12v kernel 12pcie 12gen 2
    12speed 5 GT/s 12lanes 1 12bus-ID 03:00.0 12chip-ID 8086:2723 12class-ID 0280
  12IF wlo1 12state down 12mac <filter>
  12Device-1 Intel AX200 Bluetooth 12driver btusb 12v 0.8 12type USB 12rev 2.0
    12speed 12 Mb/s 12lanes 1 12mode 1.1 12bus-ID 3-3:2 12chip-ID 8087:0029 12class-ID e001
  12Report rfkill 12ID hci0 12rfk-id 0 12state up 12address see --recommends
  12Local Storage 12total 494.67 GiB 12used 124.28 GiB (25.1%)
  12ID-1 /dev/nvme0n1 12maj-min 259:0 12vendor Kingston 12model SNVS500G
    12size 465.76 GiB 12block-size 12physical 512 B 12logical 512 B 12speed 31.6 Gb/s
    12lanes 4 12tech SSD 12serial <filter> 12fw-rev S8H40104 12temp 28.9 C
  12SMART yes 12health PASSED 12on 148d 2h 12cycles 1,644
    12read-units 9,299,358 [4.76 TB] 12written-units 6,309,151 [3.23 TB]
  12ID-2 /dev/sda 12maj-min 8:0 12vendor Memorex 12model USB Flash Drive
    12size 28.91 GiB 12block-size 12physical 512 B 12logical 512 B 12type USB 12rev 2.1
    12spd 480 Mb/s 12lanes 1 12mode 2.0 12tech SSD 12serial <filter> 12fw-rev PMAP
  12SMART Message Unknown USB bridge. Flash drive/Unsupported enclosure?
  12ID-1 / 12raw-size 457.26 GiB 12size 449.01 GiB (98.20%) 12used 124.16 GiB (27.7%)
    12fs ext4 12block-size 4096 B 12dev /dev/nvme0n1p2 12maj-min 259:2
  12ID-2 /boot 12raw-size 512 MiB 12size 511 MiB (99.80%) 12used 120.9 MiB (23.7%)
    12fs vfat 12block-size 512 B 12dev /dev/nvme0n1p1 12maj-min 259:1
  12Alert No swap data was found.
  12System Temperatures 12cpu 55.8 C 12mobo N/A 12gpu amdgpu 12temp 42.0 C
  12Fan Speeds (rpm) N/A
  12Processes 276 12Uptime 1m 12wakeups 0 12Memory 12total 16 GiB 12note est.
  12available 15 GiB 12used 1.7 GiB (11.3%) 12Init systemd 12v 254 12default graphical
  12tool systemctl 12Compilers 12gcc 13.2.1 12clang 16.0.6 12Packages 12pm pacman 12pkgs 1945
  12libs 424 12tools pamac,yay 12pm flatpak 12pkgs 0 12Client Unknown Client: systemd
  12inxi 3.3.31

I’ve tried everything from the top results in the search linked by cscs. I’ve remade a initramfs file for each kernel and updated grub. I’m still having this issue. I’ve reinstalled each kernel several times now. I’m unsure whether mkinitcpio is generating faulty init files or if somehow there’s a disconnect between what’s in the files and what grub is looking at when it starts the system.

I really don’t know if it will, but perhaps this helps:


Unfortunately no, that didn’t help. It’s still not finding a working init file.

That’s good.

That uses an AMD cpu. Did you also try to re-install amd-ucode package?

Please list the contents of your boot partition, for example after chrooting and mounting /boot:

$ ls -l /boot

and the initrd lines of grub.cfg

$ grep initrd /boot/grub/grub.cfg

Last but not least:

I don’t know if it’s got anything todo with your current problem, but there should be a newer bios version downloadable from TUXEDO, I’ve got 1.07.11RTR2 on my machine.

Please list the contents of your boot partition, for example after chrooting and mounting /boot

[manjaro /]# ls -l /boot
total 192980
drwxr-xr-x 4 root root     4096 Jan 10 17:36  EFI
drwxr-xr-x 4 root root     4096 Feb  8  2022 'System Volume Information'
-rwxr-xr-x 1 root root    81920 Dec 11 10:32  amd-ucode.img
drwxr-xr-x 2 root root     4096 Jan 11 10:48  grub
-rwxr-xr-x 1 root root 36819903 Jan 11 10:47  initramfs-5.10-x86_64-fallback.img
-rwxr-xr-x 1 root root 12851932 Jan 11 10:47  initramfs-5.10-x86_64.img
-rwxr-xr-x 1 root root 42899769 Jan 11 10:47  initramfs-5.15-x86_64-fallback.img
-rwxr-xr-x 1 root root 13197312 Jan 11 10:47  initramfs-5.15-x86_64.img
-rwxr-xr-x 1 root root 44898264 Jan 11 10:48  initramfs-6.1-x86_64-fallback.img
-rwxr-xr-x 1 root root 14584751 Jan 11 10:47  initramfs-6.1-x86_64.img
-rwxr-xr-x 1 root root       23 Dec 21 06:14  linux510-x86_64.kver
-rwxr-xr-x 1 root root       23 Dec 24 00:47  linux515-x86_64.kver
-rwxr-xr-x 1 root root       21 Dec 21 06:14  linux61-x86_64.kver
-rwxr-xr-x 1 root root  9794240 Jan 11 10:47  vmlinuz-5.10-x86_64
-rwxr-xr-x 1 root root 10833344 Jan 10 20:31  vmlinuz-5.15-x86_64
-rwxr-xr-x 1 root root 11611456 Jan 11 09:54  vmlinuz-6.1-x86_64

and the initrd lines of grub.cfg

[manjaro /]# grep initrd /boot/grub/grub.cfg
        initrd  /initramfs-6.1-x86_64.img
                initrd  /initramfs-6.1-x86_64.img
                initrd  /initramfs-6.1-x86_64-fallback.img
                initrd  /initramfs-6.1-x86_64-fallback.img
                initrd  /initramfs-5.15-x86_64.img
                initrd  /initramfs-5.15-x86_64-fallback.img
                initrd  /initramfs-5.15-x86_64-fallback.img
                initrd  /initramfs-5.10-x86_64.img
                initrd  /initramfs-5.10-x86_64-fallback.img
                initrd  /initramfs-5.1

Reinstalling amd-ucode did not fix it.

The output lines of:

grep initrd /boot/grub/grub.cfg

should pretty much all look like this instead:

initrd /boot/amd-ucode.img /boot/initramfs-6.1-x86_64.img

because that is where all the initrd’s really are.

The initrd lines are somehow all missing the amd-ucode.img, the should look like this:

# grep initrd /boot/grub/grub.cfg
        initrd  /amd-ucode.img /initramfs-6.6-x86_64.img

Try running:

# update-grub

and check again. If it’s still not picked up, try editing at least one entry manually and see if this achieves successful boot.

edit: it just occured to me: did you run update-grub from some non-arch/manjaro distro? That could be the reason for the missing amd-ucode.img.
The last entry sure looks foreign to manjaro:

I’ve only used a manjaro live USB to do anything here. I updated grub and now this is the output for the relevant lines of grub.cfg

[manjaro /]# grep initrd /boot/grub/grub.cfg
        initrd  /amd-ucode.img /initramfs-6.1-x86_64.img
                initrd  /amd-ucode.img /initramfs-6.1-x86_64.img
                initrd  /initramfs-6.1-x86_64-fallback.img
                initrd  /initramfs-6.1-x86_64-fallback.img
                initrd  /amd-ucode.img /initramfs-5.15-x86_64.img
                initrd  /initramfs-5.15-x86_64-fallback.img
                initrd  /initramfs-5.15-x86_64-fallback.img
                initrd  /amd-ucode.img /initramfs-5.10-x86_64.img
                initrd  /initramfs-5.10-x86_64-fallback.img
                initrd  /initramfs-5.10-x86_64-fallback.img

I still get the same kernel panic error on reboot

Then the question is perhaps:
How did you chroot?
because, clearly, all the initrd’s are in /boot
not just below /

The PATHs, for example this:
initrd /initramfs-6.1-x86_64.img
should look like:
initrd /boot/initramfs-6.1-x86_64.img

I’m booting into the live USB from UEFI and using manjaro-chroot -a which auto mounts my laptop’s hard drive to /mnt. Should I be manually going in and altering those PATHs? Or is your comment more to indicate what’s going wrong in the init generation?

IMO - and kind of confirmed by things not working as they should - the paths in
are incorrect.

You can generate the file with:
grub-mkconfig -o /boot/grub/grub.cfg

Try that and see whether there is a difference in the generated file?
grep initrd /boot/grub/grub.cfg

This depends on whether one has a separate partition mounted to /boot. I have on my machine and all my entries look like

initrd  /amd-ucode.img /initramfs-6.6-x86_64.img

… and you do have a separate /boot , right?

I have and OP seems to have one as well mount their EFI partition directly to /boot:

I can’t contribute anything but more confusion and am therefore out.

I reran mkinitcpio now that the initrd lines are changed in the grub config, but I still get told that I have no working init. What else might be causing this?

hm :question:
now I’m even more confused.

Did you change /etc/mkinitcpio.conf?
Perhaps while merging .pacnew files …
sudo mkinitcpio -P
should re-create all of them.

likely relates to what is inside the initrd - there usually is a busybox binary and /init is a link to it

With lsinitcpio -x ... you can extract an image and inspect its contents