Unable to boot to desktop after latest update

Still not fixed after latest unstable updates.

This is a bug within Manjaro. With Endeavour OS works fine.

Manjaro uses an overlay package for xorg-server with some patches, @Yochanan is the last packager.
Do you see the same problem when using Arch’s xorg-server and xorg-server-common package?

TigerVNC makes Xorg crash in Manjaro but not Arch. Please fix bug.

TigerVNC developer has acknowledged the issue is on your side and nobody help in first thread.

So they conclude that Manjaro needs to rebuild tigervnc.

I didn’t know xorg was packaged by Manjaro - learned somthing new today.

I use tigervnc in several Manjaro instances I have never seen the issue you describe.

Are you sure you have configured tigervnc correct?

Although I am thinking it is not that hard to configure

So what are your usecase and how have you configured the service?

My preferred method to using SSH portwarding - so the login is not handled by the login manager but SSH - which IMO gives the best result as you don’t have to fiddle with the :0 display, no need to run as root but run as user and you get easy access e.g. using ssh keyfiles.

Well… did you try building it yourself?

1 Like

I’m not sure if miss-configuring tigervnc incorrectly makes xorg crash…

Now that I thnk of it - I am not sure tigervnc is that picky when it comes to xorg-server.

In fact I run tigervnc on a macbook m1 (arm architecture) - so while I will not reject the upstream conclusion - I am fairly certain it is local to your system.

I know for a fact that tigervnc works on Manjaro using vnc over ssh - you are making a statement, without any documentation of usecase, setup or configurations.

So please post your vnc related configurations - let’s see what can be deducted.

Neither am I - perhaps it is not tigervnc but your graphics configuration.

I took a look at the topic you refer to is an encrypted installation and from a quick glance it has nothing to do with tigervnc but is has a lot to with your gpu driver and faffing around with that as you mention in comment #23.

In fact the first mention of tigervnc is comment #66.

So when I think you are having a configuration issue I may be more right you’d like to admit. The whole tigervnc blaming thing is merely a symptom of other issues you need to address first.

1 Like

I know also for a fact that tigervnc works over VNC directly on current Manjaro XFCE stable – at least its scraping variant (i.e., x0vncserver). I’m sharing the desktop of the small machine I’m currently running on to bigger systems over VNC – all is fine, no trouble to be had.

I would expect poster’s using the standalone server instead and has something in his session startup “interact poorly” with the X server.

As I said, build it yourself and test if it makes any difference.

Or if you trust me and my bob-the-builder skills you can test this one (forgot to increment pkgrel :man_shrugging:):

wget https://transfer.sh/W0Ykrz/tigervnc-1.12.0-3-x86_64.pkg.tar.zst
1 Like

That’s no reason to create a duplicate topic. Threads merged.

Arch does not rebuild tigernvc when they update xorg-server, why should we? We update / rebuild xorg-server at the same time Arch does.

It it were an issue with packaging, then you wouldn’t be the only one having a problem. Are there any other reported issues?

1 Like

Issue still happening with your build of tigervnc.

I think the issue is the opposite, you need to rebuild xorg after rebuilding tigervnc.

If it’s some tigervnc configuration I would be glad to remove it.

Fixed the whole issue by removing the file /etc/X11/xorg.conf.d/10-vnc.conf:

Section "Module"
Load "vnc"

Section "Screen"
Identifier "Screen0"
Option "UserPasswdVerifier" "VncAuth"
Option "PasswordFile" "/root/.vnc/passwd"

which I had created myself following the guide listed in the official documentation:
Probably other config files are lying around so will delete them as well.
No idea if xorg should crash because of this file.

I’m glad you were able to figure it out. :wink:

Please follow up by letting CendioOssman know in the upstream issue to clear the matter up there.

FYI, tigervnc depends on various xorg packages, not the other way around. :wink:

Package rebuilds are only necessary when a library the package depends on has a new soname or ABI version.


Can you try creating that file and see if xorg crashes on you after reboot?

It does here on up to date Manjaro XFCE stable:

[    14.386] (II) Initializing extension VNC
[    14.386] (EE) 
[    14.386] (EE) Backtrace:
[    14.386] (EE) 0: /usr/lib/Xorg (dri3_send_open_reply+0xdd) [0x55fd4d841bed]
[    14.387] (EE) 1: /usr/lib/libc.so.6 (__sigaction+0x50) [0x7f367c731a00]
[    14.387] (EE) 2: /usr/lib/Xorg (xf86OptionValue+0xb) [0x55fd4d84e54b]
[    14.387] (EE) 3: /usr/lib/xorg/modules/extensions/libvnc.so (vncExtensionInit+0xa31) [0x7f367bd8b2f1]
[    14.388] (EE) 4: /usr/lib/Xorg (InitExtensions+0x89) [0x55fd4d72df69]
[    14.388] (EE) 5: /usr/lib/Xorg (SProcXkbDispatch+0x1809) [0x55fd4d721094]
[    14.388] (EE) 6: /usr/lib/libc.so.6 (__libc_init_first+0x90) [0x7f367c71c290]
[    14.389] (EE) 7: /usr/lib/libc.so.6 (__libc_start_main+0x8a) [0x7f367c71c34a]
[    14.389] (EE) 8: /usr/lib/Xorg (_start+0x25) [0x55fd4d7224b5]
[    14.389] (EE) 
[    14.389] (EE) Segmentation fault at address 0x100000011
[    14.389] (EE) 
Fatal server error:
[    14.389] (EE) Caught signal 11 (Segmentation fault). Server aborting
[    14.389] (EE) 

You seem to be also wanting to share your main display :0; note this is very easily done by adding simply e.g.

/usr/bin/x0vncserver -PasswordFile /home/<user>/.vnc/passwd

to for example your desktop startup applications (in XFCE, under "Session and Startup’) after generating said ~/.vnc/passwd with as said <user>, vncpasswd.

1 Like

Shot in the dark: look into DRI3. Maybe try disabling it, or change some related settings, etc.