Unable to boot or use chroot

I had to edit my part above about GPT and MBR again.

Well, maybe your Bios doesnt really support booting from an external drive really and only with the F12 option (for security reasons?). Because a stolen laptop could be easy accessed, when you boot into it from an external drive. You can lock that all by protecting the bios with a password.

You now may could
a) convert your 240GB to GPT (but with all datas lost and reinstalling required), and set your Bios to UEFI, if it cause further problems.
b) install grub from manjaro into your sbd or sbc, set bios to UEFI and set boot priority to your sdb or sbc.
And remove grub from your Noobara, that it dont updates it.
Same, if you want to install Debian.
If you ie install Debian, just skip to install grub, then boot back into your Manjaro and update-grub there on (example) /dev/sdb. That should give you the option to boot both again.

I used Debian for a while, its ok, some up to date, but just sometimes, its some parts from it, what are way behind with the update, and cause problems. And their IRC was more disappointing too with some self-loving guys.
When i want have a backup system, i install the same distro on 2 disks, so i can toggle to boot, when something goes wrong.

Dear @BaronAsh :wink:

Don’t get this wrong. Detailed explanations are good, but what we need on a support forum is not what you think the system does, but see what the system says it does. We offer support in our free time, so if just want to talk about this and that, no problem, do so, but please not as a support request.

I read novels and I enjoy it, but when it comes to technical stuff it must be short as possible and be to the point. Like:

I have problems since what ever happens before:

  1. I cannot boot a Flash Drive without typing F12 at boot time.
  2. I cannot boot Manjaro anymore without typing F12 and choose the drive.
  3. Third Problem.

It is totally unnecessary to write the whole story in all facets. Then a supporter sees this and asks for system information or if you are smart, you go to the Tutorials section to see what is recommended to post.

Back to the topic:

Then your son replaced x86_64-efi with i386-pc platform, also called legacy/bios. So if you want to switch to efi again, then you need to reinstall grub.

A lot is explained here in short: GRUB/Restore the GRUB Bootloader - Manjaro

  1. Since you’re in CSM/BIOS/LEGACY mode, you need to load the efi driver and mount it:
# Load the driver
sudo modprobe -v efivarfs
# mount the efivar
sudo mount -t efivarfs efivarfs /sys/firmware/efi/efivars
# check if is there (has content)
sudo ls /sys/firmware/efi/efivarfs
  1. If all is good, then you are ready to reinstall grub:
# Check if the efi partition is mounted to /boot/efi
mount -t vfat  
# Remove the grub folder (just installing/overwrite will break grub, since bios and efi are not compatible)
sudo rm -Rf /boot/grub
# Install grub
sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id="Manjaro" --recheck
# Create the grub config:
sudo grub-mkconfig -o /boot/grub/grub.cfg 
# Check if an entry called `Manjaro` is created

If everything seems good, then you can reboot and boot with UEFI instead of CSM.

:notebook: Please, so that we can follow you, post the output of the terminal here. When a problem appears, post it also.

Thank you. Sorry for long posts. Will work througoh those tutorial sections.
They are all EFI boot systems.

/dev/sda    gpt                                                 
/dev/sda1   gpt    c12a7328-f81f-11d2-ba4b-00a0c93ec93b vfat    EFI System
/dev/sda2   gpt    0fc63daf-8483-4772-8e79-3d69d8477de4 ext4    Linux filesystem
/dev/sda3   gpt    0657fd6d-a4ab-43c4-84e5-0933c84b4f4f swap    Linux swap
/dev/sdb    gpt                                                 
/dev/sdb1   gpt    0fc63daf-8483-4772-8e79-3d69d8477de4 ext4    Linux filesystem
/dev/sdb2   gpt    0fc63daf-8483-4772-8e79-3d69d8477de4 ext4    Linux filesystem
/dev/sdc    gpt                                                 
/dev/sdc1   gpt    0fc63daf-8483-4772-8e79-3d69d8477de4         Linux filesystem
/dev/sdc2   gpt    0657fd6d-a4ab-43c4-84e5-0933c84b4f4f swap    Linux swap
/dev/sdc3   gpt    0fc63daf-8483-4772-8e79-3d69d8477de4 btrfs   Linux filesystem
/dev/sdc4   gpt    c12a7328-f81f-11d2-ba4b-00a0c93ec93b vfat    EFI System

sdc is the 500 GB drive with the original main Manaro 1 OS, and sda is the newer 240 GB Drive with the recently installed Manjaro 2 on a newly formatted ext4. All other systems referenced from earlier have been scrubbed (nobara, debian etc.).

More detail on the sdc with Manjaro 1:

sudo fdisk -l /dev/sdc                                                   ✔ 
Disk /dev/sdc: 476.94 GiB, 512110190592 bytes, 1000215216 sectors
Disk model: SAMSUNG MZMTE512
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: DF3F3613-3E80-4047-8006-A20E3F1D20CF

Device        Start        End   Sectors   Size Type
/dev/sdc1      2048      18431     16384     8M Linux filesystem
/dev/sdc2    616448   17000447  16384000   7.8G Linux swap
/dev/sdc3  17000448 1000215182 983214735 468.8G Linux filesystem
/dev/sdc4     18432     616447    598016   292M EFI System

And yet when I disable legacy boot in BIOS it won’t boot. Something doesn’t add up. My son doesn’t understand but he couldn’t log in remotely so we were working with me typing stuff and then sending cell phone pics so…

I will go through the tutorial slowly and see if can clean it all up without losing the OS. At least right now everything works and I have the Manjaro 1 disk at the top in boot priority with legacy enabled and it boots up fine everytime. And now that have settled on using it again, I don’t have to do that very often anyway.

Thanks for your help.

Then again, if they are efi systems as you said, why do write this?

Obviously, the 500GB drive is not EFI? An EFI entry does not exist, as you said.

So what exactly is the problem now? Problem solved :white_check_mark: ?

I am just writing what happens. I put in the lsblk etc. and it says it is EFI. But if I disable legacy boot it won’t boot.

Tutorial. The comman manjaro-chroot -a did this:

manjaro-chroot -a                                                ✔  10s  
find: '/home/baron/pCloudDrive/00Crypto Folder': Permission denied
[sudo] password for baron: 
find: '/home/baron/pCloudDrive': Permission denied
==> Mounting (ManjaroLinux) [/dev/sda2]
 --> mount: [/mnt]
 --> mount: [/mnt/boot/efi]

I thought this was part of installing the manjaro-tools-base program not running a command. What did it just do? Have I mounted sda2 after it tried for some reason to mount pCloud?

I was following this part in the tutorial:

Use manjaro-chroot

Manjaro deploys a script called manjaro-chroot takes an optional argument which will search the visible devices - scan the partitions for signs of an operating system. If more than one Linux operating system is found you will get a choice of which system to chroot otherwise the file /etc/fstab from the system is used to mount the partitions and chroot into this system.This script is only available in live iso by default but you can get it in an installed system by installing manjaro-tools-base package.

root # pamac install manjaro-tools-base

root # manjaro-chroot -a


The next part confuses me:
mount /dev/sdyC /mnt

I never know what sdyC means.

ok I see many questions…

  1. manjaro-chroot is a helper script. It is usually used to be run on a Manjaro live session (flash drive boot) to switch to the local system within the terminal. Since you are booted locally, it is not needed.
  2. lsblk doesn’t show you that you run efi. It list the block devices, for example your partitions. To determine, if you booted into efi, commonly efibootmgr should return a list of boot entries.
  3. sdyC is a placeholder. That is usually /dev/sdb2 for example → SCSI Disk B Partition 2

Thank you. So with Nr 3 I need to know which partition to specify and usually I don’t. When I run “efibootmgr” or “efibootmgr -a” :

“EFI variables are not supported on this system.”

(Just installed it.)

Re 1 I was following the tutorial where it says: " This script is only available in live iso by default but you can get it in an installed system by installing manjaro-tools-base package." So I installed that package.

To clarify: Of which system are we talking about? Which drive? /dev/sda, /dev/sdb or /dev/sdc? Which system is booted?

What is the output of:

 ls /sys/firmware/efi


mount -t vfat  


cat /etc/fstab
 ls /sys/firmware/efi                                                    ✔ 

ls: cannot access '/sys/firmware/efi': No such file or directory
    ~  mount -t vfat                                                          2 ✘ 
    ~  cat /etc/fstab                                                           ✔ 

# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=9b57e27f-245c-4e84-9779-7d0cbe578626 /              btrfs   subvol=/@,defaults,noatime,space_cache,ssd,compress=zstd,commit=120 0 1
UUID=9b57e27f-245c-4e84-9779-7d0cbe578626 /home          btrfs   subvol=/@home,defaults,noatime,space_cache,ssd,compress=zstd,commit=120 0 2
UUID=9b57e27f-245c-4e84-9779-7d0cbe578626 /var/cache     btrfs   subvol=/@cache,defaults,noatime,space_cache,ssd,compress=zstd,commit=120 0 2
UUID=9b57e27f-245c-4e84-9779-7d0cbe578626 /var/log       btrfs   subvol=/@log,defaults,noatime,space_cache,ssd,compress=zstd,commit=120 0 2
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0
UUID=ec4a266c-f6e1-497c-91ab-af62b4230b7a /run/media/baron/2TBData ext4 defaults,noatime 0 2

(I believe there is another fstab on sda if/when the system uses that boot area to boot up into the other Manjaro 2 OS.)

Alright, it is /dev/sdc then with your btrfs installation. Which is pure BIOS/legacy/CSM. Fstab states that it doesn’t mount the efi partition, since it is not listed there.

/dev/sdc4, which is the efi partition. Is useless here then and can be removed without doubt.

Alright. What is your goal now? This system works and is booted.

Well, it would be nice to come out of this understanding what happened and why so that I can better manage things in the future. And also to have a better booting experience. Or maybe because one system is ext4 and the other is btrfs it is best to keep them separated each with their own boot-up routines and I select which to run in BIOS? Would also be nice to understand why cannot boot up the livecd’s any more without manually selecting them.

We have an appointment in town so have to leave for a few hours in a little while. Very sorry.

Note this: If you have grub in bios mode installed, then you cannot boot a grub with efi and vice versa. All systems have to be in the same mode.

So we determined that sdc is pure bios:

Although, a useless efi partition is there. /dev/sda seems to be in efi mode:

Because It looks like a pretty default “erase installation”.

Only way to switch between the systems is using the UEFI Boot Manager (what you see when typing F12).

And no, it has nothing to do with the file system, but with the incompatibility between bios and efi.

In your UEFI/BIOS Settings, however you want to call it, you need to put the Flash drive higher on the boot list as the local installations. Boot priority or Boot order, however you want to call it. Then it will always boot the Flash-Drive first. But note that if you install another OS, then it will take over priority. You need to readjust it again.

Have a good time :wink:

Thank you again. Leaving soon but:

  1. How do you see it’s in BIOS not efi mode from the print-out?
  2. The flash drives are at the top above the hard drives in BIOS order. But I can only boot with them via the F12 manual select option. Very strange.

Re: “And no, it has nothing to do with the file system, but with the incompatibility between bios and efi.”

After writing out the previous post I finally grocked that. Part of my problem is that all these things are very abstract to me. I don’t really know the difference between bios-mbr and efi, or gpt etc. and since I only wrestle with such things for a day or two every year or two I have to pretty much start from scratch each time.

  1. I look at the Partition Scheme.
    MS-DOS → 100% BIOS
    GPT → then you have to look which partitions are created
  2. Partitions:
    8MB non-formatted partition flagged with bios_grub → BIOS
    vfat/fat16/32 formatted partition flagged with boot, esp, boot,esp → EFI
    if both are present, then it has to be checked internally:
    /etc/fstab → contains the efi partition → EFI
    efibootmgr has content → EFI
    if not → BIOS

Yeah, that is strange, but has to do with the UEFI Firmware then. :man_shrugging:

Thank you again. I think I know what I want now, but first a clarification:

I am not finding the command that shows the 8 mb partition (sdc1) is MsDos. fdisk -l show it as a ‘linux filesystem’ whereas sdc4 is ‘EFI System.’ Is that how you know?

As to where to get to if possible:

  1. First, I would like to get this Manjaro1 system on sdc to operate via EFI boot and to get rid of any and all other types of boot partitions/scripts etc. I don’t know how or why it happened, but it seems to be the cause of all this confusion.

  2. Twist: is it possible to transfer the system currently on sdc to sda?
    Because I think what I would like to end up with is
    a) One OS only on sda (240 GB SSD) - preferably the system currently on sdc since everything works properly there and the newly installed one on sda has niggles, the main one being the printer not working well (though I finally did get it to work after a long time by turning the machine off and on after no joy with endless driver installations etc!), and also not all gnome extensions work properly and for some mysterious reason cannot log in via the browser to change them - gnome extensions ‘just says no!’

b) then I could scrub sdc disk and use it for Timeshifts and dd disk image backups only.

If I keep the main OS on the current 500 GB drive, then my understanding is that I cannot use the smaller sda for dd backups of the larger disk. That’s why I’m thinking of shifting it over. I would like to end up with simple, bullet-proof whole system backup method that can simply restore the entire disk quickly - like I used to do back in the day with Windows Exp and Hard Disk Manager (a great program developed in D-land, I think)

c) If I cannot shift it over from sdc to sda (or transfer the Home files to effect this or whatever), then perhaps I should go with the fresh installation on sda - with the expectation of being able to resolve the niggles - and simply wipe the sdc drive to use for all timeshift and dd backups etc. without any additional OS anywhere on the computer. (If I want to play with distros - which rarely do - can do so from within a virtual manager like Boxes.)

If it is not possible to transfer the OS from sdc to sda, then I’ll probably stick with this sdc drive for now because everything works so well and probably erase the backup OS on sda and just use livecd if there are problems like this (unable to boot etc) in the future which there shouldn’t be if I only have one OS, no?

After this experience I am thinking that having a backup OS - which seemed prudent to me at the time - is inviting more headaches than it potentially solves and in any case doesn’t really offer anything more than a livecd EXCEPT that I can use it to keep working on things in word processors etc. But those things can be worked on via livecd too for a little while making the reasons for having a second OS questionable - especially given how having one can result in seriously compromising the main OS as happened to me last week for reasons am still not clear about.

Thanks again. I hope the above is clear.

Already explained:

That can be done, but would be a lot to write and explain, especially because of btrfs (and you are not familiar with it). Also, you need some basic understanding about the process so that nothing goes wrong. I assume you have almost zero knowledge about it. Contact me via PM, if you would like some support and real time explanations, I will not explain every single detail here, since a search with the correct terms can give you all the information you need, and you need the will and time to learn that.

Perhaps a fresh installation on sda would be better for you, since I assume that you are a newbie on this field. :man_shrugging: Using dd for btrfs is not recommended!

TimeShift is not a real backup tool and was never intended. Timeshift is more like “Windows Recovery”. By default, it creates a snapshot of your system files on the same disk and with timeshift-autosnap it creates a snapshot right before a system upgrade starts. And if something went wrong, you can roll it back.

If you want to backup your home files, I would suggest using borg. There are 2 GUIs for that vorta and pika-backup, although you can also just use a script. Borg supports snapshots, deduplication and compression.

Anyway, why would you create images of the whole OS? What would make sense on debian servers, which doesn’t change very often, but a rolling OS is still rolling. You will spend a lot of time creating images every time something changes.

I have a backup OS, which is just a customized Manjaro ISO and I don’t use a flash drive for this.

  1. Make some space on sdc and create a 10GB vfat partition and flag it with boot,esp and name the partition and file system “RECOVERY” (:point_right: important :point_left:).
  2. Mount it and install grub on it:
sudo mount --mkdir --label RECOVERY /mnt/recovery
sudo grub-install --target=x86_64-efi --recheck --removable --efi-directory=/mnt/recovery --boot-directory=/mnt/recovery/boot --verbose --force
  1. Create an efi entry in your UEFI/BIOS:
 sudo efibootmgr --create --disk /dev/sdX --part <number> --label "Recovery" --loader '\EFI\BOOT\BOOTX64.EFI'
  1. Copy a Manjaro ISO to that partition:
sudo cp -f /path/to/manjaro.iso /mnt/recovery/manjaro.iso
  1. This script has to be in /mnt/recovery/boot/grub/grub.cfg (create it):
function load_video {
  if [ x$feature_all_video_module = xy ]; then
    insmod all_video
    insmod efi_gop
    insmod efi_uga
    insmod ieee1275_fb
    insmod vbe
    insmod vga
    insmod video_bochs
    insmod video_cirrus

if loadfont $prefix/fonts/unicode.pf2 ; then
  # Set Video
  set gfxmode=auto
  insmod gfxterm
  # Set Langauge for grub
  set locale_dir="$prefix/locale"
  set lang="de"
  insmod gettext

# Set keyboard language for grub
#insmod keylayouts
#keymap $prefix/lang.gkb

terminal_input console
terminal_output gfxterm

insmod part_gpt
insmod part_msdos
insmod fat
set label="RECOVERY"
search --no-floppy --label --set=root $label
insmod png

set timeout_style="menu"
set timeout="10"

menuentry "Manjaro ISO"  {
    # Setup grub
    set gfxpayload=keep
    insmod part_gpt
    insmod part_msdos
    insmod fat

    ## Set Parameters for the ISO
    # Set the free or nonfree drivers
    set dri="free"
    # Set the language of the Desktop (localectl list-locales)
    set lang="de_DE"
    # Set keyboard language (localectl list-keymaps)
    set keyboard="de"
    # Set the timezone (timedatectl list-timezones)
    set timezone="Europe/Berlin"
    # Copy to RAM (needs at least 8GB RAM)
    #set c2r="copy2ram"

    # Set Params searching the ISO
    # Label of the partition where it searches for the iso file
    set label="RECOVERY"
    # Search for the partition label and switch to the root directory of it
    search --no-floppy --label --set=root $label
    # Set the device where the ISO is located
    set device="/dev/disk/by-label/$label"
    # Set the Path to the ISO
    set file="/manjaro.iso"

    loopback loop $file
    linux  (loop)/boot/vmlinuz-x86_64  img_dev=$dev img_loop=$file driver=$dri tz=$timezone lang=$lang keytable=$keyboard $cr2
    initrd (loop)/boot/intel_ucode.img (loop)/boot/initramfs-x86_64.img
  1. And now you are done. You can now reboot, type F12 and choose “Recovery” from the Bootmenu. This little installation is fully dedicated and even work when your main installation is non-functional. You can also do a full installation form here.

:notebook: You need to adjust the parameter in menu to your language. Parameters are mostly explained. If you have an amd CPU, then replace intel_ucode.img with amd_ucode.img.

Anyway, this works for me in production and if something goes wrong, I can always boot a live session and fix stuff.

Ok I hope this is clear now and helpful. :wink:

Thank you very much. I shall take a while to go through it all to understand.

I am thinking as well that the best thing is to start over but this time create a situation that covers the bases. Apparently I misunderstood Timeshift. And although am not a total newbie, I am not very good with technical issues, never have been since having MSDOS 3 and an apple Macintosh in early 80’s. My main problem is that have never been able to understand computer-speak and so am pretty useless dealing with most problems.

I think your recovery option makes a lot of sense. Presumably that is what Pop! OS does.

I also now realize that I don’t understand the issues with rolling releases, LTS non-rolling etc. It’s possible that I should go for something far more stable since my uses are pretty vanilla - word processing with basic image inserts, watching movies, browsing, not much more. There is nothing I do now that wasn’t doing decades ago, apart from more moving images/videos because of bandwidth advances. 90% of my issues with computers, both Windows and Apple in the 80’s, were system snafus popping up making operation unworkable. Apart from that I don’t like to mess with anything.

That said, there is something about Arch and Manjaro that I like. Feels smooth when running well. Debian feels a little sludgy to me for some reason. Ubuntu feels fickle somehow. So even though am a bit of a dunce with tech issues, I like the feel of this Arch-based distro the best. Though I am tired of how difficult it can be to get simple laser printers and bluetooth devices working without fiddling. And these boot issues are a pain but I think by avoiding things which create issues I can avoid them pretty much always.

One issue is btrfs vs ext4. My son recommends the latter and maybe I’ll go for that to keep things simple. But need to consider that for a little while. Then I’ll come to your post here and use it to help set up a proper situation finally.

Thank you again for your kind help. If there was a way to pay, I would. Amazon gift card?