Unable to boot live USB installer on my system

Due to the nature of this hardware, this may actually be a unique issue but I’d like to see if there might be a way to get this working.

My desktop’s motherboard is an old MSI X58A-GD45 with an i7 quad core CPU and a dedicated Nvidia GTX 970 graphics card (no integrated video input)

This old motherboard runs something known as ‘2.2 TB Infinity’ in order to support the use of GPT partitions. From what I gather it appears to be some sort of EFI and I haven’t yet figured out if I can change anything on it beyond the boot device. Otherwise it comes with standard BIOS.

Currently the 2.2 TB Infinity is what my Windows 10 partition runs under, due to it being a requirement in order to utilize any of my hard drives with capacity higher than 2.2 TB. It is the only OS installed on this system.

The Goal
My goal is to install Manjaro onto a new SSD (Samsung 870) I added to my system under the 2.2 TB Infinity EFI with a dual-boot configuration, all of my attempts to even boot into the LiveUSB environment have failed. As of writing, the furthest I have gotten with this is to the GrubRescue screen but if I can’t get to that there is simply a black screen that may or may not just say ‘Grub’ on it.

Attempting to boot to the LiveUSB environment results in either a GrubRescue instance or a hanging black screen on a confirmed 'Good' USB installer, the only OS installed on the system is Windows 10. The 'ls' command in GrubRescue for each storage device shows 'unknown filesystem'

Overall System Specs (From Speccy in Windows):

Operating System
Windows 10 Pro 64-bit
Intel Core i7 960 @ 3.20GHz 119 °F
Bloomfield 45nm Technology
24.0GB Triple-Channel DDR3 @ 534MHz (7-7-7-19)
MSI X58A-GD45 (MS-7522) (CPU 1) 101 °F
Standard Monitor (1920x1080@60Hz)
HP W2072a (1600x900@60Hz)
Standard Monitor (1920x1080@30Hz)
4095MB NVIDIA GeForce GTX 970 (NVIDIA) 139 °F
1863GB Hitachi HDS723020BLA642 ATA Device (SATA) 94 °F
931GB Samsung SSD 870 QVO 1TB ATA Device (SSD) 87 °F
5588GB Western Digital WDC WD60EZRX-11MVLB1 ATA Device (SATA) 88 °F
1863GB Western Digital WDC WD20EADS-00S2B0 ATA Device (SATA) 99 °F
111GB KINGSTON SH103S3120G ATA Device (SSD) 90 °F
57GB USB SanDisk 3.2Gen1 USB Device (USB)

So far I have taken the following actions in attempt to troubleshoot this:

 Re-imaged the USB image using multiple different tools (including the DD terminal command with a Manjaro VM onto the USB drive) and tested it good on another system
 Attempted alternative imaging options using RufusUSB (DD mode/ISO mode)
 Attempted booting with the BIOS instead of 2.2 TB Infinity
 Attempted the commonly found fix for the unknown filesystem error commands for GrubRescue
 Attempted using the Windows bootloader to try and boot the USB device
 Disabled secure boot in BIOS/Windows
 Disabled fast boot in BIOS/Windows
 Attempted reinstalling Grub on the USB media using a Manjaro VM

Any ideas would be appreciated, let me know if you need any further info.

That refers to the only limit an ESP (EFI System partition) has: it needs to be in the first 2.2 TB of any disk.

So you have an UEFI system.

Nope! It’s UEFI, but UEFI has a BIOS-compatible mode, but as Windows runs in UEFI mode this is not advisable.

  • Download one of the old releases of Manjaro ( for the KDE version they’re here)
  • install Kernel 5.4 LTS (Long Term Support) which is better for older hardware
  • upgrade.


I finally got around to trying this, I downloaded version 19, and then version 17.1.12 and tried both (I used gnome because thats what I want as the desktop) with no success.

Using rufus, I used the ISO image mode and the DD modes which had different effects each mode but still failed to boot no matter what. I also tried it both in 2.2 TB Infinity and BIOS.

DD Mode Effect - Version 19 would briefly show a ‘Grub’ text that would disappear and then hung on a blank screen, Version 17.1.12 was similar except it showed a ‘Welcome to Grub’ text that it would hang on. This happened on both BIOS and EFI.

ISO Mode Effect - Both versions would go directly to Grub rescue with ‘unknown filesystem’, using the ls command for each hard drive would result in ‘unknown filesystem’ for each one.

I’m wondering if my nVidia card might have something to do with this, or if there might be some type of special grub configuration my system needs in order to boot the USB

I don’t think so. My opinion is that your disks are not recognised as disks by Linux, so try seeing of you can change the mode of the disks in your firmware while testing that Windows sill boots. (probably AHCI or ACPI error)

Why do I think so?


My opinion is that your disks are not recognised as disks by Linux

Wouldn’t it still be able to at least boot to the LiveUSB in that case? Since I am not utilizing any disks on the system yet

It’s just an opinion and this:

leads me to believe that on top of the unknown file system.

OTOH, you could also have a dodgy download. Did you verify the SHA1 of your ISO?


you could also have a dodgy download

I verified the SHA for the original version 20 image that I initially used.