Unable to boot into manjaro on ideapad duet 3

I have ideapad duet 3 10IGL5. I try to install manjaro on it.
I change the boot order to boot from usb first. but it goes to the windows.
I don’t have a memory stick with with usb-c so I use a usb-to-usb-c adapter. I don’t know if this might be the issue. In addition I tried to install ubuntu 22 also without success and it seems impossible to boot from sd-card (it’s not event in the boot list options). Any idea?

Try the search


Hello @dafna,

I managed the installation some time ago, but cant remember how exactly. I also used a usb-to-usbc adapter.

Then you need to enter “bios”:

For pressing F12 dont miss the “FN” Key. In “bios” take a look to disable “secure boot”. From “bios” I guess you can change bootorder or enter bootmenu.

Now I see there is an option in “bios” to enable/disable “USB Boot”, this you should enable. :wink:


hi, thanks. I disabled secure boot and it did show a manjaro screen. I tried to boot with both proprietary and open source drivers. But neither worked. I get only a black screen.