Unable to boot into manjaro after updating graphics drivers

Hi, I was experiencing very bad performance out of my GPU (1060) in a game, so I went to the visual installer and chose the proprietary drivers and reboot my computer. After trying to boot back into my manjaro installation, I am greeted with my motherboard’s splash screen and nothing else. I’m unsure if this is related, but the day before all of these issues started, I was attempting to pass my single 1060 as GPU to my win10 vm. I attempted to follow everything I could find online to fix errors similar to this and nothing has worked. Mainly I have chroot into my manjaro installation and tried just about every command I could find with no help to the situation. I also somehow managed to nuked my already working win10 dual boot drive by installing another instance of manjaro over it, somehow.

I’m sure I missed some key details somewhere so if anyone needs some more information please let me know. Thanks in advance

So, what is your current state?

Here is a little script to collect necessary configs: GPU Report ($2174072) · Snippets · Snippets · GitLab

curl -s "https://gitlab.com/-/snippets/2174072/raw/main/gpu-report.sh" | sh

Post the link here then.

Currently I can not boot into my ssd with my main manjaro installation. I have to instead boot into a live iso on a flash drive. Can I run this scrip through chroot?

Yes, should work there also.

https://0x0.st/-xrC.txt here it is

The newest Xorg says:

[     8.156] (II) modeset(0): [DRI2] Setup complete
[     8.156] (II) modeset(0): [DRI2]   DRI driver: nouveau
[     8.156] (II) modeset(0): [DRI2]   VDPAU driver: nouveau

So you actually boot with nouveau drivers, but on the other hand it is blacklisted?


## Generated by mhwd - Manjaro Hardware Detection
blacklist nouveau
blacklist ttm
blacklist drm_kms_helper
blacklist drm

That make no sense :dizzy_face:

remove this file:


options kvm-intel nested=1

and this one:


options vfio-pci ids=10de:10f0,10de:1b83

Both files removed, no change.

[manjaro /]# ls /etc/modprobe.d

new curl output : 0x0.st/-xsw.txt

Are you sure that you did not boot another OS? The Xorg.0.log did not change…

Please remove quiet from the kernel parameter at /etc/default/grub and recreate the menu: sudo update-grub when chrooted and reboot then. Where does it stuck?

So what I did was I just chroot in via live iso and did rm and removes the files you said to remove and rebooted, choosing my previous working manjaro installation on my ssd. Like I said before nothing changed.

After doing your most recent suggestions, we’ve gained some sort of progress, although am am unsure of whether or not it is positive or not. I’ve attached an image of what now appears when I try to boot in.

imgur com/a/KOskFXC

So there is a problem with the early hook…

Could post this file: /etc/mkinitcpio.conf ?

Maybe recreate the initramfs: sudo mkinitcpio -P

1 Like

My friend, that was it. Thanks so much for your time. I’m back into my manjaro installation with all my files. After it’s all said and done, only managed to lose one of my two dual boot OS’ because of you, which is much better then I thought this situation would end up. :smiley:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.