Unable to boot from usb

I tried to use lots of tools to flash the USB drive. And it can boot in another of my laptop. So, I think the USB drive and the iso is good.
But failed on this one with this error:

mount: /run/miso/sfs/livefs: wrong fs type, bad option, bad superblock on /dev/loop0, missing codepage or helper program, or other error
ERROR: Failed to mount ‘/dev/loop0’’

The device is Xiaomi’s laptop:
CPU: AMD R7-5800H
RAM: 16G DDR 4
DISK: ZhiTai TiPlus 5000 1T

I think it may be caused by the disk.
At first. I use a 500G disk to be the primary disk of this laptop. It works fine.
But after I switch the disk to this 1T disk, it can’t boot.

Additionally, I tried to use VM to boot and connect the external disk directly.
At first, it boots well, but after some time reboots. it throws the same error.
It’s so puzzling.

You used the .iso file to boot the VM from?

check the integrity of that file


whatever is provided to check the integrity of the file you downloaded

There may be issues with recent CPUs on real hardware - but in a VM, that should not matter

I tried to use the USB drive on another PC, and it works fine.
So I think the iso and the USB drive are good.

About the CPU, at first, the iso could boot on the current laptop( which can not boot now), but it can’t boot after I changed the disk.

It’s really puzzling.

sorry - but I do not know what that might mean

Maybe check boot order in BIOS?

The message indicates a problem with the storage medium or the ISO.

  1. Redownload the ISO
  2. Download the gpg signature from the iso download location
  3. Validate the iso and the sig file (in the same folder)
    • For the full plasma
    gpg --verify manjaro-kde-21.3.7-220816-linux515.iso.sig manjaro-kde-21.3.7-220816-linux515.iso
    • For the minimal plasma
    gpg --verify manjaro-kde-21.3.7-minimal-220816-linux515.iso.sig manjaro-kde-21.3.7-minimal-220816-linux515.iso
  4. Use ventoy to prepare your USB stick
  5. Drag and drop the ISO file onto the newly prepared USB stick