Unable to boot, flashing cursor


I have an issue where I am unable to boot my system. On power up I get a flashing cursor in the top left (after bios splash). The system is completely unresponsive, and I never see grub.

I have had a similar issue awhile ago, after a kernel update, where the Nvidia (proprietary) drivers never updated.

I also have an additional issue where I accidentally reset the bios while moving my computer to a new location. For whatever reason a large reset button is present on the back-plate. I don’t think this caused the boot issues but am not certain.

For additional information the machine had been on for a long time before being updated and shutdown, so this may have upset something.

I have tried uninstalling the Nvidia drivers and reinstalling via chroot on a live USB, but this has not helped.

I also updated the system using chroot but still no luck.

I’m unsure on where to look for any more clues as to why I cannot boot, any help would be much appreciated.


Below is from chroot into system on live USB. Proprietary drivers had been removed at this point.

    inxi -F
   *12System:    12Kernel 5.9.16-1-MANJARO x86_64 12bits 64 12Desktop Xfce 4.16.0 12Distro Manjaro Linux 
   *12Machine:   12Type Desktop 12Mobo ASRock 12model Z77 Extreme4 12serial <filter> 12BIOS American Megatrends 
   *           12v P2.00 12date 07/13/2012 
   *12CPU:       12Info Quad Core 12model Intel Core i7-3770K 12bits 64 12type MT MCP 12cache 12L2 8 MiB 
   *           12Speed 1600 MHz 12min/max 1600/3900 MHz 12Core speeds (MHz) 121 1600 122 1600 123 1600 124 2264 
   *           125 1600 126 1998 127 1600 128 1600 
   *12Graphics:  12Device-1 Intel Xeon E3-1200 v2/3rd Gen Core processor Graphics 12driver i915 12v kernel 
   *           12Device-2 NVIDIA GP104 [GeForce GTX 1070] 12driver nouveau 12v kernel 
   *           12Display 12server X.Org 1.20.10 12driver 12loaded nvidia 12resolution 1680x1050~60Hz 
   *           12OpenGL 12renderer NV134 12v 4.3 Mesa 20.3.4 
   *12Audio:     12Device-1 Intel 7 Series/C216 Family High Definition Audio 12driver snd_hda_intel 
   *           12Device-2 NVIDIA GP104 High Definition Audio 12driver snd_hda_intel 
   *           12Device-3 C-Media Audio Adapter 12type USB 12driver hid-generic,snd-usb-audio,usbhid 
   *           12Sound Server-1 ALSA 12v k5.9.16-1-MANJARO 12running yes 
   *           12Sound Server-2 PulseAudio 12v 14.2 12running yes 
   *12Network:   12Device-1 Broadcom NetLink BCM57781 Gigabit Ethernet PCIe 12driver tg3 
   *           12IF enp4s0 12state up 12speed 100 Mbps 12duplex full 12mac <filter> 
   *12Drives:    12Local Storage 12total 2.52 TiB 12used 29.36 GiB (1.1%) 
   *           12ID-1 /dev/sda 12vendor Samsung 12model SSD 840 Series 12size 232.89 GiB 
   *           12ID-2 /dev/sdb 12vendor Samsung 12model SSD 860 EVO 500GB 12size 465.76 GiB 
   *           12ID-3 /dev/sdc 12vendor Samsung 12model HD154UI 12size 1.36 TiB 
   *           12ID-4 /dev/sdd 12vendor Samsung 12model SSD 850 EVO 500GB 12size 465.76 GiB 
   *           12ID-5 /dev/sde 12type USB 12vendor Kingston 12model DataTraveler 3.0 12size 14.48 GiB 
   *12Partition: 12ID-1 / 12size 211.11 GiB 12used 29.36 GiB (13.9%) 12fs ext4 12dev /dev/sda2 
   *           12ID-2 /boot/efi 12size 299.4 MiB 12used 280 KiB (0.1%) 12fs vfat 12dev /dev/sda1 
   *12Swap:      12Alert No Swap data was found. 
   *12Sensors:   12System Temperatures 12cpu 29.0 C 12mobo N/A 12gpu nouveau 12temp 28.0 C 
   *           12Fan Speeds (RPM) N/A 12gpu nouveau 12fan 847 
   *12Info:      12Processes 270 12Uptime 7m 12Memory 15.53 GiB 12used 1.9 GiB (12.3%) 
   *           12Client Unknown Client: systemd 12inxi 3.3.03

Seemed to be a grub problem, reinstalling it seemed to fix it.
I followed the post in the Manjaro wiki.

To fix on EFI system:
boot to live USB
chroot into broken system
grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck
grub-mkconfig -o /boot/grub/grub.cfg


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.