Unable to boot after trying to plot 3d graphs in maple

I was trying to finish a project for a course using maple to draw graphs, but was unable to draw 3d graphs using plot3d. I found a solution for this on the offical arch wiki, and so did exactly as it said. I normally use oh my fish, so I typed sudo bash first in order for the commands to work. When I then excecuted the commands they did not work, and my screen went blank with an error saying something is wrong and to contact an administrator. I am now unable to boot into manjaro, with the errors “failed to start authorization manager” and “dependency failed for modem manager”.

Apologies for bad formatting, I am (understandably) writing this on my phone.

To clarify, this was the command I copied from the wiki: libstdc++.so.6 -> /usr/lib64/libstdc++.so.6


command with fish was ?

sudo bash libstdc++.so.6 -> /usr/lib64/libstdc++.so.6

it’s not a valid command (bash or fish)
this command doesn’t do anything because it’s not valid so don’t break the system. No writed other commands ?

ps: it’s writed in wiki create link and not run this line :wink:

you should check if you have not deleted usr/lib64/libstdc++.so.6 file or if is empty from a live iso

This was not one line, I first typed sudo bash as a seperate command

but sudo bash is good, only open a bash
maybe afterwards you created a symbolic link but the source was wrong ?

libstdc++ file is in gcc-libs package - if its error … you install this package from live iso in manjaro-chroot

Sorry, but how do I do that once I have chrooted into my system?

install a package

manjaro-chroot -a
 pacman -S gcc-libs
sync && exit

nothing is sure that it’s this package because apparently you didn’t enter in terminal a file name “libstd…” :wink:

Thank you so so much, this fixed it! I was really worried there for a second, but everything worked out ok! Now I just have to finish my assignment…

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.