Unable to boot after running fsck

I was unable to login to my account using the correct password so I restarted the system upon which I received the following error.

mount: /openswap_keymount : mount(2) system call failed : Structure needs cleaning Failed to open keyfile ERROR: resume: hibernation device ‘dev/mapper/luks...’ not found mount: /new_roots: mount(2) system call failed : Structure needs cleaning You are now being dropped into emergency shell sh: can’t tty: job control turned off

Scouring the forum, someone suggested running fsck booting from a live usb
I did that

fsck.ext4 /dev/sda2

Warning fsck.ext4 exited with signal 9

Then I tried booting again, this time i got the following error

[FAILED] Failed to start Flush Journal to Persistent Storage.
[FAILED] Failed to start PostgreSQL database server.
[FAILED] Failed to start Simple Desktop Display Manager.
[FAILED] Failed to start Samba NMB Daemon.
[FAILED] Failed to start Samba SMB Daemon.
[FAILED] Failed to start Snap Daemon.
[FAILED] Failed to start Snap Daemon.

I also ran check on the partition from gparted, which too closed with an error.

Then I tried updating by using chroot from the live ubuntu

sudo pacman -Syuu

But there I got the following error

Error: failed to init transaction (unable to lock database)

On the forum I found suggestions for cleaning temp folder and removing /var/lib/pacman/db.lck but no such file existed.

Please advise. THANK YOU

You provided not much helpful info. If you have problems with your file system you are encouraged to provide some info about it…

Start a live ISO, try to manjaro-chroot into your system - if possible - and then share with us output of

test -d /sys/firmware/efi && echo efi || echo bios
sudo parted -l
cat /etc/fstab

I have included the info below

[ubuntu /]# test -d /sys/firmware/efi && echo efi || echo bios
[ubuntu /]# sudo parted -l
Model: ATA TOSHIBA MQ04ABF1 (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system  Name  Flags
 1      2097kB  317MB   315MB   fat32              boot, esp
 2      317MB   991GB   991GB
 3      991GB   1000GB  8795MB

Model: Generic Flash Disk (scsi)
Disk /dev/sdb: 4027MB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 1      65.5kB  4027MB  4026MB  primary  fat32        boot, lba
[ubuntu /]# cat /etc/fstab
# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=83E8-1852                            /boot/efi      vfat    umask=0077 0 2
/dev/mapper/luks-ecf026c9-e363-44ec-849c-5bb0ea0884cb /              ext4    defaults,noatime 0 1
/dev/mapper/luks-2144441c-7335-45c3-9439-53790dad55e7 swap           swap    defaults,noatime 0 2
NAME FSTYPE UUID                                 PARTTYPE                             PARTTYPENAME
|    vfat   83E8-1852                            c12a7328-f81f-11d2-ba4b-00a0c93ec93b EFI System
|    crypto ecf026c9-e363-44ec-849c-5bb0ea0884cb 0fc63daf-8483-4772-8e79-3d69d8477de4 Linux filesystem
| `-ssd
|    ext4   807dbaa6-5afb-42e8-827e-1a3885fa546f                                      
     crypto 2144441c-7335-45c3-9439-53790dad55e7 0fc63daf-8483-4772-8e79-3d69d8477de4 Linux filesystem
     swap   74a2c5c2-6213-4642-996e-27e782da5329                                      
     vfat   13F9-312C                            0xc                                  W95 FAT32 (LBA)

Are you running Ubuntu or Manjaro?

If you have a full disk encryption without /boot partition I can only say, hopefully have backed up all valuable data as this does not look good, I’m no expert on recovery of luks encrypted partitions but I’m sure it will be difficuult.

The live disk I used was ubuntu, the installed OS is Manjaro. I am able to access all my data by mounting sda2 after doing cryptsetup luksOpen /dev/sda2 /mnt
I think there is a boot efi partition, not sure though.
Thank you for your help.
By the way I had a similar kind of issue earlier, as far as I remember last time only did a swap on swapoff from the live usb and it booted fine after that. This time there seems to be an issue with the filesystem, I concur with you it seems serious.