Ugly fonts on Firefox for non-root user

I’ve recently created a non-root user on my Manjaro (KDE Plasma) PC. On this second user account, some pages on Firefox use very ugly fonts. When I log in as my main user, fonts in Firefox look fine. Fonts in Chromium on the non-root account also look normal. Here are some screenshots from an particularly ugly looking website (I’m not allowed to post links or images so make sure to remove the spaces):

Firefox as non-root user imgur. com/NJbnALO

Chromium as non-root user: imgur. com/NBClvay

Firefox as main user: imgur. com/17MDq9L

What I tried until now:

  • Checked KDE’s font settings, both users have the same settings.
  • moved .config/fontconfig/fonts.conf from main user to new user. (Had no effect so I switched back to default config)
  • Changed gfx.font_rendering.fontconfig.max_generic_substitutions in about:config to 127.
  • Copied my font settings in Firefox to the new user. Interestingly, on my main user account, Noto is shown as the default font in Firefox. On the non-root account, default fonts in Firefox are DeJaVu fonts.

None of these have solved the issue yet. Do you have any other suggestions?

If you are on Testing or Unstable, there recently was an update to fontconfig that had this effect on my FF fonts in Manjaro and my EndeavourOS (VM), but strangely, not in my Arch (VM).

The changes were to:


If you prefer, you can put it back to the way it was by editing it and change lines 8, 21, and 38 to put the deja vu version first in the lists again.

Thanks for the reply. Unfortunately, I’m on the Stable branch and I haven’t updated in a while so I still have DejaVu on those lines.

Try to copy your whole ~/.mozilla folder from user to new user (there is no such thing as non-root user, I mean all your users are non root). See if using your user profile in your new user changes anything.

I’ll try your suggestion, thanks.

What I mean by that is the main user can run sudo while the new user can’t. Whatever is the correct terminology for that.


The correct ownership should then be set. As the user, after copying the directory, run:

sudo chown $USER:$USER ~/.mozilla

I moved the .mozilla directory and also changed ownership of all files under that directory to the new user. Unfortunately the issue still persists.

@LazyLucretia Improve Font Rendering - Manjaro

1 Like

I followed the steps here and I think the issue is solved. Fonts look much better right now. Thanks a lot. :+1:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.