UEFI Booting issue with Manjaro 20.2

i have UEFI Bios , in manjaro 20.1.2 everything was perfect, i can manually partition for manjaro setup like this, 50gb ext4 for root drive, and 500mb fat32 for boot/efi with boot flag,

everything was good, then i can select Manjaro from uefi boot menu,

but after manjaro 20.2 update, i have tried fresh installation and manual partition as before, and there is no uefi boot for manjaro :frowning:

with same process i can install and boot manjaro 20.1.2,
what happened with 20.2 ?

1 Like

No clue what this should mean…

sorry i am bad in english,
i mean there is nothing after installation manjaro as i mention installation process.

You reinstall your OS everytime it shows an update?
No idea what you mean. Please re-write your post so we can understand it.
Or write in your local language sub-forum.

After installing manjaro there is no grub loader. Thats my problem

Did you use the GUI installer (Calamares) or Architect?


Just tried with the Cinnamon 20.2 ISO in VirtualBox, manual partitioning:

EFI: on

Layout: GPT
500 MB FAT32, boot flag, mounted to /boot/efi
19,5 GB ext4, mounted to /

Works fine here… :man_shrugging:

With Manjaro, you don’t need to reinstall every time a new ISO version is released. Just update your existing installation.

You should check if you can make appear de GRUB menu when the system boots, by pressing a key depending wether you have BIOS or UEFI. I think for UEFI the correct key is ESC; in that case, boot your system an hold esc to access the grub menu, where you should be able to see the boot options and the kernels that you have installed on your computer.
Furthermore, you can always check your grub configuration file with

$ sudo mousepad /etc/default/grub

There are various options available, for example, if you want to always show the menu when system boots you should modify your file by writing


If you want to, as said above, to press the esc key to show menu on boot, leave as:


Finally, if you ever make changes on GRUB configuration file, always run the command

$ sudo grub-mkconfig -o /boot/grub/grub.cfg

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.