UEFI Boot Problems

After fighting with Mesa/Cyberpunk to try to get Cyberpunk to run on my ARC GPU, I decided to replace my PC early and bought some parts. (See below. I was planning on building a new PC later this year, but the ARC problem prompted me to do it early.) However I am unable to get it to boot in UEFI mode with my live USB with the Manjaro image on it. I can get it to boot up in CSM mode with the USB, but not UEFI (which apparently means I can’t use some features of my hardware). I reimaged the USB to make sure it was OK, and my old AM4 machine with the ARC GPU in it boots up just fine from the USB in UEFI mode. I can also boot the AM5 machine from a Windows 10 boot USB too. It’s just the Manjaro USB that will not boot in UEFI mode on the AM5 machine.

I have tried turning off Secure Boot, and that had no impact. Does anyone have any ideas on what might be causing me to be unable to boot the Manjaro installation USB in UEFI mode on the below hardware?

MSI MAG B650 TOMAHAWK (Updated to BIOS version from 2023/05/29)
G.SKILL 64G 2X D5 6000 C36


1.) Manjaro USB will NOT boot in UEFI mode on AM5 machine.
2.) Manjaro USB WILL boot in UEFI mode on AM4 machine.
3.) Windows 10 USB WILL boot in UEFI mode on both machines.
4.) Manjaro USB WILL boot on AM5 machine in CSM (compatability) mode, but this disables some hardware features.
5.) Secure Boot has been tried both ON and OFF.

How’d you write the image?

And which ISO?

1 Like

The first time I believe it was Rufus. When I reimaged it I used imagewriter.
The ISO is the Plasma Desktop one from Manjaro Downloads. I downloaded it fresh on Sunday to make sure I had a recent version when the old one didn’t work.

There are more up to date images automatically built here:

You may try one of those given the new hardware and all.

1 Like

OK. How do I get the ISO out of those files? I grabbed the KDE version which says iso.zip but it looks like it’s not the whole thing. Do I need to combine the files somehow?

Oh yeah, I forgot about that.
See here:

1 Like

I had better luck with 7z by opening a console window in the folder where the parts were. The following command combined the parts and spat out the ISO file. (Just in case someone else stumbles on this topic some day and has the same problem.)

“7z x manjaro-kde-23.0-230717-linux63.iso.zip”

The AM5 PC still does not detect the Manjaro USB. But the same brand and capacity (bought at the same time) is detected. Both are detected on my old AM4 PC.

The images below show what the BIOS looks like when the Windows 10 USB is plugged in and when the Manjaro USB is plugged in.

there are 2 files that you have to download from the github page:


then check in bios if:
secure boot is disabled;
fast boot is disabled - you may not have this option;
fast startup is disabled in windows;

and use Ventoy to flash the usb.

1 Like

Does the system boot from a usb containing another non-secureboot OS?
I recently updated to a b650 board and had to delete the secureboot keys to get it to see my manjaro installation.
Though i did not have to reinstall so cant comment about the live CD. Just thought i’d mention the keys thing.

ETA: If you are dual booting windows this may wreck that if it relies on those keys.

1 Like

This seems to have been the problem. I did create a new USB stick with Ventoy as brahma suggested and used that rather than the live USB but I think the actual fix was deleting the Secure Boot Keys.

Thank you all very much for the assistance!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.