UEFI Boot or Drive not detected by Laptop

So my problem is that I have an Acer Aspire 5 (A515-56-56DJ) laptop that had windows preinstalled- never booted into windows as I preceded to run a Manjaro 20.2.1 liveusb installation on. I have a dell xps of my own that I have successfully installed Manjaro onto numerous times without issue (so I’m not stranger to the interface) - the laptop into in question is for my Nephew.

I have never done a UEFI install as this Laptop in devoid of the ability to use a legacy boot.

I went and disabled fast boot and secure boot in the bios.

I did the GUI installation and everything seemed to go well. Restarted the computer and BAM! slapped with an emergency shell with the message:

ERROR: resume: hibernation device 'UUID=00c29a38-0fbf-4bc3-b57e-0ebd706b2519' not found
mount: /new_root: can't find UUID=907b1aaf-e75d-444d-ae4b-bd667abfa344.
You are now being dropped into an emergency shell.
sh: can't access tty: job control turned off
[rootfs ]#

Also I am not dual booting. Many the similar issues I found had a dual booting scenario- I do not.

Things that I have tried since:

  • Reinstalling - choose the erase disk option and found that the new install yeilded EFI partion but the partitions being replaced did not show an EFI partition- that also happened the next time re-installation was tried, so as far as I can tell the GUI installer is claiming that it will make as EFI partion but does not.
  • Creating a new liveusb
  • reinstalling the grub (more on this in a few moments) - I did this because I found that the install DID NOT place any files into /boot/efi. But the laptop did not want the go to the bios after the grub was reinstalled, so does this mean that the computer saw, preventing access to the bios, but it but didn’t know what to do with it?
  • Manually partitioning the drive (it is an nvme) - the graphical manual installation DOES NOT have and ‘esp’ flag option.
  • even tried changing trusted bootloaders in the bios.
  • probably did a ton of other things I can remember trying.

I have looked at a number of other topic under support on the forum with similar symptoms but have not found a cause.

My best guess is that the drive needs to be partioned manually and the efi partition needs to be created using an ‘esp’ flag.

Please help!

1 Like

Hm… maybe try manual partitioning and before you make the partitions, create a new partition table to GPT. You can do it in the installer.

The current partition table might be MBR since it’s a Windows laptop.

I personally do 100MB for /boot/efi, and format it to FAT32.

Hey- thanks for the input!

Yep, did those too. GPT has been used each time installing it in various ways.

Tried using gparted from the liveusb too but found no place to add tags.
I can read the partitions from the liveusb and they do not read the partitions from the fresh install (laptop drive) as UEFI.

Hm… try one of these ISOs. They are release review ISOs that are using Kernel 5.10

I’ll give it a try.

I am unable to the unzip these files

You need both the .zip and .z01, then use 7z x <name.zip> to extract the ISO.

Ark can’t handle multi-part zips

Same result with this image. Got the emergency shell again.

Could TPM (TCM) in the BIOS interfere with an installation?

Thank you, the unzip was successful. I keep finding programs on this computer that I did realize it had.

Can you use your live usb to chroot into your fresh install and then recreate your uefi partition? I’ve used the guide from the old wiki to repair my uefi partition with chroot before, might be worth a try

Well that was kind of the thought at first - getting the UEFI partition to show up by giving it an ‘esp’ tag which is not given as an option in the installer. I haven’t tried the manual install yet with the 21.0 review image. So that may be my next move. If you have anymore thoughts just holler.

2 Likes

Can you try Architect, provided you have a steady internet connection as it seems better at handling HDDs (Manjaro Gnome already has a launcher icon to run architect).
efi partition should be minimum 300MB

I have tried to go through Architect and have not felt particularly confidant doing so, however I was able to confirm today that the EFI partition does in fact get created with an ‘esp’ tag. I finally figured out how to inspect the partitions and their flags in gparted. So now I seem to be leaning in the direction that there is a hardware setting in the BIOS that is preventing this.

I have been installing it with at least a 300MB EFI partition each time so that hasn’t been an issue I don’t believe.

I’m curious about the TPM (trusted platform mmmm…something) stuff and secure boot effects in this matter though…

TPM should not be an issue. I have TPM enabled on my laptop (HP-15Q-DS*).
However - just to check it once - hit Clear TPM (dont disable it). Clearing the TPM does no harm.
And see.

I didn’t get to try to clear the TPM, I instead tried to do one other thing that seemed like a good thing to try at the time: I have, in woeful manner gone and locked the computer down - I turned secure boot back on to access the trusted boot files and did not turn it off so now I am in a secure boot loop that does not permit access to the bios or permit booting from the usb either. Sigh… Think I’m done for a while, or least till I can figure this one out.

Fedora, Ubuntu and Open SUSE supports Seure boot - can you burn an ISO and see if you can install any of them?
Just for testing…
Dont go for Ubuntu LTS as it will probably wont support your hardware as it uses 5.4 kernel.

1 Like

I didn’t have a single issue installing fedora. At this point I have to assume it is a secure boot / TPM issue and not particularly worth me to explore more at this point. My main goal was to keep family away from MSW and give them a better experience and a can achieve that with most Linux distros. However I would love to get my nephew on Manjaro at one point (his mother has been on it for quite a while and has not a single issue). Should I encounter this on a new machine down the line I will happily explore those options.

Thank you all for your time in helping me explore this one.

1 Like

Looks like the manufacturer was sneaky and not actually disabling the secure boot (wild guess)…

haha - probably.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.