Ubuntu remote server and Vim


I just installed manjaro with i3wm and I was using ubuntu before.
I accessed to a remote ubuntu server via ssh and opened Vim to write a code.
However, i can’t use cut (or yank) and paste properly.
Previously with my ubuntu, i was able to cut and paste whatever i want, but now it only yank a single whole line. I first thought that i did something wrong during installation, but i can’t fix this problem even after i tried to reinstall manjaro. I also tested with various terminals too but they showed the same result.

I am really happy with manjaro now, I don’t wanna ditch it because of vim issue.

When you switch from an Ubuntu install to i3 wm on Manjaro it is like switching from a BMW735 to a sportscar with stickshift.

I cannot say which packages are required but valid options are xsel and xclip.

Also take into account the terminal emulator used which - as I recall - it is a variation of xterm (urxvt).

My problem is i cannot yank a word.
I just tried to access to the server through Windows too and it works fine.
Only Manjaro shows this problem. It only yanks a whole line…

I just installed xclip but it shows no difference.

I am not sure what should I do…
I may have to go back to ubuntu.

I work with server very frequently over ssh - and I have no issues with copy/pasting - so I am very convinced it is a configuration issue on your side.

But I don’t what as I am not using i3 but I am fairly certain it is connected to the terminal emulator chosen by the maintainer of i3.

If you want to continue using a tiling wm like i3 you should learn how it works and how to configure the system instead of giving up.

Actually, I have been using i3wm with Ubuntu and I didn’t have this issue before.
Also, my local vim in Manjaro has no issue. The issue only happens in the remote server.
Thank you for your suggestion. I will take a look thanks.

I didn’t mean to offend - merely suggesting to look into the terminal emulator used - and a base Manjaro is different than Ubuntu with respect to the set of packages - and you may simply be missing packages which is needed to make the two terminals communicate the copy/paste correct.

I have never been a tiler but I do remember that urxvt does things differently.

I also remember that on the Manjaro i3 edition - the terminal is hardcoded into a script in /usr/bin and you need to change your local i3.conf to use another virtual terminal.

Just remembered another thing - it could be because the remote machine is missing the terminfo for urxvt - or terminafo for the remote terminal is missing on your i3 system.

One thing is the line terminator - which I suspect is different - hence the paste is considered one long line - instead of breaking it up as it was copied.

Thanks a lot.
I tried urvxt, xterm, alacritty, terminator and gnome-terminal so far.
I am not an expert on Linux so I just tried everything I can do :slight_smile:
They all showed the same issue.

Neither am I :slight_smile: long time user but expert, no. I know only the most basic commands of vi so I wouldn’t know how to paste a multiline content into vim.

Just booted the i3 minimal iso - connected to the pi I have running ubuntu - fired up vim on ubuntu.

Then I opened palemoon and copied the first two paragraphs. I then pasted them into vim using Ctrl+Shift+v. As this is done on a Manjaro i3 ISO - I am fairly certain your issue isn’t related to Manjaro but rather is local to your system - what it is - I have no idea.


Ok, it seems it is the server issue.
I just tried to access another server but it shows no issue.
Also, I tried to access the server with the issue via ubuntu after a clean install, but it still shows the issue.
Do you have some idea how to fix this issue?

Ok it was my Vim configuration issue. I removed a plugin called esayclip then it shows no error. Thank you for your suggestions and help! I really appreciate it.
However, this is a bit weird that plugin showed no issue in other ubuntu servers.

Anyway, thanks again!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.