(u)efi boot issues

So, after several days of investigating, from my point of view, I can only draw the conclusion that something doesn’t seem to be adding up with the manjaro isos. No matter what I try, either build my own using grub configured in the profile, systemd-boot doesn’t make an iso for some reason, or using an official iso, the result remains unchanged. If I restart my system holding down the shift key, to get to the windows troubleshooting screen, activate “use a device” and select my thumbdrive, the system boots, but not in (u)efi mode… I can easaly verify this by running efibootmgr -v and it always returns that the system does not support efi variables. This goes for both my asrock b450 steel legend system, as well as my macbook air 2011. This in particular is an issue since this means I can not install using cli, since it won’t accept going u(efi) nor will I be able to use a manjaro iso to rescue a modern system. Are we really holding on to mbr booting in the year 2021 allmost 2022?

Most UEFI implementations will always attempt to boot in legacy BIOS mode if this is enabled in the settings. You really do have to disable CSM (legacy BIOS emulation) in the UEFI settings to force them to boot in native UEFI mode on bootable media that supports both boot methods.


1 Like

2 reasons why I think it’s really not the hardware:
1 rufus doesn’t allow me to pick the partition table used (on manjaro isos only). Arch, mint, windows… they all offer me the list to pick between mbr and gpt (non csm).
2. apple doesn’t have a bios to configure this in, so there might be a selection issuor so, not sure. But, if I boot arch, mint, or windows using the method above, they all end up in efi.

To clarify a few things:

  • macbook: no osx, disk got repartitioned before installing first windows, then trying to get manjaro up and running. I followed the cli guide, but couldn’t finish the grub-install part and consequently the
    grub-mkconfig . After booting into the arch iso I had lying around, efibootmgr returned efi values and lo and behold, the installation was finished… and, windows got detected, and yes, the efi partition had ms files, so that at least is that.
  • Main system: I had secure boot on till last week, so that by default disabled csm, so I asked a sighted person to help me turn secure boot off, but not to turn on csm, so unless it did that by default, wich i doubt…
    The funky thing at least to my mind is that windows seems to recognize it’s an uefi usb or so, since it always says uefi usb sandisk …, then harddrive and then just usb.
  • Media creation: I used multiple thumb drives, used multiple isos, used etcher and rufus and for lols and giggles i’ll just flat copy / extract an iso on a fat32 drive … gpt table and all, and see where I end up…

The MacBook is too old to support UEFI. A quick search says it’s a Sandy Bridge based laptop but UEFI was first introduced on the Ivy Bridge arch. I remember getting a Win 7 Ivy Bridge HP but they introduced the same laptop with Windows 8 a couple of months later with a different motherboard. The desktop should be alright though. I’d probably download a rescue iso and create a linux live USB using the rescue ISO and not Windows. Make sure you start the live USB systems from the /BOOT/EFI forder on the USB and Grubx64.efi file. The old MBR systems used to boot automatically as the Grub was installed in the MBR and not on a special partition that didn’t require a special settings in the BIOS. After a UEFI system is installed you have to change the path in UEFI to the default Grubx64.efi file on the hard drive because the default boot is set to the Windows bootloader.

I could be off with the year, anywho it does support efi since both win10 and manjaro " installed using cli for efi" were found by installing grub for efi target. So, I did some more digging around, and as I said, copyed the iso contents to my usb drive through windows explorer… Still, even though the windows boot app recognises it as gpt partition, it refused to boot manjaro in efi mode. Since I’m totally blind, I used the tryed and true method of pressing enter / waiting without any selection or so what so ever. I’m starting to wonder if the mistake isn’t there, since I’ve read that people had to pick mbr or efi install etc, so what if that’s the grub menu. The method of pressing enter worked for latest arch iso and also mint, so i’m totaly confused why it doesn’t now. Also, does it matter on what kind of system the iso was made on? (i’m just trying to figure this whole thing out, since i made the talking mate iso finally include braille with orca, so I’d rather use that to get my main system setup…)

Still no luck in getting the iso to boot in efi. Even went as far as burning a phisical disc, just to rule out it being the usb drive written to or something of the sort. One thing I’ve learned is to not use 7zip to extract the iso. Other than that copying the contents on to a fat32 drive, still boots fine, but again in mbr only. I also used ventoy to see if that might help, but no luck. I also tryed figuring out if I could get grub to change or so, but that didn’t help, since the only bits i could find were for changing language and keyboard, and removing the module loading for dos partitions just probably borked it. I have one final attempt left, though I’m not even sure if i want to pursue the endeavor, seeing as it would require me to follow a whole guide on making isos with syslinux and all… But one can also say that things are getting stupidly desperate and frustrating, with my brain always asking" Is it really so hard to just simply boot in efi mode by default…"

system information below… Note that after the test command, i inserted efibootmgr -v from arch disc.

inxi -Fxxxza
  Kernel: 5.15.5-1-rt22-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC misobasedir=manjaro
    misolabel=MANJARO_TALKINGMATEM_ quiet systemd.show_status=1 driver=free nouveau.modeset=1
    i915.modeset=1 radeon.modeset=1
  Console: tty 2 DM: LightDM 1.30.0 Distro: Manjaro Linux base: Arch Linux
  Type: Desktop Mobo: ASRock model: B450 Steel Legend serial:  UEFI: American Megatrends
    v: P3.50 date: 09/23/2020
  Info: model: AMD Ryzen 7 3800X socket: AM4 bits: 64 type: MT MCP arch: Zen 2 family: 0x17 (23)
    model-id: 0x71 (113) stepping: 0 microcode: 0x8701021
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache: L1: 512 KiB
    desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB L3: 32 MiB desc: 2x16 MiB
  Speed (MHz): avg: 3475 high: 3900 min/max: 2200/4559 boost: enabled base/boost: 3900/4550
    scaling: driver: acpi-cpufreq governor: schedutil volts: 1.1 V ext-clock: 100 MHz cores:
    1: 2200 2: 2200 3: 3900 4: 3900 5: 3900 6: 3900 7: 3900 8: 3900 9: 3900 10: 2200 11: 3900
    12: 2200 13: 3900 14: 3900 15: 3900 16: 3900 bogomips: 124568
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2
    mitigation: Full AMD retpoline, IBPB: conditional, STIBP: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA TU104 [GeForce RTX 2060] vendor: eVga.com. driver: nouveau v: kernel
    bus-ID: 0b:00.0 chip-ID: 10de:1e89 class-ID: 0300
  Device-2: Future Devices Papenmeier Braille-Display type: USB driver: usbfs bus-ID: 1-10:3
    chip-ID: 0403:f208 class-ID: 0000
  Display: server: X.org compositor: marco v: 1.26.0 driver: loaded: modesetting
    alternate: fbdev,vesa tty: 240x67
  Message: Unable to show advanced data. Required tool glxinfo missing.
  Device-1: NVIDIA TU104 HD Audio vendor: eVga.com. driver: snd_hda_intel v: kernel
    bus-ID: 0b:00.1 chip-ID: 10de:10f8 class-ID: 0403
  Device-2: AMD Starship/Matisse HD Audio vendor: ASRock driver: snd_hda_intel v: kernel
    bus-ID: 0d:00.4 chip-ID: 1022:1487 class-ID: 0403
  Device-3: Blue Microphones Yeti Stereo Microphone type: USB
    driver: hid-generic,snd-usb-audio,usbhid bus-ID: 5-3:4 chip-ID: b58e:9e84 class-ID: 0300
  Sound Server-1: ALSA v: k5.15.5-1-rt22-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASRock driver: r8169
    v: kernel port: d000 bus-ID: 09:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp9s0 state: up speed: 1000 Mbps duplex: full mac: 
  Local Storage: total: 6.19 TiB used: 11.2 GiB (0.2%)
  ID-1: /dev/nvme0n1 maj-min: 259:4 vendor: Samsung model: SSD 970 EVO Plus 250GB
    size: 232.89 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD
    serial:  rev: 2B2QEXM7 temp: 30.9 C scheme: GPT
  SMART: yes health: PASSED on: 1y 17d 17h cycles: 443 read-units: 15,237,031 [7.80 TB]
    written-units: 20,496,928 [10.4 TB]
  ID-2: /dev/nvme1n1 maj-min: 259:0 vendor: Corsair model: Force MP500 size: 223.57 GiB
    block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: 
    rev: E7FM04.C temp: 52.9 C scheme: GPT
  SMART: yes health: PASSED on: 1y 158d 14h cycles: 623 read-units: 13,677,728 [7.00 TB]
    written-units: 17,150,657 [8.78 TB]
  ID-3: /dev/sda maj-min: 8:0 vendor: HGST (Hitachi) model: HDN726060ALE610
    family: Deskstar NAS size: 5.46 TiB block-size: physical: 4096 B logical: 512 B sata: 3.1
    speed: 6.0 Gb/s type: HDD rpm: 7200 serial:  rev: T517 temp: 34 C scheme: GPT
  SMART: yes state: enabled health: PASSED on: 4y 73d 4h cycles: 1618
  ID-4: /dev/sdb maj-min: 8:16 type: USB vendor: SanDisk model: Extreme Pro drive model: pSSD
    family: based SSDs size: 119.25 GiB block-size: physical: 512 B logical: 512 B sata: 3.0
    speed: 6.0 Gb/s type: SSD serial:  drive serial:  rev: 6EB 1030 temp: 8 C
    scheme: GPT
  SMART: yes state: enabled health: FAILED! on: 42 hrs read: 0 KiB written: 0 KiB Pre-Fail:
    attribute: Perc_Avail_Resrvd_Space threshold: 5 alert: FAILING_NOW
  ID-5: /dev/sdc maj-min: 8:32 type: USB vendor: SanDisk model: USB 3.2Gen1 size: 57.3 GiB
    block-size: physical: 512 B logical: 512 B type: N/A serial:  rev: 1.00 scheme: GPT
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
  ID-6: /dev/sdd maj-min: 8:48 type: USB vendor: Kingston model: DT Elite G2 size: 115.5 GiB
    block-size: physical: 512 B logical: 512 B type: N/A serial:  rev: PMAP scheme: MBR
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
  Alert: No swap data was found.
  System Temperatures: cpu: N/A mobo: N/A gpu: nouveau temp: 28.0 C
  Fan Speeds (RPM): N/A gpu: nouveau fan: 944
  Processes: 398 Uptime: 13m wakeups: 0 Memory: 15.55 GiB used: 1.25 GiB (8.1%) Init: systemd
  v: 249 tool: systemctl Compilers: gcc: N/A Packages: pacman: 970 lib: 279 Shell: Bash (login)
  v: 5.1.12 running-in: tty 2 inxi: 3.3.10
parted -l
Model: ATA HGST HDN726060AL (scsi)
Disk /dev/sda: 6001GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number Start End Size File system Name Flags
1 17.4kB 134MB 134MB Microsoft reserved partition msftres
2 135MB 6001GB 6001GB Basic data partition msftdata

Model: SanDisk Extreme Pro (scsi)
Disk /dev/sdb: 128GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags:

Number Start End Size File system Name Flags
1 1049kB 128GB 128GB Main Data Partition msftdata

Model: USB SanDisk 3.2Gen1 (scsi)
Disk /dev/sdc: 61.5GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags:

Number Start End Size File system Name Flags
1 1049kB 61.5GB 61.5GB ext3 Main Data Partition msftdata

Model: Kingston DT Elite G2 (scsi)
Disk /dev/sdd: 124GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number Start End Size Type File system Flags
2 2733MB 2738MB 4194kB primary esp

Model: Samsung SSD 970 EVO Plus 250GB (nvme)
Disk /dev/nvme0n1: 250GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags:

Number Start End Size File system Name Flags
1 1049kB 556MB 555MB ntfs Basic data partition hidden, diag
2 556MB 661MB 105MB fat32 EFI system partition boot, esp
3 661MB 677MB 16.8MB Microsoft reserved partition msftres
4 677MB 250GB 249GB Basic data partition msftdata

Model: Force MP500 (nvme)
Disk /dev/nvme1n1: 240GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags:

Number Start End Size File system Name Flags
1 17.4kB 16.8MB 16.8MB Microsoft reserved partition msftres
2 16.8MB 157GB 157GB ntfs Basic data partition msftdata
3 157GB 208GB 50.5GB ntfs Basic data partition msftdata

efibootmgr -v
EFI variables are not supported on this system.
test -d /sys/firmware/efi && echo efi || echo bios
efibootmgr -v
BootCurrent: 0005
Timeout: 1 seconds
BootOrder: 0000,0005,0001,0004
Boot0000* Windows Boot Manager	HD(2,GPT,a78085cf-0bdb-4209-b0d8-64e644327b54,0x109000,0x32000)/File(\EFI\MICROSOFT\BOOT\BOOTMGFW.EFI)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.}...a................
Boot0001* Hard Drive	BBS(HD,,0x0)..GO..NO........q.S.a.m.s.u.n.g. .S.S.D. .9.7.0. .E.V.O. .P.l.u.s. .2.5.0.G.B....................A...........................%8S.@_......4..Gd-.;.A..MQ..L.S.4.E.U.N.J.0.N. .M.P.5.0.0....................A...................................................>..Gd-.;.A..MQ..L. .H.D.N.>..Gd-.;.A..MQ..L.A.N.A.G.R.X.X.B. . . . . . . . . . . . ........BO
Boot0004* USB	BBS(USB,,0x0)..GO..NO........q.S.a.n.D.i.s.k. .E.x.t.r.e.m.e. .P.r.o. .0....................A.............................>..Gd-.;.A..MQ..L. .U.S.B....................A................................Gd-.;.A..MQ..L. .E.l.i.t.e. .G.2. .P.M.A.P....................A.............................F..Gd-.;.A..MQ..L.2.0.C.F.
Boot0005* UEFI: KingstonDT Elite G2 PMAP, Partition 1	PciRoot(0x0)/Pci(0x1,0x3)/Pci(0x0,0x0)/USB(3,0)/HD(1,GPT,ad1de5ef-40b2-4908-98e3-8633f265952a,0x800,0xe6ff7df)..BO

The MacBook is too old to support UEFI.

Intel Macbooks and Imacs support 32bit Uefi since 2006 and 64bit since 2008/09.

I’m not a Mac user so sorry about the bad info. I don’t understand what you are trying to do.

What I’m trying to do is get my manjaro iso’s to boot in efi mode so I can install a “rescue system” on usb and if that works out on my main system. My macbook already has a working efi copy but that’s only because I used an arch iso to complete the grub installation since there the efi variables did show up. I had to use a “custom iso” that included brltty, orca, and espeakup, due to my visual impairment, and so it’s becoming a chore to get things to work just like they should. This is also why I use the win10 selecting of a boot device, at least on my main system.

I might have found a sollution, but this will need a bit of further investigation… But, it seems to me that the way isos are made is key here, and that’s sadly missing from the buildiso instructions. If a system is non efi , or has no variables exposed, it seems as though then the iso is made in mbr / bios mode only, while having efi vars exposed seems to make the iso image more kean on booting efi modes too…
I’ll have to cycle through a few images I made on a vm and a few made on my macbook to see if that’s true, so i’ll get back if there’s more, unless other people can give this a wurl too…