Two versions of Spectre Meltdown Checker installed

I realized this morning that I have two versions of spectre-meltdown-checker installed - from the Official Repositories and from the AUR.

When I remove the AUR version it also removes the Official Repositories version. When I reinstall the Official Repositories version it also reinstalls the AUR version.

How do I fix this?

Here’s my /etc/pacman.conf file for reference (I’ve never altered this file before):

# /etc/pacman.conf
# See the pacman.conf(5) manpage for option and repository directives

# The following paths are commented out with their default values listed.
# If you wish to use different paths, uncomment and update the paths.
#RootDir     = /
#DBPath      = /var/lib/pacman/
#CacheDir    = /var/cache/pacman/pkg/
#LogFile     = /var/log/pacman.log
#GPGDir      = /etc/pacman.d/gnupg/
#HookDir     = /etc/pacman.d/hooks/
HoldPkg      = pacman glibc manjaro-system
# If upgrades are available for these packages they will be asked for first
SyncFirst    = manjaro-system archlinux-keyring manjaro-keyring
#XferCommand = /usr/bin/curl -L -C - -f -o %o %u
#XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u
#CleanMethod = KeepInstalled
Architecture = auto

#IgnorePkg   =
#IgnorePkg   =
#IgnoreGroup =

#NoUpgrade   =
#NoExtract   =

# Misc options
ParallelDownloads = 4

# By default, pacman accepts packages signed by keys that its local keyring
# trusts (see pacman-key and its man page), as well as unsigned packages.
SigLevel    = Required DatabaseOptional
LocalFileSigLevel = Optional
#RemoteFileSigLevel = Required

# NOTE: You must run `pacman-key --init` before first using pacman; the local
# keyring can then be populated with the keys of all official Manjaro Linux
# packagers with `pacman-key --populate archlinux manjaro`.

#   - can be defined here or included from another file
#   - pacman will search repositories in the order defined here
#   - local/custom mirrors can be added here or in separate files
#   - repositories listed first will take precedence when packages
#     have identical names, regardless of version number
#   - URLs will have $repo replaced by the name of the current repo
#   - URLs will have $arch replaced by the name of the architecture
# Repository entries are of the format:
#       [repo-name]
#       Server = ServerName
#       Include = IncludePath
# The header [repo-name] is crucial - it must be present and
# uncommented to enable the repo.

Include = /etc/pacman.d/mirrorlist

Include = /etc/pacman.d/mirrorlist

# If you want to run 32 bit applications on your x86_64 system,
# enable the multilib repositories as required here.

Include = /etc/pacman.d/mirrorlist

# An example of a custom package repository.  See the pacman manpage for
# tips on creating your own repositories.
#SigLevel = Optional TrustAll
#Server = file:///home/custompkgs

How did you install it? If you use pacman then it cannot install any package from the AUR, because pacman has no access to the AUR.

Try this:arrow_down:

sudo pacman -Rdd spectre-meltdown-checker && sudo pacman -S spectre-meltdown-checker

I don’t remember installing it at all, but it was probably with pamac (gui). I’ll try your advice.

In that case, it was probably when the Community repo was nuked, which coincided with pamac having some serious issues. :thinking:

I uninstalled both versions from Pamac (gui), then installed with pacman. Now both are listed as installed when I view in Pamac. Weird…

I wonder if there’s a bug in the Pamac gui? When I run pamac list -m the spectre-meltdown-checker doesn’t show as installed from the AUR. It’s a mystery, or maybe there’s a setting I need to adjust.

I have just checked in the pamac GUI here on my system, and it shows three versions…:

  1. the official Manjaro one;
  2. an AUR one with the same version number; and
  3. an AUR one with an older version.

It only shows the first one as installed. Have you updated the databases?

Yes, I have. I can see all 3 in my pamac gui as well. 1 and 2 are shown as installed in the gui, but the pamam CLI only shows the official repository version as installed.

Then there must be something seriously amiss with your pamac GUI. There is no other explanation. :face_with_raised_eyebrow:

What version of the GUI are you using? Mine is pamac-gtk3 10.5.3. Are you by any chance using the pamac version from the AUR instead of the official Manjaro one? :thinking:

Edit: I’ve just discovered some weirdness here myself. According to octopi, I have pamac-cli from the AUR installed, while I never did such a thing. But it’s possible that this is a package that was dropped from the repo and that it therefore shows up as an AUR package.

“Curiouser and curiouser”, said Alice… :face_with_raised_eyebrow:

That’s the same version I’m running. I don’t have octopi, but according to pamac gui I have the following installed:

Official Repositories:


However, when i run pamac list -m nothing that the AUR reports for pamac gui above is listed…

Its just listing packages that also have the same name in the AUR.

1 Like

Why would the Pamac GUI show that behavior, but not Pamac CLI?

Because pamac gui (if the setting is one) does both.
pamac-cli you have to use AUR commands for aur … ex ‘build’ instead of ‘install’ or ‘search -a’, etc.

( pamac has had this problem for a while … people end up with AUR packages without realizing it … pamac would even replace one with the other during upgrades … double funny because some of the packages are pamac specifically … leading to a broken pamac because it is made up partially of aur pamac packages that pamac accidentally replaced itself with )

1 Like

Thanks for your explanation!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.