Two pines but only one phones

I have two pinephones, one alpha and one beta. I’m trying to get the beta up and running but it does not send or receive calls. At first I though it was the sim because there was a similar problem on a normal phone but I’ve tried it out on the alpha phone and that one sends and receives calls just fine. They are both on the same image, the most recent download. I’ve tried updating them but they get borked on the update.

Does the modem show up in lsusb? You should have a line like this:

Bus 002 Device 003: ID 2c7c:0125 Quectel Wireless Solutions Co., Ltd. EC25 LTE modem

It’s claiming

bash: lsusb: command not found...

for lsusb but the output of mmcli -L is

    /org/freedesktop/ModemManager1/Modem/0 [QUALCOMM INCORPORATED] QUECTEL Mobile Broadband Module

Not entirely sure why it’s doing that, ls works just fine.

lsusb is a separate command from ls, I guess it is simply not installed. (It is a diagnostic tool, not strictly necessary to operate the system.)

But it looks like your modem is at least detected, so I am not sure why it is not doing calls.