Two out of three screens go black after login

I’ve been trying to tackle this problem for a while now. After an updating a couple of months ago I’ve been getting this issue where on the login screen I see all three of my monitors, but after logging in one of my external monitors and my laptop screen go black.

I tried different kernels switching between recommended kernels and updating to the 6.0 kernel.
I’ve tried using the video-nvidia and the video-nvidia-470xx drivers.
Tried switching my laptop between discrete graphics and dynamic graphics.

Nothing really seems to be working. If anyone has any suggestions it would very much be appreciated.

inxi -Fxxz

  Kernel: 6.0.15-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    Desktop: KDE Plasma v: 5.26.4 tk: Qt v: 5.15.7 wm: kwin_x11 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: LENOVO product: 82JQ v: Legion 5 Pro 16ACH6H
    serial: <superuser required> Chassis: type: 10 v: Legion 5 Pro 16ACH6H
    serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: SDK0R32862 WIN
    serial: <superuser required> UEFI: LENOVO v: GKCN36WW date: 04/21/2021
  ID-1: BAT0 charge: 73.3 Wh (100.0%) condition: 73.3/80.0 Wh (91.7%)
    volts: 17.1 min: 15.4 model: Celxpert L20C4PC1 serial: <filter> status: full
  Device-1: hid-dc:2c:26:07:77:6c-battery model: Keychron K1 serial: N/A
    charge: N/A status: discharging
  Device-2: hidpp_battery_0 model: Logitech Wireless Mouse MX Master 3
    serial: <filter> charge: 100% (should be ignored) status: discharging
  Info: 8-core model: AMD Ryzen 7 5800H with Radeon Graphics bits: 64
    type: MT MCP arch: Zen 3 rev: 0 cache: L1: 512 KiB L2: 4 MiB L3: 16 MiB
  Speed (MHz): avg: 1700 high: 4062 min/max: 400/4463 boost: enabled cores:
    1: 400 2: 400 3: 2992 4: 400 5: 400 6: 3063 7: 4062 8: 400 9: 3322 10: 400
    11: 400 12: 3231 13: 3549 14: 400 15: 3396 16: 400 bogomips: 102243
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Device-1: NVIDIA GA106M [GeForce RTX 3060 Mobile / Max-Q] vendor: Lenovo
    driver: nvidia v: 525.60.11 arch: Ampere pcie: speed: 8 GT/s lanes: 8
    bus-ID: 01:00.0 chip-ID: 10de:2560
  Display: x11 server: X.Org v: 21.1.6 compositor: kwin_x11 driver: N/A
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3440x1440 s-dpi: 184
  Monitor-1: DP-2 size-res: N/A
  Monitor-2: DP-4 size-res: N/A
  Monitor-3: HDMI-0 pos: primary res: 3440x1440 dpi: 109
    diag: 867mm (34.15")
  API: OpenGL v: 4.6.0 NVIDIA 525.60.11 renderer: NVIDIA GeForce RTX 3060
    Laptop GPU/PCIe/SSE2 direct render: Yes
  Device-1: NVIDIA GA106 High Definition Audio driver: snd_hda_intel v: kernel
    pcie: speed: 8 GT/s lanes: 8 bus-ID: 01:00.1 chip-ID: 10de:228e
  Device-2: AMD Family 17h/19h HD Audio vendor: Lenovo driver: snd_hda_intel
    v: kernel pcie: speed: 8 GT/s lanes: 16 bus-ID: 05:00.6 chip-ID: 1022:15e3
  Sound API: ALSA v: k6.0.15-1-MANJARO running: yes
  Sound Server-1: JACK v: 1.9.21 running: no
  Sound Server-2: PulseAudio v: 16.1 running: yes
  Sound Server-3: PipeWire v: 0.3.63 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Lenovo driver: r8169 v: kernel pcie: speed: 2.5 GT/s lanes: 1
    port: 2000 bus-ID: 03:00.0 chip-ID: 10ec:8168
  IF: eno1 state: down mac: <filter>
  Device-2: Realtek RTL8852AE 802.11ax PCIe Wireless Network Adapter
    vendor: Lenovo driver: rtw89_8852ae v: kernel pcie: speed: 2.5 GT/s lanes: 1
    port: 1000 bus-ID: 04:00.0 chip-ID: 10ec:8852
  IF: wlp4s0 state: up mac: <filter>
  Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8
    bus-ID: 3-4:2 chip-ID: 0bda:4852
  Report: rfkill ID: hci0 rfk-id: 2 state: up address: see --recommends
  Local Storage: total: 953.87 GiB used: 77.33 GiB (8.1%)
  ID-1: /dev/nvme0n1 vendor: SK Hynix model: HFS001TDE9X084N
    size: 953.87 GiB speed: 31.6 Gb/s lanes: 4 serial: <filter> temp: 41.9 C
  ID-1: / size: 937.53 GiB used: 77.33 GiB (8.2%) fs: ext4 dev: /dev/nvme0n1p2
  ID-2: /boot/efi size: 299.4 MiB used: 312 KiB (0.1%) fs: vfat
    dev: /dev/nvme0n1p1
  Alert: No swap data was found.
  System Temperatures: cpu: 46.1 C mobo: N/A gpu: nvidia temp: 37 C
  Fan Speeds (RPM): N/A
  Processes: 304 Uptime: 13m Memory: 15.49 GiB used: 2.7 GiB (17.4%)
  Init: systemd v: 252 default: graphical Compilers: gcc: 12.2.0 clang: 14.0.6
  Packages: 1327 pm: pacman pkgs: 1319 pm: flatpak pkgs: 8 Shell: Zsh v: 5.9
  running-in: konsole inxi: 3.3.24

Anyone any ideas?

  1. Are all the monitors recognized in KDE settings → Display Configuration?
  2. Do all monitors show output on Wayland if you currently use xorg? What about the other way around?
  3. Have you tried explicitly defining connected monitors as shown in PRIME - ArchWiki - section 3.1?
  4. Are these any errors/warnings shown in journalctl?
  5. Have you tried adding Nvidia modules to KMS Kernel mode setting - ArchWiki ?

Just some of the things that I’ve had to try when I got a laptop with Nvidia card.

I think KDE devs know multi-monitor isn’t working well, apparently they are working on it though according to this post: Plasma 5.27 Beta - KDE Community