Tuxedo Pulse 15 Touchpad suddenly stopped working

After months without problems, the touchpad of my Tuxedo Pulse 15 suddenly stopped working when i unplugged my external keyboard, LAN and an HDMI Monitor.
It also doesn’t show up under “xinput list”:

⎡ Virtual core pointer                    	id=2	[master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer              	id=4	[slave  pointer  (2)]
⎜   ↳ Logitech MX Master                      	id=10	[slave  pointer  (2)]
⎣ Virtual core keyboard                   	id=3	[master keyboard (2)]
    ↳ Virtual core XTEST keyboard             	id=5	[slave  keyboard (3)]
    ↳ Power Button                            	id=6	[slave  keyboard (3)]
    ↳ Video Bus                               	id=7	[slave  keyboard (3)]
    ↳ Power Button                            	id=8	[slave  keyboard (3)]
    ↳ Sleep Button                            	id=9	[slave  keyboard (3)]
    ↳ HD Webcam: HD Webcam                    	id=11	[slave  keyboard (3)]
    ↳ HD Webcam: IR Camera                    	id=12	[slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard            	id=13	[slave  keyboard (3)]
    ↳ Logitech MX Master                      	id=14	[slave  keyboard (3)]

My external USB mouse still works as intended.

Anybody has an idea how to fix this?

Do you see a green led on the touch pad?

Normally if it’s on that mean you have turned on the touch pad using the key combination on the keyboard.

Try to turn it on again and see if that helps.

I don’t see a led on the touchpad, but the keyboard shortcut of fn + f9 doesn’t change anything.
I also tried the tuxedo-touchpad-switch tool with the following output:

Your desktop environment is not supported.
No compatible touchpads found.
gracefull_exit(...): set_touchpad_state(...) failed.

Same behaviour for both, XFCE and i3wm.

Output under KDE:

No compatible touchpads found.
kded5_modules_touchpad_handler(...): set_touchpad_state(...) failed.
setup_kde(...): kded5_modules_touchpad_init(...) failed.
main(...): setup_kde(...) failed.
No compatible touchpads found.
gracefull_exit(...): set_touchpad_state(...) failed.

I just booted into an Ubuntu 22.04 live instance, where the touchpad worked flawlessly again.
Therefore a hardware error can probably be ruled out.

1 Like

Will have to check with Tuxedo team.

Tried a different kernel?

1 Like

Thanks a lot.
Changing from 5.19 to 5.15 solved the problem for now, will try to upgrade to a newer kernel tomorrow and report if it works again for those.
Still strange behavior since it worked on 5.19 for a while and just stopped when i unplugged some cables (HDMI, LAN, USB Keyboard and AUX)

Sound like the newer kernel version have some changes which breaks the drivers.
Do you have 5.19-headers for the dkms pkgs to be compiled.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.