Tutanota Desktop: Could not access secret storage in the desktop client

Hi! I use Tutanota Desktop (an email app client) and now when I open this application there’s a window with this error message “Could not access secret storage in the desktop client”.
I’ve tried this application in the 2 versions I’ve found (AUR and appimage) and both have the same problem.

In the Tutanota’s FAQ there’s this note …

Tutanota desktop app uses system keychain to be able to encrypt sensitive details such as credentials and alarms. On Linux there must be an app installed which provides secret storage. This is usually set up together with the rest of the desktop environment but sometimes it requires manual setup.

I think the KDE Plasma application for handling keys is called Wallet Manager.
Does anybody know how to set up the system in order to handle Tutanota’s keys?

Thanks in advance!

I had to look up what “Tutanota Desktop” even meant, what it was/is.
It seems to be an e-mail app/e-mail client with focus on security/encryption.

From this post it is not clear what your problem (with it) is.
Not to me, anyways.

1 Like

I’m sure you’re right.
There are 3 problems, I’m still a newbie, my English is not as good as it should and a lot of times I can’t make myself clear.
I’ve changed the original post.
Thanks!

Do you have kwallet installed? kwalletmanager is the configuration GUI.

1 Like

from the AUR package page (AUR (en) - tutanota-desktop) i read that you need libsecret installed as its a request to add it at a dependency for the package.

jowlo commented on 2021-04-14 13:47
Would you mind adding libsecret as a dependency. The electron app uses keytar to store credentials for push notifications. keytar depends on some secret storage provider.

1 Like

It was added it as a dependency. :wink:

2 Likes

I do have installed kwalletmanager and libsecret.
There’s a place in KWalletManager called Applications and 2 sections:

  • These applications are currently connected: (kawalletmanager5 and kded5)
  • These applications are authorized to access this wallet: (empty)
    There isn’t an option to add anything.

You need org.freedesktop.secrets. This is supplied by gnome-keyring. Kwallet has never added it, and libsecret does not provide it as well. Unfortunately you must install gnome-keyring to get any electron apps using keytar to work.

2 Likes

The Tutanota Desktop packages are now updated to depend on org.freedesktop.secrets instead of libsecret.

2 Likes

I have checked the Solution box because the problem I was asking about is solved by installing the gnome-keyring, BUT with this package in my system I have new problems.

Tutanota doesn’t show the error message anymore but it doesn’t remember my email password.
I have to type it every time I start this application.
There’s a general error message (“An application wants to access the keyring”) every time I start Linux.

So I have uninstalled the gnome-keyring package.
At least, I have learned new things.
Thank you very much!!

Can you reproduce it with the AppImage?

If so, you could open an issue. Just be sure to mention you tried both the AppImage and the AUR package. If you do open an issue, let me know here.

EDIT: This issue may be related since you’re using KDE:

1 Like

The problem is the same using both versions.
I use the appimage version now.

I have just written a post in Reddit [r/tutanota]

Thanks!

I have found a “solution” that works for me.
I have given up using this application and I’ve decided to use something else.

I have installed chromium-snapshot-bin from aur
I have created a link in the system menu with these values:

Name: Tutanota Mail
Comment: The desktop client for Tutanota, the secure e-mail service.
Command: chromium-snapshot-bin --app=https://mail.tutanota.com
I have assigned the right icon downloaded previously.

I think this is called the App Mode in Google Chromium.
There are no bars (address, tools) at all. It looks like the Tutanota app.

I hope it works for somebody else too.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.