Turned off wifi to save power and now bluetooth and wifi are broken - also deja dup won't restore

Hello! I was on a plane yesterday and turned off my wifi from the menu in this picture. I just toggled wifi to off to save battery.

When I tried to toggle it back on, it was gone. No wifi option in the menu (removed picture). Bluetooth keeps flickering between “No Bluetooth Found” and “Bluetooth turned off”.

I have tried everything on this forum, and everything I can find online. Nothing works to turn or unblock the wifi / Bluetooth.

I tried to use my deja dup restores to see if maybe I can revert to how it was a week ago, and it says “last backup 9 days ago” but in the restore tab it says “no backups found”.

Here is the output of inxi -Fazy:

  Kernel: 5.10.114-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64
    root=UUID=c7c6d7ad-b3d4-41ba-9746-938c01bb3799 rw
  Desktop: GNOME v: 42.1 tk: GTK v: 3.24.33 wm: gnome-shell dm: GDM v: 42.0
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: Razer product: Blade 14 - RZ09-0370 v: 1.04
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: Razer model: PI411 v: 4 serial: <superuser required> UEFI: Razer
    v: 1.06 date: 06/07/2021
  ID-1: BAT0 charge: 62.1 Wh (100.0%) condition: 62.1/61.6 Wh (100.7%)
    volts: 17.5 min: 15.4 model: Razer Blade type: Unknown serial: <filter>
    status: full
  Info: model: AMD Ryzen 9 5900HX with Radeon Graphics bits: 64 type: MT MCP
    arch: Zen 3 family: 0x19 (25) model-id: 0x50 (80) stepping: 0
    microcode: 0xA50000C
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
    L3: 16 MiB desc: 1x16 MiB
  Speed (MHz): avg: 2117 high: 3145 min/max: 1200/3300 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 2238 2: 3145
    3: 1916 4: 1914 5: 2395 6: 2394 7: 1916 8: 1916 9: 1914 10: 1916 11: 2008
    12: 2068 13: 2398 14: 1916 15: 1915 16: 1916 bogomips: 105442
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: always-on, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA GA104M [GeForce RTX 3070 Mobile / Max-Q] vendor: Razer USA
    driver: nvidia v: 510.68.02 alternate: nouveau,nvidia_drm non-free: 515.xx+
    status: current (as of 2022-05) arch: Ampere pcie: gen: 1 speed: 2.5 GT/s
    lanes: 8 link-max: gen: 4 speed: 16 GT/s lanes: 16 ports: active: none
    empty: DP-1,DP-2,HDMI-A-1 bus-ID: 01:00.0 chip-ID: 10de:249d
    class-ID: 0300
  Device-2: AMD Cezanne vendor: Razer USA driver: amdgpu v: kernel pcie:
    gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s ports:
    active: eDP-1 empty: none bus-ID: 04:00.0 chip-ID: 1002:1638
    class-ID: 0300
  Device-3: IMC Networks Integrated Camera type: USB driver: uvcvideo
    bus-ID: 3-4:2 chip-ID: 13d3:56d5 class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.1
    compositor: gnome-shell driver: X: loaded: modesetting,nvidia gpu: amdgpu
    display-ID: :1 screens: 1
  Screen-1: 0 s-res: 2560x1440 s-dpi: 96 s-size: 677x381mm (26.65x15.00")
    s-diag: 777mm (30.58")
  Monitor-1: eDP-1 model: TL140BDXP02-0 built: 2021 res: 2560x1440 dpi: 210
    gamma: 1.2 size: 310x174mm (12.2x6.85") diag: 355mm (14") ratio: 16:9 modes:
    max: 2560x1440 min: 640x480
  OpenGL: renderer: AMD RENOIR (LLVM 13.0.1 DRM 3.40 5.10.114-1-MANJARO)
    v: 4.6 Mesa 22.0.3 direct render: Yes
  Device-1: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Razer USA
    driver: snd_rn_pci_acp3x v: kernel alternate: snd_pci_acp3x pcie: gen: 3
    speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s bus-ID: 04:00.5
    chip-ID: 1022:15e2 class-ID: 0480
  Device-2: AMD Family 17h/19h HD Audio vendor: Razer USA
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    link-max: gen: 4 speed: 16 GT/s bus-ID: 04:00.6 chip-ID: 1022:15e3
    class-ID: 0403
  Sound Server-1: ALSA v: k5.10.114-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.51 running: yes
  Device-1: Intel Wi-Fi 6 AX210/AX211/AX411 160MHz driver: iwlwifi v: kernel
    pcie: gen: 2 speed: 5 GT/s lanes: 1 bus-ID: 02:00.0 chip-ID: 8086:2725
    class-ID: 0280
  IF-ID-1: enp4s0f3u1 state: up speed: N/A duplex: N/A mac: <filter>
  Local Storage: total: 1.05 TiB used: 280.1 GiB (26.1%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
    model: MZVLB1T0HBLR-00A00 size: 953.87 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: EXF7201Q temp: 38.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 type: USB vendor: Samsung
    model: Flash Drive FIT size: 119.51 GiB block-size: physical: 512 B
    logical: 512 B type: SSD serial: <filter> rev: 1100 scheme: MBR
  ID-1: / raw-size: 953.57 GiB size: 937.53 GiB (98.32%)
    used: 191.74 GiB (20.5%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 288 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  Alert: No swap data was found.
  System Temperatures: cpu: N/A mobo: N/A gpu: amdgpu temp: 52.0 C
  Fan Speeds (RPM): N/A
  Processes: 458 Uptime: 7m wakeups: 1 Memory: 15.1 GiB used: 2.48 GiB (16.4%)
  Init: systemd v: 250 tool: systemctl Compilers: gcc: 11.2.0 alt: 10
  clang: 13.0.1 Packages: 1682 pacman: 1669 lib: 461 flatpak: 9 snap: 4
  Shell: Zsh v: 5.8.1 running-in: hyper inxi: 3.3.16

Please help! I would love to turn on wifi and Bluetooth again, OR restore from a backup.



did you try switching kernels?
output from:
rfkill list

1 Like

That’s a crude bug.

The only thing what gnome3 does here is blocking und unblocking using rfkill…so:

Is there maybe a hardware switch?

Yes I tried switching to 510 as well. Maybe its a hardware switch that I can’t find?

rfkill list output:

383: hci0: Bluetooth
	Soft blocked: no
	Hard blocked: no

your wifi is not even being detected…
try it with also the 5.17 kernel

hm ok… then please check if you can you can do a scan on the terminal. Follow the pairing steps here: Bluetooth - ArchWiki

If that works, then it must be some bug at the gnome settings.

I switched back to 515. I really have no clue what was happening. maybe it’s this:

  • I was running all commands using my default terminal hyper
  • rfkill list wasn’t returning anything at all, just blank.
  • I switched terminals to the basic terminal
  • I ran rfkill list again and pasted that output above.
  • I then re-ran sudo rfkill unblock bluetooth && sudo systemctl restart bluetooth this time in the other terminal (not hyper).
  • I then switched back from linux 510 to 515 LTS. Boom… wifi and Bluetooth are restored.

Maybe my hyper terminal isn’t set up properly. Otherwise, I am at a loss. Thanks everyone for your help, I hope to figure out more about what was going wrong to help anyone who may read this in the future.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.