Tuned 2.15.0-1 broken by python-configobj 5.0.6-10

tuned 2.15.0-1 broken by python3.9.1-1

Getting tuned.service error…

tuned[563785]: File “/usr/lib/python3.9/site-packages/tuned/units/ init .py”, line 1, in
tuned[563785]: from .manager import *
tuned[563785]: File “/usr/lib/python3.9/site-packages/tuned/units/manager.py”, line 9, in
tuned[563785]: from tuned.utils.global_config import GlobalConfig
tuned[563785]: File “/usr/lib/python3.9/site-packages/tuned/utils/global_config.py”, line 3, in
tuned[563785]: from validate import Validator
tuned[563785]: ModuleNotFoundError: No module named ‘validate’

Temporary fix until update…

Edit

/usr/lib/python3.9/site-packages/tuned/utils/global_config.py

comment out line 3 code #from validate import Validator

and add this line of code (as line 4)

from configobj.validate import Validator

Edit

/usr/lib/python3.9/site-packages/tuned/gtk/gui_plugin_loader.py

comment out line 28 code #from validate import Validator

and add this line of code (as line 29)
from configobj.validate import Validator

Hi @inc,

Just a thought, have you rebuilt it? It’s recommended to install rebuild-detector and then checking if there are any rebuilds necessary:

$ sudo pacman -S rebuild-detector
$ checkrebuild
1 Like

Yes i did checkrebuild but tuned wasn’t reported, so went looking for a solution.

and Hi. (Sorry)

OK, cool cool!!!

:wave: No worries!

1 Like

Please do not post about problems with AUR packages in Announcement threads.

1 Like

Sorry i am new here.

I have unmarked the chosen solution because it doesn’t solve it. I have already issued the solution (editing 2 files), till an update is issued.

Thanks

That is NOT the solution. You should not have any files left in /usr/lib/python3.8/site_packages/.

You need to rebuild any Python packages from the AUR when there’s a major Python update. I actually just tried out tuned a day or two ago, in fact. It works just fine.

Tip: Once you get it sorted, keep in mind it will conflict with tlp. That’s just in case you didn’t already know that. :wink:

1 Like

Not true. I have completely removed tuned from my system including any build files and reinstalled, the error is the same. Editing the 2 files as shown enabled the tuned.service to start an the gui to run.

Also no one mentioned /usr/lib/python3.8/site_packages/ I said 3.9!

I did. If you installed Python 3.9 and did not rebuild any Python packages installed from the AUR, they were still installed there. What is the output of:

ls /usr/lib/python3.8/site_packages/

If you’ve already rebuilt your Python packages, it should say:

ls: cannot access '/usr/lib/python3.8/site_packages/': No such file or directory

I have rebuilt tuned and it still produced the error. The fix is to edit the 2 files.

I have No such file or directory ‘/usr/lib/python3.8/site_packages/’

Aha! It’s a problem with python-configobj 5.0.6-10. You can downgrade it to 5.0.6-9 for now. it’s fixed with 5.0.6.r110.g3e2f4cc-1. See Downgrading packages - Manjaro

Yes i know it is and i know i can. Or i can edit 2 files and fix it, until the update is issued with (probably identical) fixes. :wink:

It was two typos: :man_shrugging:

Have you read the dates on those 2 links?

timgates42 authored and jhermann committed on Dec 7, 2019

@felixonmars @jhermann

felixonmars authored and jhermann committed on Oct 14, 2020

Nothing to do with current issue. tuned worked fine till python3.9 update.

I will wait till this becomes available in Pamac and install it. I will then, out of curiosity, check the 2 files and see if my 2 edits get preserved.

No, they won’t. The files are modified, so they will conflict. You’ll have to manually remove them first or instruct Pacman to overwrite them when updating.

…or you could just download 5.0.6.r110.g3e2f4cc-1 from a mirror now, install that and call it a day.

I meant in the sense of their content. I will of course intervene manually and remove anything that is required to allow install of update “5.0.6.r110.g3e2f4cc-1”

No need, tuned is working fine. MY update is as good as 5.0.6.r110.g3e2f4cc-1