Tty's other than login manager and WM show a black screen

Hi everyone,

I have been trying to resolve this issue for some time. A description and my attempts follow.

Pressing Ctrl+Alt+F{1…7} works correctly for tty1 (login manager) and tty2 (awesome-wm or gnome).
However, for any other tty, a black screen shows up with no info.
This is troublesome, as I am forced to boot from a live usb and decrypt my luks drive manually every time my configuration breaks (which luckily happened only once).

Upon reading this thread, I tried chvt [n], which works the same way as the Ctrl+alt+F[n] key binding, yielding no operable console.

Initially, the output of systemctl list-units | grep tty was merely:

system-getty.slice             loaded active active     Slice /system/getty                   loaded active active     Login Prompts

However, after running: systemctl enable getty@tty{1..7}, the same command return the following lines, in addition to the previous ones:

 getty@tty2.service                       loaded active running   Getty on tty2
 getty@tty3.service                       loaded active running   Getty on tty3
 getty@tty4.service                       loaded active running   Getty on tty4
 getty@tty5.service                       loaded active running   Getty on tty5
 getty@tty6.service                       loaded active running   Getty on tty6
 getty@tty7.service                       loaded active running   Getty on tty7

After rebooting, tty’s still don’t work. However, the DE/WM is now on tty8 (as I can return to it through the Ctrl+Alt+F8 key binding). Additionally, systemctl status getty@tty8 shows the service as being “disabled”.

I have also tried un-commenting the line: NAutoVTs=6 in /etc/systemd/logind.conf, to no avail.

I have also looked at the similar threads: Virtual Consoles not Working and Why Does the Ctrl+Alt+F1…F6 Not, none of which seemed to add valuable information.

I can swiftly provide more info to anyone willing to help. Thank you in advance.

Well I guess it is the display-managers choice. Since you mention gnome, I assume you use gdm. Maybe switch to lightdm for example. Lastly I had to switch because gdm switches from session :0 to :1 what is is troublesome for some non-gnome applications. At least works perfectly. I use gnome for usual stuff and i3 (previous dwm) for coding stuff or gaming.