TTY doesn't work with new monitor

Hi, i have two monitor 1 UW Samsung and 1 2k Dell both attached with display port.

The xrandr config is the following:

xrandr --output DisplayPort-0 --primary --mode 3840x1600 --pos 0x0 --rotate normal --rate 119.98 --output DisplayPort-1 --mode 2560x1600 --pos 3840x0 --rotate normal --rate 59.97 --output HDMI-A-0 --off --output HDMI-A-1 --off --output DVI-D-0 --off

When i try to switch to TTY both monitor say there was no signal and go in stand-by, when i switch back to x they both power on.

inxi -Gxxx                                                                                   (130) 16:58:37 
  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
    vendor: Sapphire Limited Nitro+ driver: amdgpu v: kernel bus-ID: 0a:00.0
    chip-ID: 1002:67df class-ID: 0300
  Display: x11 server: X.Org driver: loaded: amdgpu
    unloaded: modesetting alternate: ati,fbdev,vesa resolution: 1: 3840x1600
    2: 2560x1600~60Hz s-dpi: 96
  OpenGL: renderer: AMD Radeon RX 580 Series (POLARIS10 DRM 3.40.0
    5.10.89-1-MANJARO LLVM 13.0.0)
    v: 4.6 Mesa 21.3.2 direct render: Yes


I have tried everything from early kms to uvesafb; also i’ve tried to extract an Edid without success. The only thing that solved my problem is to add in the grub the following kernel parameter: amdgpu.DC=0, the side effect is that the main monitor (LG 38gn950) the refresh rate lower to 79 instead of 120, that isn’t the max because if i go at 144 i cannot use the second monitor (Dell 30). When i put that parameter when i switch to tty the two monitors display the console and they didn’t say no signal and then switch off. Other side effect of that parameter is that the audio from the radeon is turned off, but for me is not a problem, because i don’t use it.