Trying to use gpasswd add my user to vboxusers fails

Trying to add to sudo gpasswd a $USER vboxusers results in no vboxusers?

Trying to run a Virtualbox instance and access a USB device connected to the host PC. I tried to run the above command (changing the $user to me) and the response was :

gpasswd: user ‘vboxusers’ does not exist

Version 6.1 of Virtualbox, with Extensions installed.

EDIT: Seems it was the wrong syntax, should have been
sudo usermod -a -G vboxusers <your_username>

It’s now working.


The syntax of gpasswd is correct - assuming virtualbox is correct installed.

The group vboxusers does not exist on the guest - but the host as it is the user on the host which initiates USB passthrough.

$ groups
network scanner lp wheel manjaro
$ grep vbox /etc/group    
$ sudo gpasswd -a $USER vboxusers
Adding user manjaro to group vboxusers

The usermod command can used as well.

Two ways to achieve the same result but on the host.

1 Like

Cool, thanks for that. It does get confusing at times :slight_smile:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.