Trying to update NVIDIA drivers in TTY or liveUSB


Firstly, let me say that I’ve spent months on and off looking at dozens of posts here and other places before posting here. I am a 1-2 year intermediate newbie to Linux and Manjaro, but I’m not totally clueless. I can use the command line and terminal somewhat comfortably but interpreting and diagnosing issues from lines on the screen is not my strong suit. There’s no “official” ranking i guess, but if I see “you have to do this” and theres not a plain english description to go with i may struggle. dont be afraid to hold my hand or assume im totally unaware, i wont take it personally. Do not assume i know that i need to do ‘X’ in order to do ‘Y’ and tell me just to do ‘Y’.

I have a computer with and NVIDIA GeForce RTX 2070 Super, and i am running Manjaro Gnome (i want to transfer to KDE or XFCE but thats another post) with 5.15.60-1 [just installed it with tty1] 5.13.19-2 and 4.14.290-1. I have two physical and separate hard drives, one with Manjaro, the other with Windows 10 exclusively for gaming, so it’s not really a dual boot… both are 1TB so confusing them might be an issue. I’d need to be careful with /sda/ stuff, and my lack of experience means im not confident in making sure which is which in the terminal. A GUI would be fine.

Some exposition: After updating majaro, the 5.13 stopped booting. it went to the black screen and unable to get to a command line, though 4.14 was still working after some fiddling on my end, which involved a timeshift useage. Somewhere along the lines i tried installing new drivers but it failed. I updated the system and it bricked the 4.14 as well. I have diagnosed this as an issue with the video drivers. I just downloaded the 5.15 kernel using TTY after editing ‘rw quiet’ to ‘rw 3’

Things I have tried: updating the system (pacman -Syu and others in tty), pressing CTRL+ALT+F1-12 on the black screen (and ALT and CTRL separately) and not getting a command line, messing around on the GRUB command line (version 2.06~2~manjaro), trying different settings in the Edit Boot Options of the splash screen

ISSUE: I have the usual black screen of death with a fast blinking cursor, and usually the three dots stuck on the screen.

Capabilities: I can TTY into my system. I can live boot with my USB (i have manjaro XFCE 21.3.0-220617linux515 to be exact) and i can chroot -a (i forget the exact command) and mount my hard drive and access it through the terminal. On the Live boot it asks which drivers to use when i launch the liveUSB and it works with the proprietary drivers and open source drivers.

I’m thinking I need to download the new NVIDIA/open source drivers and update them. But I just cant do it with TTY or the live USB, i cant find anywhere describing how to do it.

P.S. I read somewhere that 5.13 was losing its support and the drivers were not compatible if they were updated. I’m not sure why I had that in the first place, but thats the core of this issue.

P.P.S. Alternatively, if i can install the new version from the liveUSB and keep everything on the drive (like a migration i guess) i wouldnt have to worry about it, but lets try to install the drivers first please. Whatever information you need, please let me know, i can use the terminal. I ask do not be quick to send me somewhere else, I’ve most likely seen it and tried it. Like I said I’ve spent several months on and off trying to fix this.

Thank you.

Remove those kernels, they are no longer supported. See Manjaro Kernels - Manjaro

After doing that, you will be able to ensure the proprietary NVIDIA driver is installed. See Configure Graphics Cards - Manjaro

This looks very similar to numerous issues reported so far.

It worked!.
On the live usb with chroot I deleted the kernels and for fun i did a reboot. No longer have the GRUB menu to choose which drive to boot.

booted to live USB again,
sudo mhwd -a pci nonfree 0300
“skipping already installed config ‘video-nvidia’…”

okay so im gonna reinstall this.
sudo mhwd -f -i pci video-nvidia

successfully reinstalled driver.


Successfully into the desktop! Though not without erasing my dark mode for the UI. But it worked! Thank you for that. Reboot was fine also. Currently trying to figure out how to put that screen up so i can choose which drive to boot instead of it auto loading majaro.

it is, however, there was some unique issue that was holding me back. In this case, i believe it was the old kernels preventing me from updating the drivers for 5.15. I think my issue brought new nuances that could be helpful for others.

FYI that has actually been the common cause so far.

Well, none of the guides i read told me to delete the old kernels before re downloading the drivers. Also, if there is thread out there that is identical to mine, the wording or phrases i used obviously didnt match. but i appreciate it

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.