Trying to run Anbox, installed aur/linux-zen-git, can't boot because of missing crypto config

Hello, I’m trying to get Anbox to run on my setup.

I saw it needs kernel modules ashmem and binder so I tried installing them from various sources, as DKMS modules, as aur/linux-manjaro-xanmod custom kernel…

What I ended up doing was installing aur/linux-zen-git (as there’s no extra-linux-zen in manjaro repositories for some reason, even though they are in arch repositories), and editing the config so it would have the relevant ashmem and binder modules.

After a (very) long build of the custom kernel (and after installing aur/nvidia-dkms-performance in which I downgraded the version in the PKGBUILD to match the current nvidia 460.32.03 version to match dependencies, because again, nvidia-dkms is not in manjaro repositories even though it’s in arch repositories), I rebooted.

rEFInd saw the linux-zen kernel, so I booted with it, but then it failed to boot, because the drive is encrypted, and I didn’t specify anything about that in the custom kernel config. It says it’s not LUKS, if that’s any relevant.

I installed manjaro from the normal calamares GUI from the manjaro gnome live session, but I didn’t check the encryption option, as I have a SSD, and encryption lowered the performance of it significantly.

Is there something I’m missing, should I edit the custom kernel config to let it know that there’s no encryption ? Or does manjaro do a bit of encryption somewhere that’s a problem here ?

Another question I have is: Why do some packages not exist in manjaro repositories ? Is it a lack of time or resources to maintain packages that the general population wouldn’t need ? Does it directly clash against something that Manjaro does but not Arch ? I like Manjaro’s ISOs and pre-configured systems that I can easily install, but I feel like having an Arch system would have been easier for this ^^

Sources for config changes and packages:

Alright, I tried a couple kernels, but I can never boot from them, I’m probably doing something wrong. So I went to see if maybe I could just add the modules I need in the normal manjaro 510 kernel instead. And then I found this:

There’s the config I’m looking for right in the kernel, but in a different file. Does that make it disabled ? If so, is there a way to enable that ? Or maybe it’s already enabled, but just not live on the manjaro repositories.

Can someone help me make sense of that ? Thank you ^^

I’m definitely no expert on this, my kernel knowledge is extremely limited so apologise if I’m wrong.
I think you may need the kernel headers if you are using nvidia dkms but i may be wrong

I do need kernel headers to install dkms stuff yes.

In the end, the normal core/linux510 kernel has the modules anbox needs, the issue was aur/anbox-git. Maybe it tries to load them but that doesn’t work because they are built-in, not loadable ?

the anbox snap works though, you first need to enable the daemon, and then run the app manager
anbox session-manager

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.