Trying to login with Plasma reboots my computer

I have been using Manjaro Linux on my Lenovo Yoga 9i for a bit over a year, and haven’t updated pamac for about half a year.

Recently, I tried to boot my computer, but was met with an unfamiliar login screen. Instead of my normal ‘Nordic’ theme that I downloaded from online, I had the Breeze theme loaded with a message saying

The current theme cannot be loaded due to the errors below, please select another theme

file:///usr/share/sddm/themes/Nordic/Main.qml:26:1: plugin cannot be loaded for module “org.kde.plasma.core”: Cannot load library /usr/lib/qt/qml/org/kde/plasma/core/ ( cannot open shared o next file: No such file or directory)

This was fixed by editing /etc/sddm.conf.d/kde_settings.conf and changing the theme to Breeze.

But I was met with another issue. I have a select screen to change my DM, and the options are

Enlightenment (Wayland)
Plasma (X11)

Here, when I select Enlightenment I can see the DM. But I can’t access WiFi. I tried using Ethernet, but ping says that the hostname cannot be resolved. pamac update gives the same error as ping.

When I select Plasma, which is my main DM, my system just reboots itself.

What can I do to get Plasma back?

you have probably installed some AUR packages that are causing it…
in the login screen enter into TTY - ctrl+alt+f2 or f1-f6 keys, enter your username and password, and post output from:
pacman -Qm

I can’t access TTY for some reason, Ctrl + Alt + F1 (any of them) doesn’t work, I’m not sure if that helps diagnose the problem any further. I have access to a terminal though, I can open Enlightenment and use VSCode’s inbuilt terminal.

Here is the output:

anaconda 2022.10-1
anbox-modules-dkms-git r42.cd66055-1
android-studio 2022.1.1.19-1
apple-fonts 1.0.3-1
bed-latex 1.3.7-1
ceph-libs 15.2.17-1
debtap 3.5.1-1
deepin-wayland 1.0.0-1
ideviceinstaller 1.1.1-1
libimobiledevice-glue-git r37.6fcb870-1
libplist-git 1:2.3.0.r14.g21a432b-1
libusbmuxd-git 2.0.2.r30.gf47c36f-1
lichess-nativefier 0.0.1-1
linux60 6.0.15-1
lxc-git-debug lxc.
manjaro-documentation-en 20160419-1
manjaro-firmware 20160419-1
metis 5.1.0-p10-2
mullvad-vpn 2022.5-3
noto-fonts-compat 20151217-1
protonvpn 1.0.0-2
protonvpn-cli 3.12.0-2
protonvpn-gui 3.10.0-1
pyinstaller 5.9.0-1
pyinstaller-hooks-contrib 2023.1-1
python-altgraph 0.17.3-1
python-pep517 0.13.0-1
python-proton-client 0.7.1-1
python-protonvpn-nm-lib 3.12.0-1
python-pytest-drop-dup-tests 0.3.0-2
python-tinyaes 1.0.4-1
python2 2.7.18-5
python2-dnspython 1.16.0-3
qemu-virtiofsd 7.2.1-1
ripcord 0.4.29-1
spotify 1:
spotify-adblock 1:
systemd-fsck-silent 239-1
ttf-ms-fonts 2.0-12
unityhub 3.2.0-1
visual-studio-code-bin 1.75.1-1
zoom 5.3.4-1

first remove these:

sudo pacman -R systemd-fsck-silent manjaro-firmware manjaro-documentation-en ceph-libs

this kernel is dead:

so if you are not running it, remove it:
sudo pacman -R linux60
if you are running it, switch to another one, then remove it…

now to your problem… remove these from AUR:

sudo pacman -Rdd libusbmuxd-git libplist-git libimobiledevice-glue-git

install them from official repos:

sudo pacman -S libusbmuxd libplist libimobiledevice

rerun update:

sudo pacman-mirrors --fasttrack 5 && sudo pacman -Syyu

if no errors, reboot…


Hello, I just reinstalled Manjaro last night as I didn’t really have any crucial data on this computer. I’m not sure if this would work though, as I wasn’t able to access my WiFi or Ethernet. And your solution required me to use pacman.

Thanks for all the help.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.