Trying to install rtl8821cu drivers via pamac

It seems that we have a useable instruction set here but its not working for me
/t/im-having-problems-installing-wifi-drivers-rtl8821cu/134152/4

I’m trying to follow the instructions by u/Mirdarthos. I managed to install the headers successfully via the command

pamac install $(pamac list --quiet --installed | grep "^linux[0-9]*[-rt]*$" | awk '{print $1"-headers"}' ORS=' ')

When I try to run pamac build rtl8821cu-dkms-git I get an error

remote: Support for password authentication was removed on August 13, 2021.
remote: PleaseLINKREMOVED for information on currently recommended modes of authentication.
fatal: Authentication failed for 'LINKREMOVED'
==> ERROR: Failure while downloading 8821cu-20210118 git repo
    Aborting...
Error: Failed to build rtl8821cu-dkms-git

The OP of the original thread claims that the fix worked, but my output is telling me they removed auth functions long ago.

Any ideas?

EDIT Must have been a problem with the remote, even the pamac gui was failing with the same error. I tried a git clone command and at first that failed too but mysteriously about 15 minutes later I was able to clone the repo and now pamac build ran successfully

1 Like

Hi @das137
I suggest you to install the package from other sources:
‘GitHub - brektrou/rtl8821CU: Realtek RTL8811CU/RTL8821CU USB Wi-Fi adapter driver for Linux’

‘AUR (en) - rtl8821cu-dkms-git’

‘AUR (en) - rtl8821cu-morrownr-dkms-git’

The last post reported that Manjaro with this package was running well.

Hope it help,

Regards

Please post a full inxi output so we can be sure that is even the correct driver that you are attempting to install.

That being said, for either of the dkms variants you should have the appropriate linux headers installed for you kernel(s) in addition to dkms. I would go with the morrownr variant to start with.