Trying to install manjaro to an old computer

I have an old computer which has the specs.:

Intel Core 2 Duo E4300
Corsair DDR2 533MHz 2GB (1x2)
ATI HD 5570
Seagate ~250GB HDD
(I also can give the detailed specs if anyone wants.)
*Also my comp. has only the BIOS, not UEFI since its pretty old.

Past problems with the hardware:
It’s my first desktop computer from 2007, a slightly modified Packard Bell iStart J5333. It had some issues with its ram the past 4-5 years, so I changed them recently. The new rams are also compatible with its motherboard, ECS PT890T-A. Besides ram, I remember, in the old days it’d give BSoDs about its USB and PS/2 ports but after some drivers installed, I believe, they are also no more.

Problem while trying to install Manjaro (as well as other distros):

-tried Zorin, Arch, Manjaro xfce-kde-

So, I can boot into flash drive without any problems. But the first menu with all the boot options and sort is kind of slow; it sometimes makes me wait a couple of seconds to move between the options, and selecting an option like adjusting the keytable and saving it takes more time. Aside from this, the real problem is to boot in live environment in the flash. The first time I booted manjaro(and many other distros) in the live environment, it made me wait for ~3-4 mins just to show only a cursor and a black screen. So when this happened I just turned the system off and then whenever i try to boot live from usb, my display shows the disconnected message after a while, aithout anything appearing in the screen.So then,I tried some commands from the internet concerning this issue: I have tried “nomodeset”(was mentioned for the black screen issue),“video=SVIDEO-1:d”(someone had an ati card with the same issue), and after i tried “nomodeset” in arch, i got an ERROR No UMS support in radeon module error,and also deleting the command line about radeon pressing e on the boot option that i want to pick.
No positive results so far.

(-I have a flash drive which is not that fast, namely SanDisk SDCZ50-032G, a 32GB one. I was also be able to flash Win10 from it to a new pc recently, so i don’t know if its the problem.
-I also tried burning manjaro to a DVD,still the same issue.)

I’d be very glad to give more information regarding the issue if anyone is willing to help.

  1. Is your BIOS legacy or UEFI?

  2. Even if you manage to get it installed, I really don’t think you’re going to have a pleasant experience with any type of DE with only 2GB RAM.

The BIOS is legacy, recently updated it manually. Actually I don’t expect a monstrous performance boost or sort from installing, but I just wanted to give it a try since the distros may be a little more fluent than win7.