Trying to install manjaro on a separate hard drive but i get secure boot error

Hi, first time trying to setup linux.
Made a bootable USB drive with balena and changed my boot order to the usb drive in bios
Saved bios and tried to boot into the USB and i got a “Secure boot violation” prompt
so I decided to turn off secure boot following instructions from google and it was just me going to my settings tab> security > Trusted Computing and then turning off Secure boot completely as per instructions on MSI forums.

Still no luck same screen comes up, booted back into windows automatically so I decided to give up for now and turn TPM back on because it broke the enter security PIN on windows.

If it’s relevant my motherboard is an MSI B450 mortar max

What do I do now?
(also i was gonna put images here of all the stages and the prompt itself but i got denied so)

Welcome to Manjaro! :smiling_face_with_three_hearts:

  1. Please read the information behind this link. It will help you to post necessary information. [HowTo] Provide System Information
  2. Please press the three dots below your post and then press the :pencil2:
  • If you give us information about your system, we can see what we’re talking about and make better suggestions.
  • You can do this by using inxi in a terminal or in console.
inxi --admin --verbosity=7 --filter --no-host --width
  • Personally identifiable information such as serial numbers and MAC addresses are filtered out by this command
  • Presenting the information in this way allows everyone to be familiar with the format and quickly find the items they need without missing anything.
  1. Copy the output from inxi (including the command) and paste it into your post.
  • To make it more readable, add 3 backticks ``` on an extra line before and after the pasted text.
    (Wisdom lies in reading :wink: )

You may have to disable secure boot in UEFI

You can find similar posts allover the forum :slight_smile: Please search for “secure boot” windofs

Dual boot with windows:

Switch from Windows - how to use GNU/Linux:

I have tried, I just simply cant. I fully disabled my TPM module and no luck.

Also i have multiple drives and im trying to install it to my D: drive since i heard that having windows and linux on the same drive can cause problems.

The only problem with Windows and Linux being on the same drive is that Windows updates sometimes breaks GRUB which can easily be fixed by updating GRUB when it occurs by booting into Linux and running sudo update-grub in your terminal.
You’re going to need to either press the Boot Menu key and choose Linux or go into your BIOS and change the boot order so that Linux boots first - I suggest the former as it only needs to be done this one time.

1 Like

I dont have linux even installed to do this, I have a seperate drive so i wont need to worry about that.
My issue right now is that my USB stick is not being booted into i just get a secure boot warning even tho my secure boot is turned off.

A sincere effort to describe your issue in text will yield a much better response.

TL0 users cannot post images or links - it is quality of this forum.

Did you copy or did you burn Linux to the stick?
You need to burn it, with a tool like Rufus so that it makes the USB stick a bootable device.
And most modern major Linux distributions don’t have a problem with either Secure Boot or the TPM module being present.

I did, i figured out the issue anyways. You have to go into advanced settings then “windows os” settings and then turn off secure boot from there. I got manjaro now im just trying to figure out what the ■■■■ .tar.gz is and what deb is while trying to install stuff

.tar.gz file is a compressed file. Similar to a .zip file in Windows but using a different type of file compression
A .deb file is yet another type of compressed file, designed for Debian based OS’s, not native to Manjaro but some programs may need support from Debian to work properly.

1 Like