Trying to install manjaro kde minimal lts, blank screen appears after the loader reaches "Graphical Interface Reached"

I am trying to install manjaro-kde-21.0.7-minimal-210614-linux54 on my machine

I am currently on ubuntu and was going to replace it with manjaro,

this is my laptop’s probe ( i cannot include links search for this probe on linux-hardware . org)

I removed silent from the bootloader options while booting but there is no error or usefull log

I have disabled safe boot and fast boot, also i am using uefi and burned the usb using balena etcher.

I also have verified the gpg keys and its valid

Hello @gopherHerder :wink:

So the issue appear after installation or when booting the ISO?

If it does stop just at “Graphical Interface Reached”, then there is problem when switching from video basic mode to the graphical mode. Commonly more information are at /var/log/Xorg.0.log.

  1. Switch to another TTY and login: user+password → manjaro
  2. Have a look at the log: cat /var/log/Xorg.0.log | less
  3. Upload it: cat /var/log/Xorg.0.log | curl -F'file=@-' and post the link here.

Thanks for Replying…

So the issue appear after installation or when booting the ISO?

This Appears While Booting the ISO.

Switch to another TTY

I tried opening a TTY with multiple key combinations ctrl + alt + f2 and going on till f7
didn’t want to open, then i waited for 10 minutes but still did not work… :<

Then i removed quiet from the boot options and replaced it with 3 so that i boot into tty directly, it worked, but since the display manager did not start i have no logs, i can also connect to the wifi with nmcli

when i again do sudo systemctl start display-manager
or startx
it again goes to the black screen and i am not able to do anything

If that does not work, then add this to the kernel parameter:

It should stop at this target and display a basic login. Login there as described above.

Then try to start:

sudo systemctl start display-manager.service

and see if that works then.

If not, then you check the xorg log like described above. You should be able to switch to another tty.

Well that strange… normally you should be able to switch the TTY.

Tried this…
Logged into the tty , then started display-manager.service
i waited for 10 minutes then it showed me a cursor and after 5 minutes more it showed my the Welcome To Manjaro white colored box, but everything was black around it and i couldn’t switch to TTY again, as it was hung up

ok… possible that there is feature enabled which does not work well with your Intel Chipset.

Add this to the kernel parameter:

i915.enable_dc=0 i915.enable_fbc=0 i915.enable_psr=0 i915.mitigations=off

Also it could be possible that SNA Acceleration of the newest driver does not work well with your Chipset. Try using UXA:

  1. Boot into and login.
  2. Create a file:
    sudo nano /etc/X11/xorg.conf.d/20-intel.conf

Put this in there:

Section "Device"
  Identifier "Intel Graphics"
  Driver "intel"
  Option "TearFree" "true"
  Option "AccelMethod" "uxa"

And start the display-manager. Maybe this helps…

You could also install with the manual method:

yup did that same thing happened again, ill try manual installation ig :man_shrugging:

Ok so im on manjaro, idky but i burned my usb again with the full iso instead of the minimal one and it worked :grinning_face_with_smiling_eyes: thanks for the help

btw. after installing if you have a system with intel vmd and/or intel optane and when you boot manjaro or any arch distro , if you get an error like UUID=xxxxxx not found

then boot your live usb, and chroot to your installation and open /etc/mkinitcpio.conf
with vi or nano and add MODULES = (vmd) and save it,
then run mkinitcpio -P
and boot again should work

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.