Trying to install graphics driver and Vulkan dependencies for Nvidia

i have an mx230
and i got stuck on this screen:

error: target not found: nvidia-dkms
:: There are 7 providers available for nvidia-utils:
:: Repository extra

  1. nvidia-340xx-utils 2) nvidia-390xx-utils 3) nvidia-418xx-utils
  2. nvidia-430xx-utils 5) nvidia-435xx-utils 6) nvidia-440xx-utils
  3. nvidia-450xx-utils

You card is based on GP108M, pascal architecture so choose nvidia-450xx-utils

:: There are 6 providers available for lib32-nvidia-utils:
:: Repository multilib

  1. lib32-nvidia-390xx-utils 2) lib32-nvidia-418xx-utils
  2. lib32-nvidia-430xx-utils 4) lib32-nvidia-435xx-utils
  3. lib32-nvidia-440xx-utils 6) lib32-nvidia-450xx-utils

what now?

same driver lib32-nvidia-450xx-utils

error: target not found: nvidia-settings
warning: vulkan-icd-loader-1.2.151-1 is up to date – reinstalling
warning: lib32-vulkan-icd-loader-1.2.151-1 is up to date – reinstalling

still not working

Is there a reason you are not handling drivers through mhwd ?

i tried mhwd

Error: config ‘video-hybrid-intel-nvidia-450xx-prime’ conflicts with config(s): video-hybrid-intel-nvidia-440xx-prime

As this is not the first time you tried.
Remove all display drives with pamac-manager.
Open manjaro-settings-manager and auto install proprietary driver.