Trying To Install Fusuma - Gem Issue

Hey Guys,

Trying to install Fusuma for touchpad gesture support:

Hitting the following issue:

sudo gem install fusuma                                     
Fetching fusuma-2.0.5.gem
WARNING:  You don't have /root/.local/share/gem/ruby/3.0.0/bin in your PATH,
	  gem executables will not run.
Successfully installed fusuma-2.0.5
1 gem installed

Not sure what I need to do net to get things working. Any assistance would be greatly appreciated.


Never use sudo with other package managers like Gem, NPM, Pip, etc.

ruby-fusuma is in the AUR (Arch User Repository), install if from there.

Thanks @Yochanan, what’s the best way to ‘cleanup’ what I’ve done? I executed the following commands from the wiki:

sudo pacman -S libinput
sudo pacman -S ruby
sudo gem install fusuma

The same way you installed it:

sudo gem uninstall fusuma


    ~  sudo gem uninstall fusuma                                             
Remove executables:

in addition to the gem? [Yn]  y
Removing fusuma
ERROR:  While executing gem ... (NameError)
    uninitialized constant Gem::RDoc                        

Try installing ruby-fusuma and see if there are any conflicting files. If not, you may be good to go.

Thanks @Yochanan, looks good. Now I just need to figure out this config file so I can enable back/forth gestures in my browser of choice for navigation.