Trying to get steam to load already installed games from multiple drives

I want to say im not completely new to linux, but some messing around with mint and using a liveboot usb to get some old laptops running to help transfer data from old hard drives to newer, larger ones probably doesnt count.
(i was very surprised that those old laptops worked with no issues that i could tell, gotta say my favorite thing so far about linux is the live boot usbs and the fact that it can run on all of the computers ive come across so far)

anyway, im trying to get steam to recognize the drives i used on windows to store games, ive only got a limited mobile data plan, so i dont really want to have to redownload all of them.
one of those drives has a windows installation on it and one is just my hard drive that has photos, music anything i dont need on an ssd really
both are ntfs but i remember reading that linuxs ability to read ntfs has improved greatly.

i am somewhat comfortable using the command line, but if there is a gui option i would rather that if possible.
ive tried going into system settings> removable storage> removable devices and enabling automatic mounting of removable media and that hasnt seemed to work as i expected it to.
steam can now see my hard drive, but wont let me pick a specific folder in said hard drive to use as a library.
if it turns out i cant just get steam to load my already downloaded windows games via proton or whatever their fancy compatibility things name is than ill probably just go back to windows for now, at least until ive got proper home internet that isnt limited.

ive no idea if this post is too long, sorry if it is and thank you to anyone who can help me, im just not feeling like searching the depths of the internet to do something i can easily do on windows today.

(yes ive already done some searching, but it hasnt helped me i would give links but apparently im not allowed to)

What I did when changing from Windows to Manjaro:

  1. Backup your games in Steam Client on Windows.

  2. Restore this backup in Steam Client on Manjaro.

No redownloads of games needed…except for necessary Proton runtimes to get the games running.

I transferred about 300GB of games with this method without any problems.

The Steam folder structure for Windows and Linux is completely different, so using the Windows folder structure in Manjaro won’t work.

Steam games work well with the above method (and of course you can use the Steam client on Manjaro to later change the library location to a pure data drive instead of your home directory)

Anyway, the actual more important question for you is how to properly mount ntfs drives.

However, since we don’t know anything about your PC and your intentions how to use it, any help is just pure guessing at the moment.

Please read [HowTo] Provide System Information

i didnt even think about using the backup feature thanks for reminding me, ive already got a few large ones backed up because steam likes to download updates when i dont want it to regularly, often breaking modlists.

here is what that command in that link output, i hope ive formatted that correctly
(ive just noticed it saying it didnt have root privliges, should i redo that with sudo in front of it?)

  Kernel: 5.15.7-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=4ea4334f-394f-4f34-8eb6-4be390c47f7f rw quiet apparmor=1
    security=apparmor resume=UUID=20f69f48-11b3-495c-9f18-135f8e8e6198
  Desktop: KDE Plasma 5.23.4 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Desktop System: MSI product: MS-7A74 v: 1.0
    serial: <superuser required>
  Mobo: MSI model: B250M PRO-VH (MS-7A74) v: 1.0
    serial: <superuser required> UEFI: American Megatrends v: 1.30
    date: 02/03/2017
  Device-1: hidpp_battery_0
    model: Logitech Wireless Mobile Mouse MX Anywhere 2S serial: <filter>
    charge: 100% (should be ignored) rechargeable: yes status: Discharging
  RAM: total: 15.34 GiB used: 3.85 GiB (25.1%)
  RAM Report:
    permissions: Unable to run dmidecode. Root privileges required.
  Info: model: Intel Core i5-7500 bits: 64 type: MCP arch: Kaby Lake family: 6
    model-id: 0x9E (158) stepping: 9 microcode: 0xEA
  Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 256 KiB
    desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB L3: 6 MiB
    desc: 1x6 MiB
  Speed (MHz): avg: 3683 high: 3696 min/max: 800/3800 scaling:
    driver: intel_pstate governor: powersave cores: 1: 3668 2: 3696 3: 3696
    4: 3674 bogomips: 27208
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon
    art avx avx2 bmi1 bmi2 bts clflush clflushopt cmov constant_tsc cpuid
    cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts ept ept_ad erms est f16c
    flexpriority flush_l1d fma fpu fsgsbase fxsr ht hwp hwp_act_window hwp_epp
    hwp_notify ibpb ibrs ida intel_pt invpcid invpcid_single lahf_lm lm mca
    mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae pat
    pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts
    rdrand rdseed rdtscp rep_good sdbg sep smap smep smx ss ssbd sse sse2
    sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust
    tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt
    xsaves xtopology xtpr
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled
  Type: mds mitigation: Clear CPU buffers; SMT disabled
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
    IBRS_FW, STIBP: disabled, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort mitigation: TSX disabled
  Device-1: Intel HD Graphics 630 vendor: Micro-Star MSI driver: i915
    v: kernel bus-ID: 00:02.0 chip-ID: 8086:5912 class-ID: 0380
  Device-2: NVIDIA GP106 [GeForce GTX 1060 3GB] vendor: Gigabyte
    driver: nouveau v: kernel bus-ID: 01:00.0 chip-ID: 10de:1c02 class-ID: 0300
  Display: x11 server: compositor: kwin_x11 driver:
    loaded: modesetting alternate: fbdev,vesa resolution: <missing: xdpyinfo>
  Message: Unable to show advanced data. Required tool glxinfo missing.
  Device-1: Intel 200 Series PCH HD Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 chip-ID: 8086:a2f0
    class-ID: 0403
  Device-2: NVIDIA GP106 High Definition Audio vendor: Gigabyte
    driver: snd_hda_intel v: kernel bus-ID: 01:00.1 chip-ID: 10de:10f1
    class-ID: 0403
  Device-3: C-Media Audio Adapter (Unitek Y-247A) type: USB
    driver: cmedia_hs100b,snd-usb-audio,usbhid bus-ID: 1-12:4 chip-ID: 0d8c:0014
    class-ID: 0300
  Sound Server-1: ALSA v: k5.15.7-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.40 running: yes
  Device-1: Realtek RTL8192EE PCIe Wireless Network Adapter driver: rtl8192ee
    v: kernel port: d000 bus-ID: 03:00.0 chip-ID: 10ec:818b class-ID: 0280
  IF: wlp3s0 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Micro-Star MSI driver: r8169 v: kernel port: c000 bus-ID: 04:00.0
    chip-ID: 10ec:8168 class-ID: 0200
  IF: enp4s0 state: down mac: <filter>
  WAN IP: <filter>
  Message: No bluetooth data found.
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 2.06 TiB used: 1.35 TiB (65.4%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SK Hynix
    model: HFM512GDJTNG-8310A size: 476.94 GiB block-size: physical: 512 B
    logical: 512 B speed: 15.8 Gb/s lanes: 2 type: SSD serial: <filter>
    rev: 80002C00 temp: 60.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: LITE-ON model: CV1-8B128
    size: 119.24 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 201 scheme: GPT
  ID-3: /dev/sdb maj-min: 8:16 type: USB vendor: JMicron Tech model: Generic
    size: 119.24 GiB block-size: physical: 4096 B logical: 512 B type: N/A
    serial: <filter> rev: 0508 scheme: GPT
  ID-4: /dev/sdc maj-min: 8:32 type: USB vendor: Western Digital
    model: WD Elements 25A2 size: 1.36 TiB block-size: physical: 512 B
    logical: 512 B type: N/A serial: <filter> rev: 1026 scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 102.08 GiB size: 99.92 GiB (97.88%)
    used: 12.75 GiB (12.8%) fs: ext4 dev: /dev/sda2 maj-min: 8:2 label: N/A
    uuid: 4ea4334f-394f-4f34-8eb6-4be390c47f7f
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 292 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1 label: NO_LABEL
    uuid: 92A2-9C9C
  ID-3: /run/media/guess/D800CB5200CB35F2 raw-size: 476.33 GiB
    size: 476.33 GiB (100.00%) used: 301.67 GiB (63.3%) fs: ntfs
    dev: /dev/nvme0n1p3 maj-min: 259:3 label: N/A uuid: D800CB5200CB35F2
  ID-4: /run/media/guess/Elements raw-size: 1.36 TiB
    size: 1.36 TiB (100.00%) used: 998.67 GiB (71.5%) fs: ntfs dev: /dev/sdc1
    maj-min: 8:33 label: Elements uuid: BE4AEC524AEC08CB
  ID-5: /run/media/guess/Local Disk raw-size: 93.12 GiB
    size: 93.12 GiB (100.00%) used: 51.62 GiB (55.4%) fs: ntfs dev: /dev/sdb3
    maj-min: 8:19 label: Local Disk uuid: 1243FC676744618B
  ID-6: /run/media/guess/e2d4bfc0-4112-4007-a784-f8849e90a49d
    raw-size: 25.62 GiB size: 25.1 GiB (97.94%) used: 17.78 GiB (70.8%) fs: ext4
    dev: /dev/sdb2 maj-min: 8:18 label: N/A
    uuid: e2d4bfc0-4112-4007-a784-f8849e90a49d
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 16.87 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/sda3 maj-min: 8:3 label: swap
    uuid: 20f69f48-11b3-495c-9f18-135f8e8e6198
  ID-1: /dev/nvme0n1p1 maj-min: 259:1 size: 100 MiB fs: vfat label: N/A
    uuid: 72C9-5496
  ID-2: /dev/nvme0n1p2 maj-min: 259:2 size: 16 MiB fs: <superuser required>
    label: N/A uuid: N/A
  ID-3: /dev/nvme0n1p4 maj-min: 259:4 size: 505 MiB fs: ntfs label: N/A
    uuid: 02865A8C865A7FD9
  ID-4: /dev/sdb1 maj-min: 8:17 size: 512 MiB fs: vfat label: N/A
    uuid: 4F4E-82F6
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 12 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-3:2 info: Lite-On USB Keyboard type: Keyboard,HID
    driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 1.5 Mb/s
    power: 70mA chip-ID: 04ca:0020 class-ID: 0300
  Device-2: 1-11:3 info: Logitech Unifying Receiver type: Keyboard,Mouse,HID
    driver: logitech-djreceiver,usbhid interfaces: 3 rev: 2.0 speed: 12 Mb/s
    power: 98mA chip-ID: 046d:c52b class-ID: 0300
  Device-3: 1-12:4 info: C-Media Audio Adapter (Unitek Y-247A)
    type: Audio,HID driver: cmedia_hs100b,snd-usb-audio,usbhid interfaces: 4
    rev: 1.1 speed: 12 Mb/s power: 100mA chip-ID: 0d8c:0014 class-ID: 0300
  Hub-2: 2-0:1 info: Super-speed hub ports: 6 rev: 3.0 speed: 5 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Device-1: 2-5:2 info: Western Digital Elements 25A2 type: Mass Storage
    driver: usb-storage interfaces: 1 rev: 3.1 speed: 5 Gb/s power: 896mA
    chip-ID: 1058:25a2 class-ID: 0806 serial: <filter>
  Device-2: 2-6:3 info: JMicron / JMicron USA JMS578 SATA 6Gb/s
    type: Mass Storage driver: uas interfaces: 1 rev: 3.0 speed: 5 Gb/s
    power: 896mA chip-ID: 152d:0578 class-ID: 0806 serial: <filter>
  System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: nouveau temp: 63.0 C
  Fan Speeds (RPM): N/A gpu: nouveau fan: 0
  Processes: 238 Uptime: 1h 32m wakeups: 40 Init: systemd v: 249
  tool: systemctl Compilers: gcc: N/A Packages: pacman: 1262 lib: 386
  flatpak: 0 Shell: Zsh v: 5.8 default: Bash v: 5.1.12 running-in: konsole
  inxi: 3.3.11

as for how i use my pc, i do a little bit of everything.
as for the stuff on the ssd with windows on it, its an ssd i bought recently because i was sick of juggling data between two 128gb ssds and a hard drive, so if there is a way to keep the windows installation on it and let both windows and manjaro access it that would be great.
i was thinking shrinking the existing partition and adding a second, larger one.
though you did mention that the folder structure for windows a linux is different, would i be able to set it up for linux, then just select the library in windows?

You will not be able to use your Windows Steam game library on an NTFS formatted drive on GNU / Linux.

You will not be able to use your GNU / Linux Steam game library on an Ext4 formatted drive on Windows.

exFAT will not work with either.

is this an issue with steam?
or an issue with how linux reads ntfs?

i am able to run windows games fine using wine, just launched rimworld from the same drive windows is currently installed in.

@denonom already explained above:

Also NTFS does not support file and folder permissions.

At the minimum, Linux is able to read and write to NTFS filesystem, but not other NTFS features. This is because there’s a discrepancy between Linux fileystem model and Windows NTFS model. Fileystem format like ext is designed for Linux filesystem model.

Reading and writing file from and to NTFS filesystem within GNU/Linux are generally safe, but anything related to running executable within NTFS isn’t.


1 Like

oh ok, thanks.
so no way to get both to access it to save on limited ssd space then?

No, you need a duplicate in NTFS for Windows and ext for Linux.

ok, thanks.
looks like ill be juggling data around a little bit longer.