Trying to get docker container fails

Hello, I’m trying to get a custom docker container that worked on Ubuntu. The command first command I need to get fails:
wget -qO- *| sudo sh &&
sudo usermod -a -G docker $USER &&
sudo shutdown -r 0

*instead of this it’s a link as get.docker … etc. (can’t post links).

with the error:
*# Executing docker install script, commit: 7cae5f8b0decc17d6571f9f52eb840fbc13b2737

ERROR: Unsupported distribution ‘manjaro’*

Hi, AFAIK that won’t work in Manjaro.

You’ll have to install the docker package from the community repo first, then pull the container with docker pull as you normally would do.

Be aware that there’s currently an issue reported with docker on the stable branch, so it might not work either, at least until the issue gets resolved.

You may want to try the package podman-docker as well.

1 Like

So just install it normally then how to do the pull, not really sure, also this first command I mentioned is just an installation, right?

The second and final command would be:
wget -q -O- * | sudo bash

  • again this represents the link to the gitlab

So how would I pull this:
dcoker pulll *

For that, I’d check the manual pages:
man docker-search
man docker-pull

or check the official documentation available online.

Hope that helps! :slightly_smiling_face:

1 Like

why not install with pacman ? wget url | sudo is not for linux !!! it’s a good way to break his distribution

Well I tried to install docker via
sudo pacman -S docker

and it installed, but I can’t get the container working, with the command:
wget -q -O- * | sudo bash

the * (star) represents the link of the gitlab

is for install docker and not a container !

ps: you can paste url where you found your command : paste url in CODE tag


Well then I can skip that by just installing docker using pacman, but how do I get the container from gitlab?

In my opinion, that’s a docker related question and not of Manjaro’s concern.

I already pointed you to refer to the documentation.

1 Like

we not have container in git{lab,hub} ! we have scripts for create local container with docker or docker-compose
without your gitlab url , not possible to answer you , use </> btn :wink:

generally : sudo systemctl start docker; git clone url ; cd directory; sudo docker run (read docker doc…)

1 Like

Ah indeed, I didn’t post the link since I registered recently.
Also, manage to open the link and found
docker pull..
wget ..
commands and I am currently executing them so I will see if it will work.
I installed docker using via pacman and started it as
systemctl start docker

Currently waiting for it all to download, then I will try to launch it with:
sudo -E start_container

Btw, thanks a lot!

There was a #!bin/bash command before the docker pull registry .., but I skipped that since it didn’t want to run with that.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.