Trying to compile xf86-input-acecad 2017 driver

Hi there,

Some time ago I found my old Ace Cad tablet, it used to run with xf86-input-acecad driver but I can’t install it any more:

-> Could not find all required packages:
    X-ABI-XINPUT_VERSION=22.1 (Wanted by: xf86-input-acecad)
    resourceproto (Wanted by: xf86-input-acecad)
    scrnsaverproto (Wanted by: xf86-input-acecad)

It works fine on my work laptop (Ubuntu) so I’m trying to push through. I downloaded the package, removed the dependencies from PKGBUILD and now makepkg downloads and patches the driver correctly but then spits out this:

configure: error: Package requirements (xorg-server >= xproto kbproto inputproto ) were not met:                                                               
Package 'xorg-server', required by 'virtual:world', not found                        

I have xorg-server-1.20.10-3 installed. Why does configure complain about this older version?

Keeping with the idea of pushing through I tried this:

cd xf86-input-acecad-1.5.0
sed -i 's/' configure

Now configure looks for the installed version but still complains the package xorg-server wasn’t found. I tried 1.20.10 as well (i.e. without the -3 postfix), same result. Can I somehow make it understand I have the correct version?

Those packages no longer exist. That’s why they appear red on the AUR page.

The last upstream release was 10 years ago, FYI.

[ ] xf86-input-acecad-1.5.0.tar.gz 2011-05-04 23:02 339K

Yeah, I get that part but as far as I understand anybody can fix a package and send a merge request with patches so I thought I’d fix xf86-input-acecad but while I’m pretty familiar with code and probably will be able to figure out what to use in place of resourceproto and scrnsaverproto to make the code do what it’s supposed to, I don’t know much about packaging applications for Linux and AUR. I don’t understand why configure complains about missing dependency when it’s clearly installed.

I had some more time to take a closer look.

xorgproto provides those now.

Because it can’t find the xproto, kbproto, and inputproto modules provided by xorgproto.

Here are the reasons that this package will not work and will break your system even though it will build successfully with those modules present:

  • It requires X-ABI-XINPUT_VERSION=22.1 which no longer exists.

  • It conflicts with X-ABI-XINPUT_VERSION>=23, therefore it conflicts with xorg-server which provides X-ABI-XINPUT_VERSION=24.1.

In my system compiles fine after removing the X-ABI things but haven’t individuated all dependencies for a clean build

makedepends=(xorgproto xorg-server xorg-server-devel)


Yes I know, I compiled it in a clean chroot myself. I wouldn’t dare install it, though.

If what I said above wasn’t clear enough:


:: xf86-input-acecad and xorg-server are in conflict (X-ABI-XINPUT_VERSION). Remove xorg-server? [y/N] N
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: xf86-input-acecad and xorg-server are in conflict (X-ABI-XINPUT_VERSION>=23)

1 Like

I’m not going to install it against my system until I’m sure it works, no worries - I’ll use docker or virtualbox first. What I did before opening this thread was:

yay -G xf86-input-acecad
cd xf86-input-acecad
vi PKGBUILD  # experimenting with dependencies
makepkg  # no -i or -s

Then it failed so I tried fixing it a bit but didn’t succeed so far.
Thank you for the clear warning, though, I’m sure it’ll help many readers. :slight_smile:

Thank you very much, it compiled. I can test and fix what’s necessary now. :grin:

[edit] I ended up adding libinput support:

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.