Trying to build Banshee

I know its not supported anymore but it remains the single best media player ever.

I’m amazed that its available and im trying to build it using the git version listed in the add/remove software.

Im getting the following error:
checking pkg-config is at least version 0.9.0… yes
checking for GTK_SHARP_20… yes
checking for GLIB_SHARP_20… yes
checking for GLADE_SHARP_20… no
configure: error: Package requirements (glade-sharp-2.0) were not met:

Package ‘glade-sharp-2.0’, required by ‘virtual:world’, not found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables GLADE_SHARP_20_CFLAGS
and GLADE_SHARP_20_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
==> ERROR: A failure occurred in build().

any suggestions? I cant seem to find the tarball from a google search.

Looks like the AUR package maintainer needs to update the dependencies. The PKGBUILD hasn’t been touched in close to two years now.

1 Like

I was watching the output when Banshee was being built and noticed it occurred when it was building one of the dependencies.


when I try to build it independently of Banshee it provides the error. Does anyone now how to fix this, or how to set the environment variables as suggested in the error?

I can edit the build files but I don’t know where to put these environment variables ( I assume appended to the make command) but I don’t know how to set both variables mentioned.

It’s missing dependencies and pkg-config can’t find what it needs. I tried building it and received the same error along with the following:

==> ERROR: A failure occurred in build().
error: target not found: rarian
error: target not found: gnome-doc-utils

That is unfortunate. Banshee is a fantastic program with abundant features, more so then any other media management software. Luckily I still have an old Debian laptop back from 2017 that I have yet to update that has Banshee installed.

I cant imagine why this program would be left to history…

I wish I knew how to fix it or otherwise.

Thank you very much for taking the time out of your day. I am grateful for you looking into it!!

Hello, I am Xavi de Blas, main developer of Chronojump software:

repo is in gnome gitlab

I develop using Manjaro since half a year, but now that there is no glade-sharp.dll:
pacman -F glade-sharp.dll

I cannot compile anymore.

So Banshee is affected by this, but other programs also.

I noticed today because I have not updated Manjaro since some weeks.

Does anyone know a solution? Thanks.

It fail to build Hyena git submodule anyway

Making all in Hyena.Gui
MCS …/…/…/bin/Hyena.Gui.dll
./Hyena.Widgets/RatingEntry.cs(409,18): error CS0535: Hyena.Widgets.RatingAccessible' does not implement interface member Atk.IValue.GetValueAndText(out double, out string)’
/usr/lib/pkgconfig/…/…/lib/mono/gtk-sharp-3.0/atk-sharp.dll (Location of the symbol related to previous error)
./Hyena.Widgets/RatingEntry.cs(409,18): error CS0535: Hyena.Widgets.RatingAccessible' does not implement interface member Atk.IValueImplementor.GetValueAndText(out double, out string)’
/usr/lib/pkgconfig/…/…/lib/mono/gtk-sharp-3.0/atk-sharp.dll (Location of the symbol related to previous error)
Compilation failed: 2 error(s), 0 warnings
make[4]: *** [Makefile:1184: …/…/…/bin/Hyena.Gui.dll] Errore 1

Need to install rarian and gnome-doc-utils from AUR or disable docs and user-help in ./configure

Do you have gtk-sharp-2 installed?

Thats one of the packages preventing Banshee from being built and so is mono.

If anyone does figure this out, please, please, please post the solution!! There is no media player like Banshee, the next best is light-years apart from the enormous capabilities and extensions of Banshee

Yes, I have it installed.

Try installing gtk-sharp-2-git instead of gtk-sharp-2.

It worked! Thanks a lot

So… in the future, which package I am supposed to use the gtk-sharp-2-git or the gtk-sharp-2?

Thanks again!

Would you kindly post a quick how to build Banshee!!?? Please!! I’m desperate to get it working!!!

There’s no such thing.

Anyone that’s responded here have only offered tips to possibly help you build it. Since you’re apparently the only one who wants to use an old, abandoned project that requires older libraries on a rolling release distro, then feel free to write a tutorial yourself if you get it working.

Have you tried banshee-git? There haven’t been many commits other than translation updates in a number of years, but it’s worth a shot.

Sorry zaileion, it’s called “getting older”. Get used to it! :wink:
Maybe is it time to move on?

For anybody else like me just looking for a simple gui music player that allows you to sort by “Date Added” (seriously, why is this such a rare feature?), I found elementary/music to provide this: GitHub - elementary/music: Music player and library designed for elementary OS

Ignore my previous comment, after a few runs of elementary/music I couldn’t handle the crashes anymore :smiley:

I was able to install the aur banshee by installing gtk-sharp-2-git, mono-upnp-git, and gtk-sharp-3-mono-git first. banshee-git didn’t work though, I hit build errors w/ Hyena.Gui

I installed the packages you suggested and tried to build banshee but got this error:

Generation Summary:
  Enums: 10  Structs: 20  Boxed: 0  Opaques: 2  Interfaces: 0  Objects: 0  Callbacks: 2
  Properties: 0  Signals: 0  Methods: 92  Constructors: 11  Throttled: 31
Total Nodes: 168

/usr/bin/mcs -debug -define:GTK_SHARP_2_6 -define:GTK_SHARP_2_8 -define:GNOME_SHARP_2_16 -define:GNOME_SHARP_2_20 -define:GNOME_SHARP_2_24 -nowarn:0169,0612,0618 -unsafe -out:art-sharp.dll -target:library -r:/usr/lib/pkgconfig/../../lib/mono/gtk-sharp-2.0/pango-sharp.dll -r:/usr/lib/pkgconfig/../../lib/mono/gtk-sharp-2.0/atk-sharp.dll -r:/usr/lib/pkgconfig/../../lib/mono/gtk-sharp-2.0/gdk-sharp.dll -r:/usr/lib/pkgconfig/../../lib/mono/gtk-sharp-2.0/gtk-sharp.dll -r:/usr/lib/pkgconfig/../../lib/mono/gtk-sharp-2.0/glib-sharp.dll   -r:Mono.Cairo  generated/*.cs  AssemblyInfo.cs
AssemblyInfo.cs(6,11): warning CS1699: Use compiler option `keyfile' or appropriate project settings instead of `AssemblyKeyFile' attribute
generated/PixBuf.cs(27,25): error CS0234: The type or namespace name `DestroyNotifyInvoker' does not exist in the namespace `GtkSharp'. Are you missing an assembly reference?
Compilation failed: 1 error(s), 1 warnings
make[2]: *** [Makefile:628: art-sharp.dll] Error 1
make[2]: Leaving directory '/var/tmp/pamac-build-zaileion/gnome-sharp/src/gnome-sharp-2.24.4/art'
make[1]: *** [Makefile:450: all-recursive] Error 1
make[1]: Leaving directory '/var/tmp/pamac-build-zaileion/gnome-sharp/src/gnome-sharp-2.24.4'
make: *** [Makefile:378: all] Error 2
==> ERROR: A failure occurred in build().

Any chance banshee builds w/out gtk-sharp-3-mono-git? :crossed_fingers:

It’s really a shame to see such an excellent media program with every option under the sun from visualizations to media tagging, podcasts, internet radio, everything… just everything available in a single app, even stuff you didn’t know you wanted until you’ve tried Banshee. Just gone by the wayside. I can’t imagine why someone didn’t pickup the development of this awesome program. It is by far the single best media management application ever created.