Trying to boot right in with no password

Just a heads up. My new system is rpi4 KDE-Plasma.

Used add/remove software and installed “user-manager-git 5.19.90” then reboot

then went to system settings/personalization/new user manager icon added here. then I ticked the box inside - to boot with no password. Rebooted.

On reboot system crashed in screen area where it usually asks for password to continue (its a black screen here but was watching where it froze) ctl-alt-f2 did nothing ctr-alt-del would reboot again and crash again at the same spot. Lucky for me I cloned a duplicate copy yesterday so saved my work. Looking around I notice that others have also had a similer problem when trying to boot right in with no password. Manjaro works great on RPI4 and I’m loving it. Very nice indeed, puts the fun back in. Hope this is useful. Cheers…Dave


Did you tried the auto login in the system settings?
I use the auto login on my kde arm devices since 2 years…
In the past I had some auto login trouble, but not for the moment.

1 Like

Yes I tried that a couple of times. I went right in on boot but then a password was requested.

What you want is autologin, like mentioned.

The password it then asks you, is probably the kwallet/kded5 stuff, which needs to be unlocked by user authentication. This is usually done by user login, but since you skip that part, you are getting asked for that info right after.

PS: By installing user-manager-git you might have borked your install, which is now using a mix of regular and -git packages.

Hi. I’m not familiar with the kwallet/kded5 stuff. I’m using a fresh Manjaro copy I made the day before so my install should be okay unless I did something prior. I think for now I’ll just type my password and hope a fix comes down the road. Thanks for the responses. Appreciated.

I decided to take another look at this and got it to work okay.

If anyone decides to do it this way please note: your modem password will not be encrypted after this - see below) Here goes.

System Settings, startup & shutdown
tick both boxes - automatically log in - and log in again immediately
This boots right into the desktop no password required BUT now Kwallet asks for your wireless modem password. MAKE SURE you know your modem password beforehand.

Now open - sudo nano ~/.config/kwalletrc it already shows

First Use=false (keep this)

now add
Enabled=false (save and exit)

now select
System Settings, network connections, wi-fi modem, then select “Wi-Fi sec…”

Type in your Wi-Fi modem password and select Store passwords for all users (not encrypted) Note: the encrypted one did not work for me.
Thats it. Works for me and I’m okay with the no encryption part.
Hope this helps someone.
Thanks to all for the info supplied. Thumbs way up Manjaro KDE-Plasma. Loving it.

1 Like

Thanks a lot for your feedback :-)