Troubleshotting with drivers

Some time ago started to “crash” my computer it happens to often when I use skype but without too.
When it crash my main screen goes black and stop detecting it and the second monitor frezzes and show the last thing it was showing. The music, skype audio keeps working but keyboard stop too. I’ve ask for help in reddit and It looks like it’s problem with drivers.
inxi -Fazy result


Kernel: 5.8.6-1-MANJARO x86_64 bits: 64 compiler: N/A

parameters: BOOT_IMAGE=/boot/vmlinuz-5.8-x86_64

root=UUID=819b66c2-eccf-43ad-99f0-26e212acc03a rw quiet apparmor=1

security=apparmor resume=UUID=4685883e-7682-4292-b29d-3125cbad0951


Desktop: KDE Plasma 5.19.5 tk: Qt 5.15.0 wm: kwin_x11 dm: SDDM

Distro: Manjaro Linux


Type: Desktop Mobo: Gigabyte model: B85M-HD3 v: x.x serial: <filter>

UEFI: American Megatrends v: FF date: 06/19/2014


Topology: Quad Core model: Intel Core i5-4590 bits: 64 type: MCP

arch: Haswell family: 6 model-id: 3C (60) stepping: 3 microcode: 28

L2 cache: 6144 KiB

flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx

bogomips: 26349

Speed: 3668 MHz min/max: 800/3700 MHz Core speeds (MHz): 1: 2686 2: 2750

3: 3060 4: 1791

Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled

Type: l1tf

mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled

Type: mds mitigation: Clear CPU buffers; SMT disabled

Type: meltdown mitigation: PTI

Type: spec_store_bypass

mitigation: Speculative Store Bypass disabled via prctl and seccomp

Type: spectre_v1

mitigation: usercopy/swapgs barriers and __user pointer sanitization

Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,

IBRS_FW, STIBP: disabled, RSB filling

Type: srbds mitigation: Microcode

Type: tsx_async_abort status: Not affected


Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics

vendor: Gigabyte driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:0412

Device-2: NVIDIA GK104 [GeForce GTX 770] vendor: Gigabyte driver: nvidia

v: 450.66 alternate: nouveau,nvidia_drm bus ID: 01:00.0 chip ID: 10de:1184

Display: x11 server: X.Org 1.20.8 compositor: kwin_x11

driver: modesetting,nvidia alternate: fbdev,intel,nouveau,nv,vesa

display ID: :0 screens: 1

Screen-1: 0 s-res: 3200x1080 s-dpi: 91 s-size: 891x301mm (35.1x11.9")

s-diag: 940mm (37")

Monitor-1: DVI-D-0 res: 1920x1080 dpi: 92 size: 531x298mm (20.9x11.7")

diag: 609mm (24")

Monitor-2: VGA-1-1 res: 1280x1024 dpi: 96 size: 338x270mm (13.3x10.6")

diag: 433mm (17")

OpenGL: renderer: GeForce GTX 770/PCIe/SSE2 v: 4.6.0 NVIDIA 450.66

direct render: Yes
Audio ... skyped


Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet

vendor: Gigabyte driver: r8169 v: kernel port: d000 bus ID: 03:00.0

chip ID: 10ec:8168

IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: <filter>


Local Storage: total: 1.49 TiB used: 115.40 GiB (7.6%)

SMART Message: Unable to run smartctl. Root privileges required.

ID-1: /dev/sda vendor: Seagate model: ST3500412AS size: 465.76 GiB

block size: physical: 512 B logical: 512 B speed: 3.0 Gb/s

rotation: 5900 rpm serial: <filter> rev: CC32 scheme: MBR

ID-2: /dev/sdb vendor: Western Digital model: WD6400AAKS-22A7B0

size: 596.17 GiB block size: physical: 512 B logical: 512 B speed: 3.0 Gb/s

serial: <filter> rev: 3B01 scheme: GPT

ID-3: /dev/sdc vendor: Samsung model: SSD 860 EVO 500GB size: 465.76 GiB

block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s serial: <filter>

rev: 1B6Q scheme: GPT


ID-1: / raw size: 448.38 GiB size: 440.34 GiB (98.21%)

used: 115.40 GiB (26.2%) fs: ext4 dev: /dev/sdc2


Kernel: swappiness: 60 (default) cache pressure: 100 (default)

ID-1: swap-1 type: partition size: 17.09 GiB used: 0 KiB (0.0%) priority: -2

dev: /dev/sdc3


System Temperatures: cpu: 34.0 C mobo: N/A gpu: nvidia temp: 39 C

Fan Speeds (RPM): N/A gpu: nvidia fan: 18%


Processes: 190 Uptime: 1h 16m Memory: 15.53 GiB used: 2.73 GiB (17.5%)

Init: systemd v: 246 Compilers: gcc: 10.2.0 Packages: 1391 pacman: 1383

lib: 418 flatpak: 0 snap: 8 Shell: Bash v: 5.0.18 running in: konsole

inxi: 3.1.05

These are my drivers currently installed:

  • video-hybrid-intel-nvidia-450xx-prime
  • video-nvidia-450xx
  • video-modesetting

I don’t know how to choose which one to use or to remove. I tried to remove the prime one(i think it’s the one giving problems) but without success.
I tried removing them by manjaro hardware software and manualy with the guide on the wiki( Configure NVIDIA (non-free) settings and load them on Startup) and this is the result:
I can’t upload embed images but it shows that the comands

  • sudo mhwd -r pci video-nvidia
    doesn’t work it shows it doesn’t exist.

What can i do now?

You have 2 GPUs … its the nvidia alone one you need to remove.
Prime you need because of your hybrid system.

Because it doesnt.
As shown by your output above video-nvidia-450xx does exist though.

So … remove that, and to be safe reinstall prime again:

sudo mhwd -r pci video-nvidia-450xx
sudo mhwd -f -i pci video-hybrid-intel-nvidia-450xx-prime
1 Like

This don’t work to me

$ sudo mhwd -r pci video-nvidia-450xx
Removing video-nvidia-450xx…
Sourcing /etc/mhwd-x86_64.conf
Has lib32 support: true
Sourcing /var/lib/mhwd/local/pci/video-nvidia-450xx/MHWDCONFIG
Processing classid: 0300
Sourcing /var/lib/mhwd/scripts/include/0300
Processing classid: 0302
comprobando dependencias…
error: no se pudo preparar la operación (no se pudieron satisfacer las dependencias)
:: quitando nvidia-450xx-utils se rompe la dependencia con «nvidia-utils», necesaria para el paquete nvidia-prime
Error: pacman failed!
Error: script failed!

Then I realized to try to remove nvidia-utils but before I need to remove nvidia-prime. And after this finally I can remove it. And It leaves this packages installed .What are this?

$ sudo pacman -Q |grep nvidia
mhwd-nvidia-340xx 340.108-1
mhwd-nvidia-390xx 390.132-1
mhwd-nvidia-418xx 418.113-1
mhwd-nvidia-430xx 430.64-1.0
mhwd-nvidia-435xx 435.21-1.0
mhwd-nvidia-440xx 440.100-1
mhwd-nvidia-450xx 450.66-1

By the moment I hasn’t crash. God bless you.

Edit: It keeps crashing at least using skype.
Maybe I should create another post on “Software” or keep the thread here.?
Edit 2 : It happens the same using zoom . I am realising It could be problem of the webcam or the sharing window.
Edit 3 : I think it’s problem of the webcam driver but I don’t find which one is using.
I found in an arch guide that a module of webcam should be added to /etc/modules-load.d/webcam.conf but It doesn’t exist in my computer. Does it matter?ñol)

Looks like a case of this:

It could also likely be your drivers. Maybe get that fixed first.