Troubleshooting usb-c with dp alt mode malfunction

I’ve bought a widescreen office monitor with usb-c hub functionality: Samsung C34H890WGR

I’ve got my peripherals connected to the monitor. It worked like a charm for a couple of days.

Last night I left the laptop connected to the monitor and put it in sleep mode, then went to bed.

Now It’s stopped working entirely, and I’m at a loss after trying to troubleshoot for a couple hours.

The issues / things I’ve found:

  1. When connected to my laptop, the peripherals connected to the monitor work just fine. So data input works as intended, but not video.
  2. On the display configuration screen in settings, the monitor is detected with erroneous information:

Note that the settings identify it as a 1024x768 screen, when the real resolution is 3440x1440. It also says the only permitted refresh rate for the screen is 60hz, when it really is a 100hz screen.

  1. Once, running xrandr caused the connected monitor to start flickering horribly, sometimes flashing a heavily distorted image of my pc’s background. This has not happened again since.

  2. Occasionaly the monitor flashes “check usb-c cable”.

EDIT: I found the small screen. It’s on the login page, overlayed over the actual login page. Apologies for phone picture of screen:

When logging into the session, it disappears. I’m gonna guess this is some weird config issue.

Here’s the output of xrandr:

Screen 0: minimum 320 x 200, current 2944 x 1080, maximum 16384 x 16384
eDP-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 309mm x 173mm
   1920x1080     60.01*+  60.01    59.97    59.96    59.93    40.00  
   1680x1050     59.95    59.88  
   1400x1050     59.98  
   1600x900      59.99    59.94    59.95    59.82  
   1280x1024     60.02  
   1400x900      59.96    59.88  
   1280x960      60.00  
   1440x810      60.00    59.97  
   1368x768      59.88    59.85  
   1280x800      59.99    59.97    59.81    59.91  
   1280x720      60.00    59.99    59.86    59.74  
   1024x768      60.04    60.00  
   960x720       60.00  
   928x696       60.05  
   896x672       60.01  
   1024x576      59.95    59.96    59.90    59.82  
   960x600       59.93    60.00  
   960x540       59.96    59.99    59.63    59.82  
   800x600       60.00    60.32    56.25  
   840x525       60.01    59.88  
   864x486       59.92    59.57  
   700x525       59.98  
   800x450       59.95    59.82  
   640x512       60.02  
   700x450       59.96    59.88  
   640x480       60.00    59.94  
   720x405       59.51    58.99  
   684x384       59.88    59.85  
   640x400       59.88    59.98  
   640x360       59.86    59.83    59.84    59.32  
   512x384       60.00  
   512x288       60.00    59.92  
   480x270       59.63    59.82  
   400x300       60.32    56.34  
   432x243       59.92    59.57  
   320x240       60.05  
   360x202       59.51    59.13  
   320x180       59.84    59.32  
DP-1 connected 1024x768+1920+0 (normal left inverted right x axis y axis) 797mm x 333mm
   1024x768      60.00* 
   832x624       74.55  
   800x600       72.19    75.00    60.32    56.25  
   720x576       50.00  
   720x480       60.00    59.94  
   640x480       75.00    72.81    66.67    60.00    59.94  
   720x400       70.08  
HDMI-1 disconnected (normal left inverted right x axis y axis)
HDMI-2 disconnected (normal left inverted right x axis y axis)

Things I have tried:

  1. Full system update + restart
  2. Changing the usb-c cable
  3. Restarting the monitor
  4. Switching between proprietary and open source video drivers (no effect)
  5. Switching to wayland from x11 (no effect).

One thing to note is that after restarting the first time, the taskbar stopped working. I solved this after following this advice:

This mentioned that it was because the config file got corrupted because of some monitor shenanigans. Could the monitor not working be a similar issue? Is it hardware?

Any input is appreciated.

I’ve now tried following this guide: Adding undected resolutions.

This did not work with output:

xrandr --output DP-1 --mode 3440x1440_60.00 --verbose                                                                                                                                              1 ✘ 
screen 0: 3440x1440 907x380 mm  96.25dpi
crtc 1: 3440x1440_60.00  59.94 +0+0 "DP-1"
xrandr: Configure crtc 1 failed
crtc 0: disable
crtc 1: disable
crtc 2: disable
screen 0: revert
crtc 0: revert
crtc 1: revert
crtc 2: revert

For reverting monitor settings, most posts talk about editing/deleting ~/.config/monitors.xml but this file does not exist on my machine. I’ve also looked in /etc/X11/xorg.conf.d/ but no monitor config is there either.

I’ve now confirmed it’s a broken configuration by making a new user. So now it’s all about finding that broken configuration file and deleting/modifying it. My google-fu has been insufficient in finding where this could be, as my previous posts show.

So now the only help I request is, how do I manage to fix these settings?

Finally found the right config files to delete to remove the broken configs. It was from this one:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.