Troubleshooting USB 3.0 Ethernet adapter

I’ve been struggling to use an USB 3.0 Ethernet adapter for that last few days on my PC (running latest stable Manjaro). The adapter is D-Link DUB-1312.

The adapter works perfectly only on USB 2.0 port (not SS). On USB3 port, LED indicators are working (power + 1G speed), but Manjaro doesn’t recognize it at all. lsusb returns the same state, nothing new on dmesg and journalctl (if it’s relevant). ifconfig returns the same data, no new interface.

Things I’ve tried so far:

  • Different USB3 ports
  • modprobe ax88179_178a
  • Disable auto suspend for USB ports
  • Different Ethernet cable.
  • Other devices work on ports I’ve tried

Does anyone have an idea what could be wrong?


:+1: Welcome to Manjaro! :+1:

  1. Please read this:
    [HowTo] Provide System Information
    and press the three dots below your post and press the :pencil2: to give us more information so we can see what’s really going on.
    Now we know the symptom of the disease, but we need some more probing to know where the origin lies… :grin:
  2. An inxi --admin --verbosity=7 --filter --no-host --width would be the minimum required information for us to be able to help you. (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)
    Also, please copy-paste that output in-between 3 backticks ``` at the beginning and end of the code/text.


P.S. If you want to notify me that you did provide this information, please :heart: this message and I’ll come back and have another look.