Troubles with setting up WOL

So I was on the Arch Wiki page with WOL set up and they said I can install wol-systemd to make this stuff automatic. The thing is that it is not working(or I didn’t understand it)
So I did sudo ethtool -s enp3s0 wol g and then I checked if it worked by putting pc to sleep and I tried to wake it from my phone (as I did always it on WIndows) but it didn’t do anything. Then I installed wol-systemd and typed sudo systemctl enable wol@enp3s0.service and sudo systemctl start wol@enp3s0.service and then checked it by sudo ethtool enp3s0 | grep Wake-on and it showed that Wake-on: g which is good but then again if I tried to wake it from sleep it didn’t do anything again.
Do I need to do something more, or did I messed up with something?
Also anytime I check stuff with ethtool it says: netlink error: No such file or directory, is this important?

1 Like

I feel your pain, took me a while to have it working :sweat_smile:
Did you check the config on NetworkManager, like
nmcli c show "Wired_1" | grep 802-3-ethernet.wake-on-lan ?

Here is the simplest fix for WoL under Manjaro 21.0.3 (XFCE Desktop)
I have spent days on the problem.
But after getting Mint to work, I knew that it HAD be possible under Manjaro/Arch.

Here’s the solution - and it is VERY simple.
Make sure that the BIOS is set up for WoL - (for onboard LAN) usually means setting it to allow boot from PCie.

Boot Manjaro and disable TLP by entering this command in a terminal:-
systemctl disable tlp
You can confirm that it has been disabled with this command:-
systemctl is-enabled tlp

TLP is for power management on laptops etc.
It is unlikely that you will need TLP on a system that you want to be able to remotely start a machine.

Then run the Advanced Network Configuration from the Whisker Menu
Wired Connection 1
Ethernet
Wake on LAN
Select Magic only (from Default)

Reboot (don’t shut down yet)
Recheck that TLP is still disabled
systemctl is-enabled tlp

Now you can power off (use the XFCE power off window as usual)

It should now be possible to start the system using “magic packets”.
Magic packets only use the MAC address and the local IP broadcast address (eg 192.168.1.255)
I use my DD-WRT router to send the magic packets.

This works from a clean install of Manjaro and from a system that I’ve been running for the last 3 months (with all the current upgrades).

I hope that helps people.

Now I can continue on with Manjaro - I didn’t want to go back to Mint.

3 Likes

I went through the same path as you and lost a lot of time trying to figure out why Manjaro was cutting the power to the network card (the LEDs turned off) on shutdown and on sleep, even though I enabled Wake-On-LAN through ethtool:

I fixed it with the instructions on this post:

I’m not sure why TLP is enabled by default on desktops. I don’t know the extent of it’s functionalities or if there are useful functionalities for desktops.

1 Like

Damn ! Thank you, this was the fix for me after HOURS of trial and error !
Disabling tlp.service did the trick !