Trouble updating Manjaro

Please check out this thread, this question is a follow-up.

Previously, I had the following error:

[ FAILED ] Failed to start Simple Desktop Display Manager.
See 'systemctl status sddm.service' for details.

I fixed it with the amazing help of this community. But ever since then, I didn’t update my laptop fearing the same issue might happen again. I know it’s not safe and is very risky, so today I decided to get rid of the fear and update Manjaro.

What happened? I ran into the exactly same issue. My laptop got stuck again during boot-up with the same message. However, I fixed it by following the same steps and everything’s fine again.

But I am not sure how to fix this, I believe if I update again I’ll run into the same issue. Now I cannot just not update Manjaro and that possibility is ruled out. So I’d like to fix this problem once and for all, permanently.

I’d appreciate help on this since I have no clue on how I could go about solving this issue.

Thank you for your timely help! :blush:

Please run inxi -Gazy and head -n 1K /etc/X11/xorg.conf /etc/X11/xorg.conf.d/*. Are there Xorg logs in /var/log/ or ~/.local/share/xorg/?

Thank you for helping again @pobrn!

I don’t have the xorg.conf file present in the /etc/X11/. I had deleted the file (as mentioned in the thread) when I fixed up the same issue again. But please find the rest of the files and their outputs below.

inxi -Gazy:

  Device-1: Intel UHD Graphics 630 vendor: Acer Incorporated ALI driver: i915 
  v: kernel bus ID: 00:02.0 chip ID: 8086:3e9b 
  Device-2: NVIDIA TU116M [GeForce GTX 1660 Ti Mobile] 
  vendor: Acer Incorporated ALI driver: nvidia v: 450.66 
  alternate: nouveau,nvidia_drm bus ID: 01:00.0 chip ID: 10de:2191 
  Device-3: Chicony HD User Facing type: USB driver: uvcvideo bus ID: 1-7:4 
  chip ID: 04f2:b64f serial: <filter> 
  Display: x11 server: X.Org 1.20.8 compositor: kwin_x11 
  driver: modesetting,nvidia display ID: :0 screens: 1 
  Screen-1: 0 s-res: 3839x1200 s-dpi: 75 s-size: 1303x407mm (51.3x16.0") 
  s-diag: 1365mm (53.7") 
  Monitor-1: HDMI-0 res: 1920x1200 hz: 60 dpi: 94 size: 518x324mm (20.4x12.8") 
  diag: 611mm (24.1") 
  Monitor-2: eDP-1-1 res: 1920x1080 hz: 144 dpi: 128 
  size: 382x215mm (15.0x8.5") diag: 438mm (17.3") 
  OpenGL: renderer: GeForce GTX 1660 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 450.66 
  direct render: Yes 


# Read and parsed by systemd-localed. It's probably wise not to edit this file
# manually too freely.
Section "InputClass"
        Identifier "system-keyboard"
        MatchIsKeyboard "on"
        Option "XkbLayout" "us"
        Option "XkbModel" "pc105"
#adjust BusID to match your nvidia GPU
#uncomment and edit the DPI option as needed
#to fix scaling issues.

Section "Module"
    Load "modesetting"

Section "Device"
    Identifier "nvidia"
    Driver  "nvidia"
    BusID   "PCI:1:0:0"
    #Option  "DPI" "96 x 96"    #adjust this value as needed to fix scaling
    Option  "AllowEmptyInitialConfiguration"

Section "Extensions"
    Option  "Composite" "Enable"

There’s the following Xorg logs in /var/log/:

/var/log/Xorg.0.log  /var/log/Xorg.0.log.old  /var/log/Xorg.1.log  /var/log/Xorg.1.log.old

Since the files are large, I’ve attached each of them using pastebin below:

There’s the following Xorg logs in ~/.local/share/xorg:

Xorg.0.log  Xorg.0.log.old

The files using pastebin:

What exactly did you do to solve the problem? And what’s the output of sudo mhwd -li?

I ran the exact same steps that were mentioned in the thread, specifically, I ran the following commands:

$ cp -r /etc/X11 X11-backup    # backup the X11 folder
$ sudo mhwd -r video-hybrid-intel-nvidia-450xx-prime    # delete the nvidia prime
$ cd ~/optimus-switch
$ chmod +x ./
$ sudo ./                   # uninstall optimus switch
$ sudo mhwd -i pci video-hybrid-intel-nvidia-450xx-prime    # install nvidia-450xx-prime

After this, I rebooted my laptop and everything was working fine again.

It was then time for some cleanup. I copied the backup after which I cleaned up the /etc/X11/ directory:

$ mv X11-backup /etc/X11    # copy the backup
$ rm xorg.conf.nvidia-xconfig-original    # delete the xorg.conf
$ rm -rf xorg.conf.d/99-nvidia.conf    # delete all files from xorg.conf.d except 00-keyboard.conf

I then reinstalled optimus-switch:

$ git clone
$ chmod +x ./
$ sudo ./

And everything is back to normal again. However, I do think if I update Manjaro I will run into the same issue again.

Output of sudo mhwd -li:

> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
     video-modesetting            2020.01.13                true            PCI
video-hybrid-intel-nvidia-450xx-prime            2019.10.25               false            PCI

Warning: No installed USB configs!