Trouble installing pyrenamer via debtap

There are my first steps in Manjaro, so sorry for to easy questions.

I have to install pyrenamer app.

ftp br debian org/debian/pool/main/p/pyrenamer/pyrenamer_0.6.0-1.2_all.deb

This is deb so I did:

debtap pyrenamer_0.6.0-1.2_all.deb
sudo pacman -U pyrenamer-0.6.0-1-any.pkg.tar.zst

but the error message is

unable to satisfy dependency ‘python27’ required by pyrenamer

pyrenamer need python 2.7 but how to install it?
I can’t find it in pacman repository.

PS Krename, bulk rename, gprename don’t suit me.

sudo pacman -S python2
doesn’t work?

python27 is a Debian package, ours is called python2. That’s the problem with using debtap, it doesn’t always work right.

Since it’s a Python package, you could install it in a virtual environment.

What do you meann “virtual env”?
Debian Linux in virtual box or something other?

I run

sudo pacman -S python2
sudo pacman -S python2-setuptools
sudo pacman -S python2-pip

but I get still the same error:

sudo pacman -U pyrenamer-0.6.0-1-any.pkg.tar.zst
loading packages…
resolving dependencies…
warning: cannot resolve “python27”, a dependency of “pyrenamer”
:: The following package cannot be upgraded due to unresolvable dependencies:

:: Do you want to skip the above package for this upgrade? [y/N] N
error: failed to prepare transaction (could not satisfy dependencies)
:: unable to satisfy dependency ‘python27’ required by pyrenamer

Nothing to do with Debian, pyrenamer is a Python package. See: Installing packages using pip and virtual environments

You probably can edit the
file (inside your downloaded Debian package)
and adjust the required python version from 2.7 to just 2
so it matches the name of what is now installed

debtap uses the information in that DEBIAN/control file
Perhaps you get prompted to edit it before running debtap on the package?
Otherwise, you can unpack the Debian package
and either move the files “by hand”
or edit and then re-create the package after having edited that file.

Or just force install the package - it should work.

I tried to do it manually but it seems that pyrenamer doesn’t “see” python2 env. but only python3.

File “/usr/bin/pyrenamer”, line 28
print “PyGtk 2.0 or later required for this app to run”
SyntaxError: Missing parentheses in call to ‘print’. Did you mean print(“PyGtk 2.0 or later required for this app to run”)?

that error is related to PyGtk - not to python 2

This could (probably) be resolved in a similar way - I don’t know.
I have no experience in setting up and using two different python major versions simultaneously.
What @Yochanan said is probably applicable and the way to go.

I’d choose a different tool - one that is current.

But I don’t know what it is about this one that is so special that you want to keep using it.

You’re trying to run it with Python 3, hence the problem.