Trouble installing Manjaro KDE on PC build with Nvidia 1050 TI

Ok here’s what I got:

    Booting a command list
error: file '/boot/vmlinuz-' not found.
error: you need to load the kernel first.

Press any key to continue...

lol… $version is a placeholder, since I have no idea which version is there…

I ran it again just to make sure i entered it correctly (it was version $2) and it just gave a black screen.

I’m running that same Graphic card plugged into an older Acer motherboard with no issues.If you know the card is plugged in and working I’d suggest making sure something in the BIOS settings isn’t set wrong.You might try setting the BIOS back to default then see what happens.Also make sure secure boot and fast boot are not enabled.

Yeah I’ve looked thru the BIOS and fiddled with the settings, just set it back to default and no dice. Secure boot and fast boot are both disabled as well.

Tried to update your BIOS?

Tried to rewrite the USB stick after verifying the ISO is not corrupt?

You can also try the LTS minimal ISO with an older Kernel just to see if it boots with that. If it works maybe generate yourself a full ISO on GitHub following the instructions in the video and just changing the kernel to “linux54” instead of “linux513” Building your custom Manjaro ISO via Github Actions CI - YouTube

Ok so I was able to install Manjaro using the USB stick with the LTS minimal ISO paired with the command, (which is now also in the etc/default/grub file) but for some reason plasmashell isn’t starting. When I try and start it, it gives a TON of debug messages, ended with this:

terminate called after throwing an instance of 'std::runtime'
    what(): random_device: rdrand failed

anyone know what this error message means? i also have log files from dmesg and journalctl if you need info from those

Ok so I was able to build an ISO using the guide provided. Unfortunately, it stops at the

[OK] Reached target Graphical Interface

part whether launching with proprietary or open-source drivers. The does allow me to boot to a command line. I totally forgot about trying the

cat /var/log/Xorg.0.log | less

command, so I did. Unfortunately, it gave nothing. Also, when I try and start the SDDM, which seems to not be working upon sending the startx command, and when I try and launch it manually I get this error message:

x sddm.service - Simple Desktop Display Manager
    Loaded: loaded (/usr/lib/systemd/system/sddm.service; enabled; vendor preset: disabled) 
    Active: failed (Result: core-dump) since Fri 2021-08-20 20:59:24 UTC; 49s ago 
        Docs: man: sddm (1)
    Process: 2524 ExecStart=/usr/bin/sddm (code=dumped, signal=ABRT)
    Main PID: 2524 (code-dumped, signal=ABRT) 
    CPU: 22ms
Aug 20 20:59:24 manjaro systemd[1]: sddm.service: Scheduled restart job, restart counter is at 2.
Aug 20 20:59:24 manjaro systemd[1]: Stopped Simple Desktop Display Manager. 
Aug 20 28:59:24 manjaro systemd[1]: sddm.service: Start request repeated too quickly.
Aug 20 20:59:24 manjaro systemd[1]: sddm.service: Failed with result 'core-dump'.
Aug 20 20:59:24 manjaro systemd[1]: Failed to start Simple Desktop Display Manager.

So at this point there are 2 problems; when booting normally, it gets stuck on the “reached target graphical interface”, and when booting with the multi-user thing, it fails to start SDDM at all. Any ideas?

Looks like sddm tries to start, but repeated too often. Therefore it stopped. It seems the GPU initialize slow and sddm does not wait for it.

Are you really sure, there is only the nvidia card available?

inxi -Gazy

A workaround could be:

Replace MODULES=() with:

MODULES=(nvidia nvidia_drm nvidia_uvm nvidia_modeset)

at /etc/mkinitcpio.conf

Then run sudo mkinitcpio -P to update the initramfs.

i915 → intel driver

Ok so I was able to get the LTS minimal ISO installed. Unfortunately, on tty1 it gets stuck on the “clean…files…blocks” screen, so I have to launch tty2, run “startx”, and still SDDM doesn’t start. I tried the MODULES=(nvidia nvidia_drm nvidia_uvm nvidia_modeset) thing, (along with updating the initramfs) but that didn’t fix it :confused:

I think the issue at this point is clearly SDDM, but what options are left?

that is clear. SDDM won’t start if you run startx, but starts KDE directly. SDDM starts with this:

sudo systemctl start display-manager.service

If you run the xserver as normal user, then the Xorg.0.log should be located here:


or search it:

find /home/$USER -name "*Xorg*"

This log is important in your situation.

ahhh ok that makes sense.

I ran this in tty2 upon boot but it gave a fatal error.

I found the Xorg.0.log, what should I be looking for?

  • (EE) Error messages
  • What it loads…
  • Where it stops…

Just post it here…

This will upload it and print a short url:

cat ~/.local/share/xorg/Xorg.0.log | curl -F'file=@-'

here you go:

I searched for (EE) already and the two that are on there were related to my keyboard and mouse

Strange… the log says that it is working… at least the xserver.

Could you try start it like this:

startx /usr/bin/startplasma-x11

and check the Xorg log again…
This one:


or this one:


No idea where the current one will be written.

here’s the new one after running that command

Could you please describe what you see, when you run this command? Actually the xserver has been started and is working.

So seems the problem is sddm or plasma/kde.

Ok so I get a splash screen, then it loads into KDE, except many things are missing. Manjaro Hello greets me, I can launch KRunner, but I can’t open the application launcher, there’s no “taskbar” at the bottom like there is on all other fresh KDE installs. There’s a black wallpaper, right clicking on the blank space where the desktop would be doesn’t bring up a context menu. It seems that plasmashell just isn’t starting.

Since I am not a KDE User, I would search just like you would do. Maybe someone come with a proper idea.

Otherwise, try a different Desktop like Gnome or XFCE.

I tried booting a GNOME LTS ISO and that worked fine. On the KDE side, I was able to switch from SDDM to LightDM and now I can log in normally, but plasmashell still doesn’t start properly. I’m getting this rdrand failed error, and since I can’t find anything online with that error I’m going to start a new thread focusing on that issue. Thank you so much for all your help everyone, especially megavolt!

EDIT: To any future users who stumbled upon my post, it was a BIOS update that fixed everything! Never would have thought!